madshi bug tracker - madVR
View Issue Details
0000205madVRbugpublic2014-04-29 05:252015-03-22 16:04
dan 
madshi 
normalminoralways
closedfixed 
Win 7 SP1 x64
0.87.10
1.7.4 stable
LAV 0.61.2
LAV 0.61.2
Software
auto mode
no
On
all modes
AMD
HD4850
8.97.100.3-120703a-145534C-ATI
0000205: Subtitle disappears
This is a very specific bug, I was able to reproduce only on the exact following setup and file:
-using XySubFilter
-using madVR
-setting "optimize subtitle quality for performance instead of quality" checked.
-watching the following 1080p video: http://coalgirls.wakku.to/9037/princess-mononoke [^] (you'll also find other people reporting this problem in the comments)

The subtitles disappear when I go into fullscreen mode (at 1080p), on both Exclusive and Windowed modes. When not in FS they show up fine.

I have used this setting (XySubFilter + madVR with the setting mentioned checked for a long time, and never experienced such an issue with any other file).

I contacted XySubFilter's developer and he pointed me here as a madVR bug.
(the bug doesn't happen when using MPC-HC's internal EVR-CP renderer + XySubFilter).

Thanks.
-does not happen if the "optimize subtitle quality for performance instead of quality" setting is unchecked.
-does not happen using XySubFilter with MPC-HC's internal EVR-CP renderer.
-does not happen using madVR, with the setting "..." checked but using MPC-HC's internal subtitle renderer instead of XySubFilter.
No tags attached.
zip mad.zip (20,739) 2014-05-01 19:57
http://bugs.madshi.net/file_download.php?file_id=93&type=bug
? Nymphomaniac.Vol.I.2013.Blu.Ray.720p.CINEMANIA (1)-001.mkv (1,645,392) 2014-06-15 15:25
http://bugs.madshi.net/file_download.php?file_id=96&type=bug
zip madVR.reg.zip (15,095) 2014-06-15 15:26
http://bugs.madshi.net/file_download.php?file_id=97&type=bug
? 风之谷 (1280x690 - mod2 bug).mkv (2,376,034) 2014-07-19 13:15
http://bugs.madshi.net/file_download.php?file_id=102&type=bug
Issue History
2014-04-29 05:25danNew Issue
2014-04-29 07:07madshiNote Added: 0000629
2014-04-29 07:07madshiAssigned To => madshi
2014-04-29 07:07madshiStatusnew => feedback
2014-04-29 16:33cyberbeingNote Added: 0000630
2014-04-30 00:35danNote Added: 0000631
2014-04-30 00:35danStatusfeedback => assigned
2014-04-30 09:11madshiNote Added: 0000632
2014-05-01 04:25danNote Added: 0000633
2014-05-01 04:26danNote Edited: 0000633bug_revision_view_page.php?bugnote_id=633#r126
2014-05-01 09:07madshiNote Added: 0000634
2014-05-01 19:57danFile Added: mad.zip
2014-05-01 19:59danNote Added: 0000635
2014-05-01 19:59danNote Edited: 0000635bug_revision_view_page.php?bugnote_id=635#r128
2014-05-04 07:51danNote Added: 0000636
2014-06-15 15:24GCRaistlinNote Added: 0000640
2014-06-15 15:25GCRaistlinFile Added: Nymphomaniac.Vol.I.2013.Blu.Ray.720p.CINEMANIA (1)-001.mkv
2014-06-15 15:26GCRaistlinFile Added: madVR.reg.zip
2014-07-19 13:15cyberbeingFile Added: 风之谷 (1280x690 - mod2 bug).mkv
2014-07-19 13:18cyberbeingNote Added: 0000653
2015-02-24 02:56cyberbeingNote Added: 0000711
2015-03-22 16:04madshiNote Added: 0000811
2015-03-22 16:04madshiStatusassigned => closed
2015-03-22 16:04madshiResolutionopen => fixed

Notes
(0000629)
madshi   
2014-04-29 07:07   
Which exact chroma and image upscaling algorithms have you selected? And is image doubling active? How about debanding? I think this problem might perhaps only occur with specific settings...
(0000630)
cyberbeing   
2014-04-29 16:33   
I was troubleshooting this issue a bit with Dan via email, before he reported it here. On my NVIDIA + Win7 box, I was unable to reproduce this with the video he linked. Though it seems from the comment section of the website he linked, a couple other people are having the same issue.

The video in question is 1920x1038 (MOD2 height) 10-bit H.264.

Here is a small sample:
https://www.mediafire.com/?gndati69lwt17f6 [^]

Dan, please ensure you can still reproduce your issue with that sample.
(0000631)
dan   
2014-04-30 00:35   
Alright, let me summarize things:
-I can still reproduce the issue on the sample provided above.
-I tried applying the GDI32.dll hotfix (sent by email), it didn't help.

As for algorithms and other settings:

-For these tests I resetted my madVR settings to default through "restore default settings.bat", so just consider everything as default. Still reproduces the issue just like before (happens when "optimize subtitle..." is checked, but not when unchecked). If you still want to know the settings I generally use, please let me know and I'll provide them.

As for new useful information, I found this to be a regression from version 0.86.11 to 0.87.0: up to 86.11 it works fine, and starting from 87.0 the issue happens.

I realize this is a very isolated case, with an easy workaround (disabling the setting), so I'd understand if you wish to not seek this further, but if you do, let me know about any further testing that may help narrowing the problem and I'll be happy to do it.
(0000632)
madshi   
2014-04-30 09:11   
I definitely want this solved. Depending on a countless number of circumstances (like scaling settings, other settings, scaling factors, GPU manufacturer, OS, etc etc) madVR dynamically builds a custom rendering pipeline. It seems that in your specific cases this results in problems. I just hope I can reproduce it here somehow. Let's see...
(0000633)
dan   
2014-05-01 04:25   
(edited on: 2014-05-01 04:26)
Great!

Well, here's for some more testing then:
I experimented muxing the Sample and other files with the following configuration and results:

-Using the subs from the sample with another video/audio: the bug doesn't happen.

-Using subs/audio from another file (which works fine) with the video from the sample: the bug happens.

in both cases I muxed all the attached fonts as well, just to be safe.

It would seem that the font/subs used don't play a role in the reproduction of this bug, and that it's related to something on the video.

let me know if I can help with anything else.

(0000634)
madshi   
2014-05-01 09:07   
Could you please export your "HKEY_CURRENT_USER\Software\madshi\madVR" folder (regedit.exe) to a reg file, then zip that file and attach it to this bug report? Don't worry, no personal information stored there, just your exact madVR settings. Thanks.
(0000635)
dan   
2014-05-01 19:59   
Done.

These would be the settings I generally use (I've set them again), though the tests above were made using default setting (after resetting with the .bat). Happens in both cases.

(0000636)
dan   
2014-05-04 07:51   
Another finding:
-the bug doesn't happen when I have "reduce banding artifacts" on artifact removal activated.
-the bug happens with it deactivated.

naturally, I mean with "optimize subtitle quality for performance instead of quality" checked in both cases.

so now it's "reduce banding artifacts" UNchecked + "optimize subtitle..." Checked to trigger it.
This feature (or the option at least) was introduced in 0.87.* right?
(0000640)
GCRaistlin   
2014-06-15 15:24   
I also experience this issue. GF 8800 GT, driver v337.88, WinXP SP3. madVR settings and sample file attached.
(0000653)
cyberbeing   
2014-07-19 13:18   
wanezhiling just posted another example of this issue on Doom9, which I've attached.
(0000711)
cyberbeing   
2015-02-24 02:56   
madshi, is there any status on this issue?
(0000811)
madshi   
2015-03-22 16:04   
This should hopefully be fixed in the next build.