madshi bug tracker - madVR
View Issue Details
0000650madVRbugpublic2020-08-07 04:432020-08-10 05:34
TBlazeWarriorT 
 
normalcrashalways
newopen 
PC (GTX 750 1GB, i5 9400F, 16GB)WindowsWindows 10
0000650: 'ACESS VIOLATION' crash when "image upscaling = NGU sharp" and using SVP in fullscreen
Error message: https://imgur.com/5xOxmqR [^]
Happens when I turn this on: https://i.imgur.com/QKjBqNZ.png [^]
FFMPEG tooltip info: https://imgur.com/Fo98flk [^]

The playback always crashes, almost instantly when certain MadVR settings are on.
Seems to only happen when I have SVP on (SmoothVideoProject 4.0.0-6), I'm using MPC-HC 64-bit 1.9.6 and madVR 0.92.17.

This might be a SVP bug, but seems to be directly affected by madVR. I downloaded madVR and MPC-HC through the SVP mainteinance tool.

Seems related to http://bugs.madshi.net/view.php?id=527 [^]
The bug seems to only happen if I meet all 3 of the following requirements:
- Have SVP on (performing frame rate conversion)
- Have MPC-HC on a big window so upscaling kicks in (for example, fullscreen a 720p video)
- Have "Image Upscaling" set to "NGU Sharp" in settings
- Might only happen on my CPU/GPU setup (but probably affects all/most setups), can't test.

Closing SVP, watching in windowed mode, or changing Image Upscaling to Jinc either greatly lowers the chance for the crash to happen (like from 99% per second to 1%) or fully stops it (didn't test for long periods of time).
Error message: https://imgur.com/5xOxmqR [^]
Happens when I turn this on: https://i.imgur.com/QKjBqNZ.png [^]
FFMPEG tooltip info: https://imgur.com/Fo98flk [^]

I'm a basic user, I don't know what the decoding, splitter and decoder fields below are, I hope I typed the right thing but probably not. Don't know how to check.

RELATED TO: http://bugs.madshi.net/view.php?id=527 [^]
No tags attached.
Issue History
2020-08-07 04:43TBlazeWarriorTNew Issue
2020-08-07 04:49TBlazeWarriorTNote Added: 0002727
2020-08-07 08:48madshiNote Added: 0002729
2020-08-10 05:34TBlazeWarriorTNote Added: 0002730

Notes
(0002727)
TBlazeWarriorT   
2020-08-07 04:49   
The website duplicated my other issue ( http://bugs.madshi.net/view.php?id=651 [^] ). I tried to upload a text file, it said it wasnt published because .txt was invalid and asked me to press back on my browser and change it. I made minor changes to this bug report and submitted again, but then realized the website published both for some reason.
(0002729)
madshi   
2020-08-07 08:48   
Your GPU has rather little RAM, maybe that's causing the issue? I'm not sure, just guessing. You could try lowering the size of the CPU Queue and GPU Queue settings in the madVR settings under "rendering -> general settings".
(0002730)
TBlazeWarriorT   
2020-08-10 05:34   
Nope, GPU Queue at minimum (4) and CPU Queue at 8 (half the default, cause my CPU is decent) and it still crashes if I set Chroma Upscaling and Image Upscaling to something complex/heavy (maxed out NGU).
This time, it became a slideshow for a few seconds (MPC almost crashing, displaying 1 frame per second) and then crashed with the same error.
Using Jinc on both still works fine