madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000124madVRbugpublic2013-08-15 01:532014-07-28 08:31
Reporterdansrfe 
Assigned Tomadshi 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows 7 x64OSOS Version
Summary0000124: videoLUT not restored when dragging window between monitors
DescriptionThe videoLUT of the monitor which has disable gamma ramps enabled is not restored once the MPC-HC window is dragged to a different monitor. Another issue is that when dragging the MPC-HC window to a monitor that doesn't have disable gamma ramps enabled, madVR disables the gamma ramps anyways and neither does madVR restore the videoLUT after moving the window to another monitor.
Steps To Reproducedisable gamma ramps on one screen. don't disable gamma ramps on other screen(s). drag from one monitor to another in all combinations and enter/exit exclusive mode if need be.
Additional InformationThis problem occurs with all modes.
TagsNo tags attached.
madVR Version0.86.11
Media Player (with version info)MPC-HC latest nightly
Splitter (with version info)LAV Splitter latest
Decoder (with version info)LAV Video Decoder latest
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGTX 670
GPU Driver Versionlatest stable
Attached Files

- Relationships

-  Notes
(0000338)
dansrfe (reporter)
2013-08-28 21:29

Hi madshi, can you comment on this issue so that I know if I need to provide more information or if this is a non-issue.
(0000566)
madshi (administrator)
2014-04-02 17:22

Should be fixed in v0.87.9.
(0000573)
dansrfe (reporter)
2014-04-03 07:41
edited on: 2014-04-03 07:41

The videoLUT restoration problem has been solved however when a 3DLUT is selected to be loaded with the gamma ramps disabled and the window goes from overlay -> exclusive -> overlay there is a 3-5 second lag for the videoLUT to be restored on the monitor.

(0000584)
dansrfe (reporter)
2014-04-06 19:24
edited on: 2014-04-06 22:50

Also, when gamma ramps are disabled, 3DLUT is loaded, and the new windowed mode is selected, the videoLUT is removed. In overlay mode, it works as expected sans the delay to restore outlined above.

Also, is it possible to prevent loading of any other videoLUT from outside madVR while in FSE? As an extra precaution in case some profile loader reloads the desktop .icm it on a timed interval.

(0000606)
madshi (administrator)
2014-04-18 20:33
edited on: 2014-04-18 20:34

> there is a 3-5 second lag for the videoLUT
> to be restored on the monitor

There's a 3 second delay in updating the video luts when switching between windowed and exclusive mode, and when closing down. The reason for that is that there are certain situations (e.g. when skipping to the next video file in a play list) where without this 3 second delay the video luts would be switched back and forth and back again, which would produce a visible flickering. So I intentionally wait 3 seconds to gracefully cover these situations. So basically this is a feature, not a bug.

> Also, when gamma ramps are disabled, 3DLUT is
> loaded, and the new windowed mode is selected,
> the videoLUT is removed.

Ehm, yes, isn't that what's supposed to happen? I'm not sure I understand what you're saying...

> Also, is it possible to prevent loading of any
> other videoLUT from outside madVR while in FSE?

Possible? Yes. But actually preventing the loading of different video luts would be a quite heavy thing. It would require a kernel mode driver and a hook dll, which seems like overkill to me for such a small feature. So no, this is not something I'm planning to implement.

(0000655)
madshi (administrator)
2014-07-28 08:31

Closed due to lack of feedback.

- Issue History
Date Modified Username Field Change
2013-08-15 01:53 dansrfe New Issue
2013-08-28 21:29 dansrfe Note Added: 0000338
2014-04-02 17:22 madshi Note Added: 0000566
2014-04-02 17:23 madshi Status new => closed
2014-04-02 17:23 madshi Assigned To => madshi
2014-04-02 17:23 madshi Resolution open => fixed
2014-04-03 07:41 dansrfe Note Added: 0000573
2014-04-03 07:41 dansrfe Status closed => feedback
2014-04-03 07:41 dansrfe Resolution fixed => reopened
2014-04-03 07:41 dansrfe Note Edited: 0000573 View Revisions
2014-04-03 09:23 madshi Status feedback => assigned
2014-04-06 19:24 dansrfe Note Added: 0000584
2014-04-06 22:50 dansrfe Note Edited: 0000584 View Revisions
2014-04-18 20:33 madshi Note Added: 0000606
2014-04-18 20:33 madshi Note Edited: 0000606 View Revisions
2014-04-18 20:34 madshi Note Edited: 0000606 View Revisions
2014-04-18 20:34 madshi Status assigned => feedback
2014-07-28 08:31 madshi Note Added: 0000655
2014-07-28 08:31 madshi Status feedback => closed
2014-07-28 08:31 madshi Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker