madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000181madVRbugpublic2014-03-20 01:072015-04-01 16:08
Reporter6233638 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSWindows 8.1 ProOS Version6.3 (Build 9600)
Summary0000181: Tagging files with a deinterlacing type does not turn deinterlacing on
DescriptionIf you tag files with a deinterlacing mode (e.g. deint=video) it sets the mode but does not turn deinterlacing on.
 
If madVR does not think the file needs deinterlaced, it stays off and has to be manually enabled during playback.
TagsNo tags attached.
madVR Version0.87.17
Media Player (with version info)JRiver Media Center 20.0.84
Splitter (with version info)LAV Splitter 0.64.0
Decoder (with version info)LAV Video 0.64.0
DecodingDXVA2 Copyback
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modewindowed mode
GPU ManufacturerNVidia
GPU ModelGTX 570
GPU Driver Version347.52
Attached Filesrar file icon Logs.rar [^] (3,840,454 bytes) 2014-04-03 13:24
rar file icon Logs2.rar [^] (4,059,868 bytes) 2014-04-05 13:53
rar file icon Logs3.rar [^] (4,205,853 bytes) 2014-04-23 01:54

- Relationships

-  Notes
(0000545)
madshi (administrator)
2014-04-01 18:41

I can't reproduce the problem on my PC. Tagging a progressive file with "deint=video" turns video mode deinterlacing completely on. How can I reproduce the problem? I need a step-by-step guide, ideally with a sample which is properly named (including name tag etc).
(0000571)
6233638 (reporter)
2014-04-03 06:34

My deinterlacing settings are:

Automatically activate deinterlacing when needed; if in doubt, activate deinterlacing.
Disable automatic source type detection; force film mode.
Only look at pixels in the frame center.

Here is a 30s sample video which should make it obvious: http://www.sendspace.com/file/muqi67 [^]

Manually enabling deinterlacing during playback starts it in film mode, I have to switch it over to video.
(0000579)
madshi (administrator)
2014-04-03 12:44

I still cannot reproduce the problem on my PC. Your tag works perfectly here, using the same deint settings you're using.

Can you please upload a debug log, so that I can check if madVR can see the file name?

Please double check with MPC-HC, just to be safe. Must be something specific to your setup, I think. Works fine here with MC19, too, in any case...
(0000580)
6233638 (reporter)
2014-04-03 13:24

In MC19, deinterlacing is not being activated at all.
In MPC-HC, deinterlacing is being activated but it's using Film mode.
(0000583)
madshi (administrator)
2014-04-05 13:23

The logs clearly show that your bug report is valid. However, I don't really understand what's going on. Could you please create one more log with this new test build?

http://madshi.net/madVRwindowedTest.rar [^]

I've added some more log information, maybe it helps me finding out what's going on.
(0000589)
madshi (administrator)
2014-04-07 22:58

I've really confused by those logs, they make no sense to me. The "video" tag is clearly recognized and madVR does switch to video deinterlacing mode. But then a short time later it switches deinterlacing off again, and I've got no clue why. It looks like some internal variables suddenly change their value. Maybe it's some sort of buffer overrun problem or something.

Could you test some older builds to see which madVR build introduced the problem? Or did it always occur? FWIW, v0.85.4 was the first build with the new tagging system. Old versions available here:

http://www.videohelp.com/tools/madVR/old-versions#download [^]
(0000590)
6233638 (reporter)
2014-04-07 23:42
edited on: 2014-04-07 23:43

I did some testing, and it looks like any build prior to 0.87 when the profile system was introduced is working correctly.
If I remove my "SD" profile when using the current test build, the tags work as expected.
 
So it looks like madVR applies tags before profiles, and it should probably be the other way around.

(0000591)
madshi (administrator)
2014-04-07 23:46

Oh, that makes a lot more sense - you didn't mention before that you had different profiles for deinterlacing settings! So I know where to look now...
(0000592)
6233638 (reporter)
2014-04-07 23:55

It didn't occur to me that it would matter.
I can upload my settings if it helps, but they were set as described above.
(0000593)
madshi (administrator)
2014-04-08 00:03

Not necessary.
(0000605)
madshi (administrator)
2014-04-18 19:59

Should be fixed in v0.87.10.
(0000610)
6233638 (reporter)
2014-04-23 01:54

Unfortunately the fix in 0.87.10 doesn't seem to be working for me.

MPC-HC reports that video deinterlacing is being used, but I have to toggle film/video deinterlacing modes for the combing artifacts to disappear.
 
In JRiver MC19, deinterlacing still isn't being activated at all
(0000628)
madshi (administrator)
2014-04-25 13:42

Strange, I had tested it here and I was sure it was working. Will have to re-investigate...
(0000821)
madshi (administrator)
2015-03-22 19:33

It might make sense to try to reproduce this with exactly the settings you have and exactly one video file sample you're using, so that I can be sure that I'm seeing the same thing you're seeing. Could you provide me with your settings and one small sample? Thanks!
(0000897)
6233638 (reporter)
2015-03-30 20:11

Here's a sample, with my settings file: https://www.sendspace.com/file/rv54l8 [^]
(0000909)
madshi (administrator)
2015-03-31 21:08

Thanks. Should finally be fixed in the next build.
(0000911)
6233638 (reporter)
2015-04-01 15:46

Still broken in JRMC.
(0000912)
madshi (administrator)
2015-04-01 16:08

Oh man. I had this fix in v0.87.16, and then when searching for a different bug for v0.87.17, I temporarily disabled the fix for this. And then I forgot to remove the temp disabling, so it got permanent.

I've reenabled the fix in my sources again. So for v0.87.18 the fix should be active, again.

- Issue History
Date Modified Username Field Change
2014-03-20 01:07 6233638 New Issue
2014-04-01 18:41 madshi Note Added: 0000545
2014-04-01 18:41 madshi Assigned To => madshi
2014-04-01 18:41 madshi Status new => feedback
2014-04-03 06:34 6233638 Note Added: 0000571
2014-04-03 06:34 6233638 Status feedback => assigned
2014-04-03 12:44 madshi Note Added: 0000579
2014-04-03 12:44 madshi Status assigned => feedback
2014-04-03 13:24 6233638 Note Added: 0000580
2014-04-03 13:24 6233638 Status feedback => assigned
2014-04-03 13:24 6233638 File Added: Logs.rar
2014-04-05 13:23 madshi Note Added: 0000583
2014-04-05 13:24 madshi Status assigned => feedback
2014-04-05 13:53 6233638 File Added: Logs2.rar
2014-04-07 18:28 madshi Status feedback => assigned
2014-04-07 22:58 madshi Note Added: 0000589
2014-04-07 22:58 madshi Status assigned => feedback
2014-04-07 23:42 6233638 Note Added: 0000590
2014-04-07 23:42 6233638 Status feedback => assigned
2014-04-07 23:43 6233638 Note Edited: 0000590 View Revisions
2014-04-07 23:46 madshi Note Added: 0000591
2014-04-07 23:55 6233638 Note Added: 0000592
2014-04-08 00:03 madshi Note Added: 0000593
2014-04-18 19:59 madshi Note Added: 0000605
2014-04-18 20:00 madshi Status assigned => closed
2014-04-18 20:00 madshi Resolution open => fixed
2014-04-23 01:54 6233638 madVR Version 0.87.7 => 0.87.10
2014-04-23 01:54 6233638 Media Player (with version info) JRiver Media Center 19.0.121 => JRiver Media Center 19.0.129
2014-04-23 01:54 6233638 Splitter (with version info) LAV Splitter 0.61.1 => LAV Splitter 0.61.2
2014-04-23 01:54 6233638 Decoder (with version info) LAV Video 0.61.1 => LAV Video 0.61.2
2014-04-23 01:54 6233638 GPU Driver Version 327.23 => 337.50
2014-04-23 01:54 6233638 Note Added: 0000610
2014-04-23 01:54 6233638 Status closed => feedback
2014-04-23 01:54 6233638 Resolution fixed => reopened
2014-04-23 01:54 6233638 File Added: Logs3.rar
2014-04-25 13:42 madshi Note Added: 0000628
2014-04-25 13:42 madshi Status feedback => assigned
2015-03-22 19:33 madshi Note Added: 0000821
2015-03-22 19:33 madshi Status assigned => feedback
2015-03-30 18:49 6233638 Note Added: 0000892
2015-03-30 18:49 6233638 Status feedback => assigned
2015-03-30 18:54 madshi Status assigned => feedback
2015-03-30 20:11 6233638 Note Added: 0000897
2015-03-30 20:11 6233638 Status feedback => assigned
2015-03-30 20:12 6233638 Note Deleted: 0000892
2015-03-31 21:08 madshi Note Added: 0000909
2015-03-31 21:08 madshi Status assigned => closed
2015-03-31 21:08 madshi Resolution reopened => fixed
2015-04-01 15:46 6233638 madVR Version 0.87.10 => 0.87.17
2015-04-01 15:46 6233638 Media Player (with version info) JRiver Media Center 19.0.129 => JRiver Media Center 20.0.84
2015-04-01 15:46 6233638 Splitter (with version info) LAV Splitter 0.61.2 => LAV Splitter 0.64.0
2015-04-01 15:46 6233638 Decoder (with version info) LAV Video 0.61.2 => LAV Video 0.64.0
2015-04-01 15:46 6233638 GPU Driver Version 337.50 => 347.52
2015-04-01 15:46 6233638 Note Added: 0000911
2015-04-01 15:46 6233638 Status closed => feedback
2015-04-01 15:46 6233638 Resolution fixed => reopened
2015-04-01 16:08 madshi Note Added: 0000912
2015-04-01 16:08 madshi Status feedback => closed
2015-04-01 16:08 madshi Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker