madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000197madVRbugpublic2014-04-23 15:452015-03-22 11:44
Reporterromulous 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionunable to reproduce 
PlatformWindowsOSSevenOS Version64bit
Summary0000197: Massive Stuttering when Exiting FSE
DescriptionThis seems pretty random, but I thought I'd report it anyway, just in case you have any ideas.

I usually have FSE mode disabled in madVR. When 0.87.9 was released, I enabled it again just to check a couple of things. I noticed that after doing so, when I exited from FSE mode back to Zoom Player's normal windowed mode, the video clip I was playing started to badly stutter. Hitting Ctrl+J, I saw the dropped frames increasing rapidly.

I disabled FSE mode again, and problem disappeared. I have now updated to 0.87.10, and just to check, I enabled FSE mode again and I still see this behaviour with 0.87.10. Enable FSE, enter fullscreen mode in Zoom Player, wait a few seconds while the video plays a bit, exit from fullscreen mode back to windowed mode, and a few seconds later, the video starts to drop frames and stutter massively. It doesn't happen every single time unfortunately.

The only way to stop it doing this is to totally close the player. This only happens with FSE mode enabled in madVR. Because I have long had FSE mode disabled in madVR, I can't be sure that it started in 0.87.9 - .9 is just the build where I noticed it. It also doesn't happen with every video, but I have linked to a video below that I have seen it happen with on my system. I'm not sure if it is relevant or not, but when I enter FSE, if I check Ctrl+J, I see the Present Queue is 0-4/4. It never actually gets above 0 from what I can tell (until I exit back to windowed mode). Also note that the video does not stutter when I enter fullscreen mode - it plays normally until I exit back to windowed mode.
Steps To Reproduce1. Enable FSE mode in madVR.
2. Open a video file in Zoom Player, enter fullscreen (Alt+Enter). Sample video file that this issue occurs with: https://dl.dropboxusercontent.com/u/105555957/madVR%20Stutter%20Issue.mov [^]
3. Wait about 5-10 seconds for video to play a bit.
4. Exit fullscreen mode (Alt+Enter).
5. Wait about 5 seconds and the video will start to stutter badly, dropping frames.
Additional InformationFilter chain is LAV Splitter, LAV Audio, LAV Video (LAV Video in software mode).
TagsNo tags attached.
madVR Version0.87.10
Media Player (with version info)Zoom Player 9.0.1 MAX
Splitter (with version info)LAV 0.61.2
Decoder (with version info)LAV 0.61.2
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modefullscreen exclusive mode
GPU ManufacturerNVidia
GPU ModelGTX 660Ti
GPU Driver Version337.50
Attached Files

- Relationships

-  Notes
(0000611)
romulous (reporter)
2014-04-23 15:56

Just noticed one thing - and I think this explains the apparent randomness, as I can now reproduce it 100%. When I exit from fullscreen back to windowed, the video will play fine until I open part of the Zoom Player interface (eg right click the Zoom Player window to bring up the context menu, hit Space to bring up the control bar or hit I to bring up the Playing Information dialog).

As soon as Zoom's interface (eg context menu) displays, that is when the stuttering hits and madVR starts dropping frames.

If I open Zoom in windowed mode, start a video playing, and then open the interface (eg context menu), there is no problem. This only happens when:
1. Open Zoom, open a video and then enter fullscreen (Alt+Enter) with FSE enabled.
2. Return to windowed mode (Alt+Enter).
3. Bring up some part of the Zoom interface (eg right click the Zoom window to display the context menu).

After the stutter begins, closing the interface (eg the context menu) does not fix the problem - a full restart of the player is required to stop the stuttering. This happens regardless of whether Playback : Video > Display OSD through MadVR's OSD API (preserves fullscreen exclusive mode) is enabled, or disabled.
(0000617)
madshi (administrator)
2014-04-24 18:39

Can you please:

(1) Disable "windowed mode settings\present several frames in advance" and check if and how that changes the problem?
(2) Enable "general settings\enable windowed overlay" and check if and how that changes the problem?

At this point my experience tells me that this problem is probably caused by your OS/driver installation somehow. I think I will probably not be able to reproduce it. Such kind of issues usually only occur on some isolated PCs, for unknown reasons.

Anyway, let's still try to get to the bottom of this. If I get the answers to those 2 experiments mentioned above, I will try to reproduce the problem myself. But you may already prepare for the likely answer that I can't reproduce the issue and you may have to reinstall your OS at some point to get rid of this problem. This is just a guess at this point, though.
(0000627)
romulous (reporter)
2014-04-25 04:10
edited on: 2014-04-30 15:36

Hi madshi,

(1) Still occurs with that setting disabled. It might just be placebo, but the problem seems to be not quite as bad though I don't think - with present frames enabled, the stuttering is very noticeable. With it disabled, it is still badly stuttering, but doesn't seem quite as noticeable.

(2) Problem vanishes with overlay mode enabled - this is with the setting from (1) above re-enabled back to the default.

(0000774)
romulous (reporter)
2015-03-15 02:59

Don't seem to be able to reproduce this one any longer based on some quick testing, guess it can be closed.

- Issue History
Date Modified Username Field Change
2014-04-23 15:45 romulous New Issue
2014-04-23 15:56 romulous Note Added: 0000611
2014-04-24 18:39 madshi Note Added: 0000617
2014-04-24 18:39 madshi Assigned To => madshi
2014-04-24 18:39 madshi Status new => feedback
2014-04-25 04:10 romulous Note Added: 0000627
2014-04-25 04:10 romulous Status feedback => assigned
2014-04-30 15:35 romulous Note Edited: 0000627 View Revisions
2014-04-30 15:36 romulous Note Edited: 0000627 View Revisions
2015-03-15 02:59 romulous Note Added: 0000774
2015-03-22 11:44 madshi Status assigned => closed
2015-03-22 11:44 madshi Resolution open => unable to reproduce


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker