madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000198madVRbugpublic2014-04-23 22:442016-01-13 00:03
ReporterGCRaistlin 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformC2D E6420 @ 2.93 GHz / GF8800GTOSWinXPOS VersionSP3
Summary0000198: Interlaced video not detected automatically
Description[that's it]
Steps To ReproduceThe problematic file is Breakthru.VOB from http://rutracker.org/forum/viewtopic.php?t=2026054. [^]
Interlacing can be easily noticed at 00:15. madVR doesn't detect interlacing with "(.) if in doubt, deactivate deinterlacing"; when I investigated it before (with one of the older versions of madVR) the bug could be sometimes reproduced with "(.) if in doubt, activate deinterlacing" as well.
TagsNo tags attached.
madVR Version0.89.19
Media Player (with version info)MPC-HC 1.7.10.40
Splitter (with version info)LAV embedded
Decoder (with version info)LAV embedded
DecodingSoftware
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOff
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU ModelHD5770
GPU Driver Version14.4
Attached Filespng file icon lav.png [^] (16,613 bytes) 2014-04-24 20:35


png file icon lav2.png [^] (16,283 bytes) 2015-05-08 20:17


? file icon 00001.ts [^] (3,453,372 bytes) 2016-01-03 02:10
png file icon madvr_ss.png [^] (2,798,642 bytes) 2016-01-03 02:12
png file icon lav_ss.png [^] (2,758,562 bytes) 2016-01-03 02:12

- Relationships

-  Notes
(0000614)
madshi (administrator)
2014-04-24 09:11
edited on: 2014-04-24 09:12

How can I download that file? I don't see a download link.

Is this a file where LAV Filters activates deinterlacing properly, and madVR does not - even if "if in doubt activate deinterlacing" is activated?

(0000615)
GCRaistlin (reporter)
2014-04-24 18:22

http://rusfolder.com/40527629 [^]

Yes, this is the one. But I could reproduce the issue with "if in doubt activate deinterlacing" only before, after a couple of enabling and disabling "force video mode" / "force film mode" (enabling seemed to help forcing deinterlacing) and switching between "activate if in doubt" and "deactivate if in doubt".
(0000616)
madshi (administrator)
2014-04-24 18:33

Downloading now.

I don't understand your description of enabling and disabling various settings. Can you give me a step-by-step guide with which I can reproduce the problem, please? Thanks.
(0000618)
GCRaistlin (reporter)
2014-04-24 20:10

Deinterlacing for the problematic video isn't enabled automatically:
1) with "if in doubt deactivate deinterlacing"
2) with "if in doubt activate deinterlacing" and "force film mode".
(0000619)
madshi (administrator)
2014-04-24 20:30

With LAV Video Decoder set to "Deinterlacing Mode: Auto" which is the default setting, both 1) and 2) work here. Have you modified the LAV settings?
(0000620)
GCRaistlin (reporter)
2014-04-24 20:35

Yes I did or else madVR would have nothing to deinterlace. See attach for my LAV Video settings.
(0000621)
madshi (administrator)
2014-04-24 20:54

I'm not talking about "Enable Adaptive HW Deinterlacing", I'm talking about the "Deinterlacing Mode", which still seems to be set to "Auto" in your screenshot, which is the same setting it has on my PC.

Can you please redo your tests with software decoding? It's possible that the NVidia CUVID decoder doesn't properly forward the interlacing flags to madVR. Does the same problem occur with software decoding? It works fine on my PC with software decoding.
(0000622)
GCRaistlin (reporter)
2014-04-24 22:08

I set "Hardware Decoder to use" to "None" - nothing has changed. The video is still interlaced in forced film mode.
(0000623)
GCRaistlin (reporter)
2014-04-24 22:10

> I'm talking about the "Deinterlacing Mode", which still seems to be set to "Auto" in your screenshot
Does it have any effect when deinterlacing (both hardware and software based) is disabled?
(0000624)
madshi (administrator)
2014-04-24 23:37

> I set "Hardware Decoder to use" to "None" -
> nothing has changed. The video is still
> interlaced in forced film mode.

What does the madVR debug OSD (Ctrl+J) say in that situation? Does it report deinterlacing to be on or off?

> Does it have any effect when deinterlacing
> (both hardware and software based) is disabled?

Disabled where? In LAV or madVR? Not sure I understand your question.
(0000625)
GCRaistlin (reporter)
2014-04-24 23:54

> What does the madVR debug OSD (Ctrl+J) say in that situation? Does it report deinterlacing to be on or off?
deinterlacing on (settings)
film mode, unknown cadence
cadence breaks 0
decoder queue 16-16 / 16
ivtc queue 15-15 / 16

[Is there a way to write debug info to a file?]

> Disabled where? In LAV or madVR? Not sure I understand your question.
In LAV. You said I've misunderstood your question about deinterlacing mode - yes I did but I've completely disabled deinterlacing in LAV so I believe deinterlacing mode isn't important. Well nevermind.
(0000626)
madshi (administrator)
2014-04-25 00:11

Originally in the madVR doom9 forum thread you said that you found that LAV sometimes detects interlaced content better than madVR. The purpose of this thread is to get to the bottom of that problem. There are 2 potential reasons for why you got to that conclusion:

(1) Either madVR failed to activate deinterlacing at all. The OSD would then show "deinterlacing off".
(2) Or madVR tries to deinterlace, but didn't do it correctly.

So if you can reproduce a situation where LAV seems to deinterlace better than madVR, the first thing to figure out is whether the problem is (1) or (2). Generally, madVR's deinterlacing should work pretty much the same way as LAV's hardware deinterlacing works - as long as you don't force madVR's film mode on, which is totally different. So if you deactivate forced film mode, you should not be able to see a difference between LAV and madVR doing the deinterlacing. Both should be identical. Performance might be ever so slightly better when letting madVR do it.

Could you please retest it with this new background information? If you can't reproduce any problems, anymore, then I'd like to close this bug report. If you can reproduce problems, then let's get to the bottom of it.
(0000654)
madshi (administrator)
2014-07-28 08:31

Closed due to lack of feedback.
(0000992)
GCRaistlin (reporter)
2015-05-03 16:52

Let's try again - after a year (sorry for lack of feedback).
1. Reset settings of MPC-HC and madVR to defaults.
2. Open the problematic video, press Pause, go to 00:56.
3. In madVR settings: processing | deinterlacing | [x] disable automatic source type detection, (.) force film mode.
You'll see the interlaced picture immediately.
(0000997)
huhn (reporter)
2015-05-08 18:14

can you share a new sample?
if i understand you right you force film mode correct?
are you even sure the file in question is telecine and not interlaced or hybrid?
(0000998)
GCRaistlin (reporter)
2015-05-08 20:20

http://www.mediafire.com/watch/02ns1mjbgg4jef2/Breakthru.VOB [^]

>are you even sure the file in question is telecine and not interlaced or hybrid?
No I'm not. But the same LAV settings (lav2.png) with EVR CP don't cause the similar issue. Besides that I force film mode but not deinterlacing itself - by default it is set to "if in doubt, deactivate deinterlacing", and I didn't change it.
(0000999)
huhn (reporter)
2015-05-08 20:59
edited on: 2015-05-08 21:03

forced film mode can't handle interlaced sources is for telecine sources like most movies.
use forced video mode or leave everything at default and everything should work as intended.

EVR-CP doesn't have a inverse telecine filter and with your screen you feed it progressive frames.

edit: you try to feed it deinterlaced frames but CUVID is not working.

(0001001)
madshi (administrator)
2015-05-10 17:32

huhn is right. With forced film mode the Breakthru video at 00:56 shows interlacing because this video is not telecined film content, but it's native video content. Forced film mode only works for telecined film content.

To explain the difference: Telecined film content is content which originally was shot in 24fps and then it was artificially split into interlaced fields to create a 60i encoding. In contrast to that native video content consists of 60 different fields, and each field comes from a different point of time. As a result, if you watch a scene with lots of motion (like 00:56), and if you then just copy two fields together, those two fields simply don't fit together, because they're both from different points in time. So you see interlacing/weaving artifacts. Film mode technically cannot handle such videos because film mode simply looks for fields which come from the same original progressive frame and puts them back together.

So the solution is to disable forced film mode for videos like Breakthru. Sorry, this is not a bug, but as intended. If you want madVR to behave identical to EVR, simply use the default madVR settings, and don't change the "disable automatic source type detection" and "force film mode" settings.
(0001022)
GCRaistlin (reporter)
2015-05-13 16:59

Thanks for the explanation.
So the best I can do is to disable deinterlace completely in LAV and to leave default deinterlace settings in madVR?
(0001023)
madshi (administrator)
2015-05-13 17:17

If you want this specific video (and other videos like this) to play correctly then yes. But that also mean that you won't get madVR's film mode, which means that you can't play telecined 60i movie sources smoothly at 24Hz. Unfortunately madVR can currently not automatically figure out which video needs which deinterlacing setting. So to get the best experience for all files, you currently have to manually adjust deinterlacing settings. If you can live without forced film mode, using the madVR and LAV default settings should give you the same experience as with EVR.
(0001024)
GCRaistlin (reporter)
2015-05-13 17:31

I mean can I safely turn "Enable Adaptive HW Deinterlacing" off in LAV Video if I use madVR with its defaults? I used to always enable it 'cause I thought that it is the only way to deinterlace with GPU and therefore to reduce the CPU usage.
(0001025)
huhn (reporter)
2015-05-13 17:57

yes you can disable this option it is pretty much "useless". deinterlacing madVR video mode deinterlacing is done using the GPU deinterlacer which is the same as the CUVID deinterlacer. CUVID is kind of totally superseded by DXVA decoding and deinterlacing.

DXVA deinterlacing is using the correct 50/60 FPS mode with can be pretty hard on some GPUs.

you can go to rendering trade quality for performence "use half frame rate for DXVA deinterlacing" this will result in 25/30 FPS mode.
(0001026)
madshi (administrator)
2015-05-13 18:03

So I guess I can close this bug report now?
(0001027)
GCRaistlin (reporter)
2015-05-13 18:10

Yes. Thank guys again for the explanations!
(0001253)
GCRaistlin (reporter)
2016-01-03 02:09
edited on: 2016-01-03 02:13

I'm sorry to reopen this bug, but I do see the issue with madVR's deinterlacing. Again with Breakthru.vob, I believe it's what I told about in the very beginning.
What I do, step by step:
1. Reset MPC-HC and madVR settings to defaults.
2. Open http://www.mediafire.com/watch/02ns1mjbgg4jef2/Breakthru.VOB [^] and go to 00:56. Interlacing can be seen easily.
3. Change LAV Video properties:
    [x] Enable YADIF Deinterlacing (.) 50p/60p (Video)
4. Restart MPC-HC and open Breakthru.vob. No interlacing at 00:56.
WinXP SP3, HD5770, Catalyst 14.4, MPC-HC 1.7.10.40.

Another example: 00001.ts. Screenshots are taker under the conditions above.

(0001254)
madshi (administrator)
2016-01-03 09:10

If you enable YADIF deinterlacing then it's LAV's responsibility to deinterlace, not madVR's. So if you get problems this way, it's also LAV's bug, not madVR's.
(0001255)
GCRaistlin (reporter)
2016-01-03 11:14

I get problems with YADIF deinterlacing disabled (step 2 and madvr_ss.png). With YADIF deinterlacing enabled, the problem is gone (step 4 and lav_ss.png).
Ctrl-J on both files with YADIF deinterlacing disabled shows "deinterlacing on (says upstream)". Interlacing is present.

- Issue History
Date Modified Username Field Change
2014-04-23 22:44 GCRaistlin New Issue
2014-04-24 09:11 madshi Note Added: 0000614
2014-04-24 09:12 madshi Note Edited: 0000614 View Revisions
2014-04-24 18:22 GCRaistlin Note Added: 0000615
2014-04-24 18:33 madshi Note Added: 0000616
2014-04-24 18:34 madshi Assigned To => madshi
2014-04-24 18:34 madshi Status new => feedback
2014-04-24 20:10 GCRaistlin Note Added: 0000618
2014-04-24 20:10 GCRaistlin Status feedback => assigned
2014-04-24 20:30 madshi Note Added: 0000619
2014-04-24 20:30 madshi Status assigned => feedback
2014-04-24 20:35 GCRaistlin File Added: lav.png
2014-04-24 20:35 GCRaistlin Note Added: 0000620
2014-04-24 20:35 GCRaistlin Status feedback => assigned
2014-04-24 20:54 madshi Note Added: 0000621
2014-04-24 20:54 madshi Status assigned => feedback
2014-04-24 22:08 GCRaistlin Note Added: 0000622
2014-04-24 22:08 GCRaistlin Status feedback => assigned
2014-04-24 22:10 GCRaistlin Note Added: 0000623
2014-04-24 23:37 madshi Note Added: 0000624
2014-04-24 23:37 madshi Status assigned => feedback
2014-04-24 23:54 GCRaistlin Note Added: 0000625
2014-04-24 23:54 GCRaistlin Status feedback => assigned
2014-04-25 00:11 madshi Note Added: 0000626
2014-04-25 00:12 madshi Status assigned => feedback
2014-07-28 08:31 madshi Note Added: 0000654
2014-07-28 08:31 madshi Status feedback => closed
2014-07-28 08:31 madshi Resolution open => unable to reproduce
2015-05-03 16:52 GCRaistlin Note Added: 0000992
2015-05-03 16:52 GCRaistlin Status closed => feedback
2015-05-03 16:52 GCRaistlin Resolution unable to reproduce => reopened
2015-05-03 18:45 madshi Status feedback => assigned
2015-05-08 18:14 huhn Note Added: 0000997
2015-05-08 20:17 GCRaistlin File Added: lav2.png
2015-05-08 20:20 GCRaistlin Note Added: 0000998
2015-05-08 20:59 huhn Note Added: 0000999
2015-05-08 21:03 huhn Note Edited: 0000999 View Revisions
2015-05-10 17:32 madshi Note Added: 0001001
2015-05-10 17:32 madshi Status assigned => feedback
2015-05-13 16:59 GCRaistlin Note Added: 0001022
2015-05-13 16:59 GCRaistlin Status feedback => assigned
2015-05-13 17:17 madshi Note Added: 0001023
2015-05-13 17:17 madshi Status assigned => feedback
2015-05-13 17:31 GCRaistlin Note Added: 0001024
2015-05-13 17:31 GCRaistlin Status feedback => assigned
2015-05-13 17:57 huhn Note Added: 0001025
2015-05-13 18:03 madshi Note Added: 0001026
2015-05-13 18:03 madshi Status assigned => feedback
2015-05-13 18:10 GCRaistlin Note Added: 0001027
2015-05-13 18:10 GCRaistlin Status feedback => assigned
2015-05-13 18:11 madshi Status assigned => closed
2015-05-13 18:11 madshi Resolution reopened => no change required
2016-01-03 02:09 GCRaistlin madVR Version 0.87.10 => 0.89.19
2016-01-03 02:09 GCRaistlin Media Player (with version info) MPC-HC 1.7.4.8 => MPC-HC 1.7.10.40
2016-01-03 02:09 GCRaistlin Decoding CUDA => Software
2016-01-03 02:09 GCRaistlin GPU Manufacturer NVidia => AMD
2016-01-03 02:09 GCRaistlin GPU Model 8800 GT => HD5770
2016-01-03 02:09 GCRaistlin GPU Driver Version 335.28 => 14.4
2016-01-03 02:09 GCRaistlin Note Added: 0001253
2016-01-03 02:09 GCRaistlin Status closed => feedback
2016-01-03 02:09 GCRaistlin Resolution no change required => reopened
2016-01-03 02:10 GCRaistlin File Added: 00001.ts
2016-01-03 02:12 GCRaistlin File Added: madvr_ss.png
2016-01-03 02:12 GCRaistlin File Added: lav_ss.png
2016-01-03 02:13 GCRaistlin Note Edited: 0001253 View Revisions
2016-01-03 02:13 GCRaistlin Note Edited: 0001253 View Revisions
2016-01-03 09:10 madshi Note Added: 0001254
2016-01-03 11:14 GCRaistlin Note Added: 0001255
2016-01-03 11:14 GCRaistlin Status feedback => assigned
2016-01-13 00:03 GCRaistlin Status assigned => closed
2016-01-13 00:03 GCRaistlin Resolution reopened => no change required


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker