madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000200madVRbugpublic2014-04-24 22:202015-03-27 13:38
ReporterSoukyuu 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformpcOSwindowsOS Version8.1u1
Summary0000200: Smooth motion jerky on fade with "present several frames in advance" active
DescriptionThe only reason I noticed it is that now we have "present several frames in advance" in windowed mode also...
I first thought it was the source, but once I watched some older series I knew there was definitely something wrong as there were no such skips previously.

I have tried increasing GPU buffers, but it doesn't help, nor do I see any queues dropping to 0. Also no dropped frames. Not knowing the code, it seems like "present several frames in advance" clashes with "re-render if fade detected".
Steps To ReproduceA sample file is here: http://www.nyaa.se/?page=view&tid=546769 [^]

- disable "don't re-render frames when fade detected"
- enable "present several frames in advance"
- launch the file and skip to the ending (chapter E)
-> video is jerky at fades between the scenes (most notable @21:55 @22:28 @22:45)
- either enable "don't re-render frames..." or disable "present several frames in advance"
-> no more jerky transitions
Additional Information- 0.87.0 = no issue in both windowed and exclusive modes
- 0.87.1 .. 0.87.9 = no issue in windowed mode, jerky fades in exclusive.
- 0.87.10 = jerky fades in both windowed and exclusive.

Overlay mode is fine btw, only non-overlay and exclusive are affected.
TagsNo tags attached.
madVR Version0.87.10
Media Player (with version info)mpc-hc 1.7.4
Splitter (with version info)internal LAV (0.61.2.0)
Decoder (with version info)internal LAV (0.61.2.0)
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU Model260GTX
GPU Driver Version327.23
Attached Files

- Relationships

-  Notes
(0000801)
madshi (administrator)
2015-03-22 12:24

This can happen if the GPU queues are too small. I guess the default settings are rather conservative. If you want to use Smooth Motion FRC and debanding, and if you want madVR to re-render frames when a fade is detected, then increasing the GPU queue size should help get rid of the jerky fade. E.g. try increasing the GPU queue size from 8 to 12.
(0000850)
Soukyuu (reporter)
2015-03-23 23:53

It's not a stuttering per se, the queues don't drop (at least in the OSD). It's as if the clip gets visibly re-winded a few frames back, then plays again.

So instead of 1 2 3 4 5
it plays 1 2 3 1 2 3 4 5

3 probably being the frame it detects as a fade.
(0000852)
madshi (administrator)
2015-03-24 08:59

I can't reproduce that here. Have you tried increasing the queue sizes? Does that not help?
(0000871)
Soukyuu (reporter)
2015-03-27 13:33

Sorry, I'm not using windows lately, so it took a while to look at it.

It looks like the issue has solved itself. Might have been a driver related bug, or some stale config options, but I now don't have the behavior anymore. I even reduced the queues to 4 and it still doesn't happen (if it was a queue issue at all).
(0000872)
madshi (administrator)
2015-03-27 13:38

Ok, thanks. So I'll close this bug report.

- Issue History
Date Modified Username Field Change
2014-04-24 22:20 Soukyuu New Issue
2014-04-24 23:37 madshi Assigned To => madshi
2014-04-24 23:37 madshi Status new => assigned
2015-03-22 12:24 madshi Note Added: 0000801
2015-03-22 12:24 madshi Status assigned => feedback
2015-03-23 23:53 Soukyuu Note Added: 0000850
2015-03-23 23:53 Soukyuu Status feedback => assigned
2015-03-24 08:59 madshi Note Added: 0000852
2015-03-24 08:59 madshi Status assigned => feedback
2015-03-27 13:33 Soukyuu Note Added: 0000871
2015-03-27 13:33 Soukyuu Status feedback => assigned
2015-03-27 13:38 madshi Note Added: 0000872
2015-03-27 13:38 madshi Status assigned => closed
2015-03-27 13:38 madshi Resolution open => fixed
2015-03-27 13:38 madshi Resolution fixed => no change required


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker