madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000210madVRbugpublic2014-05-13 22:322018-01-21 21:30
Assigned Tomadshi 
PlatformIntel Core2Quad 9550 + AMD 6870OSWindowsOS Version7
Summary0000210: Function "command line to execute when this profile is activated/ deactivated" does not work
DescriptionTried to switch GPU clock profiles with a command line out of madvr to trigger diffrent GPU clock profiles with each madvr profile (SD, HD and FullHD) using the function "command line to execute when this profile is activated".

For testing purpose I also tried to execute simple exe-files on C: (shortest possible folder paths) and other short folders during madvr profile start but it did not work.

Background is, I need the highest GPU power only when upscaling SD material with NNEDI3 image doubling, but with HD and FullHD material I don't use image doubling and want to run the video card cooler, quieter and more energy efficient.
TagsNo tags attached.
madVR Version0.87.10
Media Player (with version info)JRiver Media Center 19.0.131
Splitter (with version info)LAV 0.61.2
Decoder (with version info)LAV 0.61.2
DecodingDXVA2 Native
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU ModelHD 6870
GPU Driver VersionCatalyst 13.12
Attached Filesrar file icon settings.rar [^] (13,387 bytes) 2018-01-18 08:40

- Relationships

-  Notes
madshi (administrator)
2018-01-14 11:37

Will be fixed in the next build.
Polopretress (reporter)
2018-01-16 00:26

Hello madshi.
Thank for this fix. I have tested, it works fine when madVR is active and i apply a switch of profil manually but it does not work when a profil is selected from a condition given by "profil auto select rules".

The expected behaviour would be to also be possible to run these commands when a profil is automatically selected (from rules) at the opening of madVr and at the closure of madVR.
Maybe, by default or by addition of a check box to includ selection of the profil at the opening of madVr and deselection of the profil due to the closure of madVR.

Thank a lot.
madshi (administrator)
2018-01-16 18:50

I can't seem to be able to reproduce the problem. It seems to work fine on my PC. Can you please double check it's really not working? I've done some small tweaks, maybe it helps, in this test build: [^]

Maybe it works better? If not, please upload your "settings.bin" file (or HKEY_CURRENT_USER\Software\madshi\madVR\Settings), then I can try reproducing the problem with your exact settings.
Javs (reporter)
2018-01-18 08:35
edited on: 2018-01-18 08:40

I too am experiencing this bug, it wont run a .bat script (tagged you on AVS madshi), or even as a test, a simple text document on my desktop.

Tried the build that you linked here too but that doesn't work.

I added my settings.bin file too if it helps.

madshi (administrator)
2018-01-18 09:54


I've tried this:

- Created "C:\test1.bat" with "start C:\test2.bat" in it.
- Created "C:\test2.bat" with "pause" in it.
- Created profiles with auto select rules, told madVR to run "C:\test1.bat".

Test result: When starting video playback, a non-hidden command line window appears, which reads "pause" and "press any key...". So this means, command line execution works well for me. What happens on your PC? Does the command line window appear or not? If it does appear, try prepending some commands to "test2.bat" before the "pause", then you can see in the command line window if your additional commands output any errors.
Polopretress (reporter)
2018-01-18 20:33
edited on: 2018-01-18 21:45

So, the behaviour is same for update with 9211b files.

I have done your script.
I agree it works fine when the profile is activated even it the program is launched.

But it does not work when the profil is deactivated due to the closure of the player. (i use potplayer and did not test yet on mpc-be)
this option (execute when profile is deactiveted) works only when you switch between profiles without closing madVR.

I have also tried to let madVR opened in the task tray by running it before to launch a movie (used of madHcCtrl.exe). It is same result even if madVR is still opened when the player is closed and the profile is not enable anymore.

So it works fine when madVR is opened but not when madVR is closed.
I hope it helps you to understand.
I can post my settings.bin if you think it is usefull.

madshi (administrator)
2018-01-18 22:05

Deactivation command line is only executed when profiles are switched in the middle of playback. That is by design. I suppose in theory I could also execute the deactivation command line when playback stops, but if the media player e.g. switches video files, you'd get a deactivation + activation command line execution for the same profile at nearly the same time then. I don't think that's a good idea.

I'm actually considering removing the deactivation command line execution. It currently doesn't work the way users seem to expect, and I don't think I can properly make it work that way. So I might just leave the activation command line execution in the next build. Or what do you think?
Javs (reporter)
2018-01-18 22:31

Does the command line execute from within madvr itself?

I am finding that with what I am trying to do, run a .py file from a .bat, that it seems to actually be executing the command line from within Kodi not MadVR. And that's why in my case it was not working every time. No matter what I do, I cant seem to be able to get it to run separate from Kodi. I am getting a python error from Kodi since its trying to use its own built in Python libraries, yet when I run the bat file independently on the desktop it does exactly what I want it to do, I also tried specifying the python exe in my bat file, but that's also not working, Kodi seems to ignore it.

I think if there was a way for MadVR to run a command from within its own process and not piggyback the host media player it would possibly work, or am I wrong in my assumption on this?

I did confirm your bat test did indeed work just fine madshi so the actual command line function itself is not broken for me, just that Kodi seems to be trying to execute it and not madvr.

p.s I think it would be good to have deactivation working on stopping playback (hopefully not pause though). Since for a JVC owner we would be sent back to SDR mode after we finish with an HDR film. At least that's what I and some others would ideally like to use this feature for.
madshi (administrator)
2018-01-18 22:43

When DSPlayer loads madVR, madVR becomes a part of DSPlayer. It's just 2 modules in the same process. It doesn't matter to Windows which module of Kodi executes a command line. There's no difference between letting or DSPlayer.exe execute a command line.

Technically, the key difference can either be the working directory, or the environment. Try doing "SET" in your batch file, when run from Kodi/madVR, and when run from desktop. It will probably differ. My best guess is that Kodi changes some path in the environment settings (which is what "SET" lists). If you manually overwrite that path in your batch file, that should solve the problem.
madshi (administrator)
2018-01-18 22:44

P.S: The command line executes in a new process, it doesn't execute in either madVR (which is impossible since madVR is not a process) nor does it execute in Kodi/DSPlayer. However, the command line inherits the working directory and environment from the Kodi/DSPlayer/madVR process.
Polopretress (reporter)
2018-01-19 01:36
edited on: 2018-01-19 01:39

ok, I understand now but it would be not good to remove the command execution when you leave the profile.
And maybe the reason why most of people are not interrested is maybe because they cannot use when madVr is switched off.
You know, i think executing at the closure of madVr is maybe more interresting than when you switch the profile.

I also understand that some people are interresting by having this switch when profile is changed during the movie but generaly when you switch the profile during a movie , it is mainly to modify the settings of the parameters to increase/decrease the sharp (and others), not to command an external device, i think.

is it possible to keep it (when profil is deactivated) by adding an option that will activate it also at the closure of madVR when the check box is greyed ?

The goal, as Javs wrote is also for me to command an external device at the launch and stop of the movie.

as Javs, i would like to use a batch file that include the start of a py file.

Linked to remark that you have given for the double command execution in case of switching, it is already the case when you have a command execution at the closure for profile 1 and a command execution at the launch of the profile 2.

Another thing i have noticed is that the command is also launched when the profile is not selected at the opening of madVR.
For example, you record your script (.bat) for both 1080p and 720p profile in "processing" section. If you run a 1080p movie, both script will be launched even if normally, the one done for 720p has not be launched because it is not selected.

madshi (administrator)
2018-01-19 09:47

Well, I don't think this is a good platform to discuss how a feature should work. We should discuss that on doom9. If we discuss it here, 99% of madVR users won't even notice and can't write their opinion. This platform is for fixing bugs.

So can we all agree that the feature "command line to execute when this profile is activated/ deactivated" does work as intended? You may not like the way it's intended, especially the deactivation part of it, but that's not a bug but by design, which could be discussed on doom9.
Polopretress (reporter)
2018-01-19 10:38
edited on: 2018-01-19 10:43

OK. then maybe i continue on doom9.

Just for information on my last comment for the wrong launch of 720p command line whith 1080 movie profile : it works fine with your update provided [^] [^]

Maybe for this observation, this is a bug on the actual release 9211

madshi (administrator)
2018-01-19 10:43

Yes, I thought it might. It was one of the key changes in the update to avoid running multiple activation command lines at movie startup.
madshi (administrator)
2018-01-21 21:29

I'm closing this one because the feature seems to be working as intended (as far as I can say). Discussion on deactivation command line execution to be continued on doom9.

- Issue History
Date Modified Username Field Change
2014-05-13 22:32 Pistensau New Issue
2015-03-14 16:05 madshi Assigned To => madshi
2015-03-14 16:05 madshi Status new => assigned
2018-01-14 11:37 madshi Note Added: 0002000
2018-01-14 11:37 madshi Status assigned => closed
2018-01-14 11:37 madshi Resolution open => fixed
2018-01-16 00:26 Polopretress Note Added: 0002133
2018-01-16 00:26 Polopretress Status closed => feedback
2018-01-16 00:26 Polopretress Resolution fixed => reopened
2018-01-16 10:13 madshi Status feedback => assigned
2018-01-16 18:50 madshi Note Added: 0002142
2018-01-16 18:50 madshi Status assigned => feedback
2018-01-18 08:35 Javs Note Added: 0002144
2018-01-18 08:36 Javs Note Edited: 0002144 View Revisions
2018-01-18 08:38 Javs Note Edited: 0002144 View Revisions
2018-01-18 08:40 Javs File Added: settings.rar
2018-01-18 08:40 Javs Note Edited: 0002144 View Revisions
2018-01-18 09:54 madshi Note Added: 0002145
2018-01-18 20:33 Polopretress Note Added: 0002146
2018-01-18 20:35 Polopretress Note Edited: 0002146 View Revisions
2018-01-18 21:17 Polopretress Note Edited: 0002146 View Revisions
2018-01-18 21:20 Polopretress Note Edited: 0002146 View Revisions
2018-01-18 21:21 Polopretress Note Edited: 0002146 View Revisions
2018-01-18 21:45 Polopretress Note Edited: 0002146 View Revisions
2018-01-18 22:05 madshi Note Added: 0002147
2018-01-18 22:31 Javs Note Added: 0002148
2018-01-18 22:43 madshi Note Added: 0002149
2018-01-18 22:44 madshi Note Added: 0002150
2018-01-19 01:36 Polopretress Note Added: 0002153
2018-01-19 01:38 Polopretress Note Edited: 0002153 View Revisions
2018-01-19 01:39 Polopretress Note Edited: 0002153 View Revisions
2018-01-19 09:47 madshi Note Added: 0002154
2018-01-19 10:38 Polopretress Note Added: 0002155
2018-01-19 10:39 Polopretress Note Edited: 0002155 View Revisions
2018-01-19 10:40 Polopretress Note Edited: 0002155 View Revisions
2018-01-19 10:43 Polopretress Note Edited: 0002155 View Revisions
2018-01-19 10:43 madshi Note Added: 0002156
2018-01-21 21:29 madshi Note Added: 0002198
2018-01-21 21:30 madshi Status feedback => closed
2018-01-21 21:30 madshi Resolution reopened => fixed

Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker