madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000230madVRbugpublic2014-08-04 11:282015-03-15 14:59
ReporterManni 
Assigned Tomadshi 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWin 8.1 ProOS Versionx64 with MCE
Summary0000230: When using the auto display mode option in MadVR, DVD playback is broken
DescriptionOn my ADM 7870, as soon as I populate the field in MadVR options with valid refresh rates for my display (I use 1080p23, 1080p24, 1080p50, 1080p59 and 1080p60) on my JVC X30 / RS-45, I get a black screen when playing a DVD folder (with the /dvd option if launched from MyMovies, but I get the same issue if I ask MPC-HC or MPC-Be to open the folder directly. It happens with all titles. As I mostly have PAL DVDs, MadVR correctly switches to 1080p50, but then it sits on a black screen (paused). It switches back to the default rate when I leave the player.

I use LAV filters, usually from a KCP codec pack, either MPC-HC stable or MPC-BE alpha, but I tried to reproduce with a standalone install of MadVR, MPC-BE and LAV (all latest at this date) and I experience exactly the same issue.

The only way to get MPC-HC or MPC-BE to play DVDs with MadVR doing the refresh rate switching is to set the video H/W option in LAV Video to DXVA2 (native) instead of none. This solves the issue, and the auto refresh rate works fine.

If the refresh rate change is done by another software, either MyMovies or jRiver19, there is no such issue.

No idea whether this is a LAV issue or an MPC-HC issue, but as the problem only arises when I populate a MadVR option, I thought I'd raise it here first.
Steps To ReproducePopulate the display modes field with valid refresh rates for the display and try to play a DVD folder (preferably PAL as this is what I tested with but I assume the issue will be the same with an NTSC one) using LAV filters and MPC-HC or MPC-BE.

I usually use the highest settings when installing with a Kawaii Codec pack, in case it makes a difference.
TagsNo tags attached.
madVR Version0.87.10
Media Player (with version info)All recent versions of MPC-BE (up to the latest 1.4.3 beta) or MPC-HC
Splitter (with version info)LAV Filters 0.62
Decoder (with version info)LAV Filters 0.62
DecodingSoftware
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU ModelHD7870
GPU Driver Version13.12
Attached Files

- Relationships

-  Notes
(0000667)
madshi (administrator)
2014-09-20 13:24

http://forum.doom9.org/showthread.php?p=1690030#post1690030 [^]
(0000780)
madshi (administrator)
2015-03-15 14:59

This is kind of a weird one. Changing the display mode itself doesn't seem to be a big problem, but recreating the Direct3D interfaces is. madVR is usually recreating the Direct3D interfaces when the display mode changes. I've now disabled that, if the DVD Navigator is in the graph. I hope it fixes the problem, and I hope it won't introduce new problems. Let's see...

- Issue History
Date Modified Username Field Change
2014-08-04 11:28 Manni New Issue
2014-09-20 13:24 madshi Note Added: 0000667
2015-03-14 17:07 madshi Assigned To => madshi
2015-03-14 17:07 madshi Status new => assigned
2015-03-15 14:59 madshi Note Added: 0000780
2015-03-15 14:59 madshi Status assigned => closed
2015-03-15 14:59 madshi Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker