madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000259eac3tobugpublic2015-03-11 20:252015-03-12 19:14
ReporterBoulder 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionnot fixable 
PlatformOSOS Version
Summary0000259: eac3to crashes when using r8brain to resample a 96kHz track
Descriptioneac3to crashes when using r8brain to resample this 5.0ch 96kHz track. Using the default SSRC works fine.
Steps To ReproduceLaunch eac3to.exe source.wav dest.wav -r8brain -resampleto48000
TagsNo tags attached.
eac3to Versionv3.28
Attached Fileszip file icon snip.zip [^] (1,922 bytes) 2015-03-11 20:25

- Relationships

-  Notes
(0000729)
madshi (administrator)
2015-03-11 22:53

Works for me:

D:\Desktop>eac3to snip.wav dest.wav -r8brain -resampleto48000
WAV, 5.0 channels, 0:00:01, 24 bits, 11520kbps, 96kHz
Reading WAV...
Resampling to 48kHz...
Reducing depth from 64 to 24 bits...
Writing WAV...
Original audio track: no audio data.
The processed audio track has a constant bit depth of 24 bits.
Creating file "dest.wav"...
eac3to processing took 1 second.
Done.
(0000730)
Boulder (reporter)
2015-03-12 17:06

Strange..the crash occurs with any WAV file.

The r8brain console version also throws "WAV file "B:\sh.wav" has unsupported tag FFFEh and thus cannot be read". The wav file was decoded by eac3to using ffmpeg (with Nero I get the same error as well).
(0000731)
madshi (administrator)
2015-03-12 18:27

Well, what can I say. It works here. You could try disabling DEP for eac3to. Maybe r8brain doesn't work with activated DEP. But why does it work on my PC then? I don't have DEP disabled here.

If I can't reproduce the problem on my PC, then there's not much I can do about this.
(0000732)
Boulder (reporter)
2015-03-12 19:12

Disabling DEP works :) I would never have thought of it, maybe I should disable it altogether since it's usually just a nuisance..
(0000733)
madshi (administrator)
2015-03-12 19:14

Well, must be r8brain's fault then. Nothing I can do about it. Still wonder why it doesn't seem to be a problem on my PC. Anyway, will close this bug report, since it's not eac3to's fault.

- Issue History
Date Modified Username Field Change
2015-03-11 20:25 Boulder New Issue
2015-03-11 20:25 Boulder File Added: snip.zip
2015-03-11 22:53 madshi Note Added: 0000729
2015-03-11 22:54 madshi Assigned To => madshi
2015-03-11 22:54 madshi Status new => feedback
2015-03-12 17:06 Boulder Note Added: 0000730
2015-03-12 17:06 Boulder Status feedback => assigned
2015-03-12 18:27 madshi Note Added: 0000731
2015-03-12 18:27 madshi Status assigned => feedback
2015-03-12 19:12 Boulder Note Added: 0000732
2015-03-12 19:12 Boulder Status feedback => assigned
2015-03-12 19:14 madshi Note Added: 0000733
2015-03-12 19:14 madshi Status assigned => closed
2015-03-12 19:14 madshi Resolution open => not fixable


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker