madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000325madVRbugpublic2015-07-16 16:402015-12-21 20:01
Reporterartins90 
Assigned Tomadshi 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionnot fixable 
PlatformPCOSWindows 10OS Version10240 x64
Summary0000325: Madvr crashes when using nnedi3 in combination with Nvidia CUVID
DescriptionHi,

I have just updated to the newest version of Madvr, v0.88.19, and I now I have found this bug. Basically when playing any video via Lav filters using Nvidia CUVID for decoding in combination with nnedi3 for chroma upscaling, madvr makes MPC crash. The rendering queues get empty and the audio keeps playing in the background for a while and then the player becomes unresponsive and crashes.
Steps To ReproduceUsing nnedi3 for chroma upscaling in combination with the latest version of lav filters and Nvidia CUVID decoding. I have attached a video below detailing the problem. Sorry for the quality but here in Italy we have only 1Mb upload speed.

I haven't tested it with image doubling and the other "nnedi3 settings" but I suspect that it might crash with the other settings as well.

https://youtu.be/dTBbyBX-xMQ [^]
TagsNo tags attached.
madVR Versionv0.88.19
Media Player (with version info)MPC HC
Splitter (with version info)1.7.9.54
Decoder (with version info)LAV Filters 0.65.0.26
DecodingCUDA
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGTX 980
GPU Driver Version353.30
Attached Files

- Relationships

-  Notes
(0001125)
artins90 (reporter)
2015-07-28 00:28

Fixed in version v0.88.21
(0001172)
madshi (administrator)
2015-09-25 20:21

Thanks. Since its fixed, I'll close this bug report.
(0001237)
m3lis (reporter)
2015-12-13 14:21

This bug has returned in 0.89.17 as I have experienced this same thing.
(0001239)
madshi (administrator)
2015-12-21 14:46

m3lis, which OS are you on? There is a known bug with CUVID on Windows 10, which I can't do anything about.
(0001244)
m3lis (reporter)
2015-12-21 19:40
edited on: 2015-12-21 19:40

Thank you for your reply. Yes, I am on Windows 10 Pro (x64). Any workaround in the meantime?

(0001245)
madshi (administrator)
2015-12-21 20:00

Yes, don't use CUVID... :) Use DXVA copyback instead.
(0001246)
madshi (administrator)
2015-12-21 20:01

This is a bug that can only be fixed by NVidia, so I'll close this bug report.

- Issue History
Date Modified Username Field Change
2015-07-16 16:40 artins90 New Issue
2015-07-28 00:28 artins90 Note Added: 0001125
2015-09-25 20:21 madshi Note Added: 0001172
2015-09-25 20:21 madshi Status new => closed
2015-09-25 20:21 madshi Assigned To => madshi
2015-09-25 20:21 madshi Resolution open => fixed
2015-12-13 14:21 m3lis GPU Model GTX 970 => GTX 980
2015-12-13 14:21 m3lis Note Added: 0001237
2015-12-13 14:21 m3lis Status closed => feedback
2015-12-13 14:21 m3lis Resolution fixed => reopened
2015-12-21 14:46 madshi Note Added: 0001239
2015-12-21 19:40 m3lis Note Added: 0001244
2015-12-21 19:40 m3lis Note Edited: 0001244 View Revisions
2015-12-21 20:00 madshi Note Added: 0001245
2015-12-21 20:01 madshi Note Added: 0001246
2015-12-21 20:01 madshi Status feedback => closed
2015-12-21 20:01 madshi Resolution reopened => not fixable


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker