madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000346madVRbugpublic2015-10-11 16:472015-10-12 00:00
Assigned Tomadshi 
StatusclosedResolutionno change required 
PlatformWindowsOSWindows 10 ProOS VersionBuild 10240
Summary0000346: Fullscreen Exclusive Mode works only on extended monitor or secondary display
DescriptionI have Lenovo W550s laptop.
It has Intel HD Graphics 5500 and dedicated Quadro K620M display adapters.
I am sure that I am not using the NVIDIA Quadro for any of the media players that I use (MPC-BE, PotPlayer and WMP), as I haven't added the same to NVIDIA control panel.
I have noticed in Windows 8.1 and as well as after upgrading to Windows 10 that madVR doesn't change into Exclusive Fullscreen mode on the primary monitor.
I'll list the conditions here when it works and when it doesn't.
1. No external monitor connected to the laptop.
Exclusive fullscreen mode doesn't work at all.

2. External monitor connected with Extend option where built-in display is primary and external monitor is secondary display
Exclusive fullscreen mode works only when PotPlayer or MPC-BE window is in external monitor/secondary display.

3. External monitor connected with Extend option where built-in display is secondary and external monitor is primary display
Exclusive fullscreen mode works only when PotPlayer or MPC-BE window is in built-in monitor/secondary display.

4. External monitor connected with Duplicate option
Exclusive fullscreen mode doesn't work.

I've tested this by enabling/disabling D3D11 option in madVR but that didn't help either.

I am guessing that this may have something to do with Intel HD 5500 Display Adapter/Driver.

Please let me know if you need any more information. I am guessing this issue is quite unique as I wasn't able to find similar issue anywhere in Doom9 forum or here.

Also, I would like you to thank for this madVR renderer, I really love it.

Steps To ReproduceUse MPC-BE or PotPlayer and play a movie in fullscreen.
Additional InformationI use the MPC-BE with madVR 64-bit installer available on here [^]
To install MPC-BE as well as the renderer.
I am then able to use it within PotPlayer as well as MPC-BE.
TagsNo tags attached.
madVR Version0.89.5
Media Player (with version info)PotPlayer (64-bit) 1.6.56209
Splitter (with version info)Built-in
Decoder (with version info)Built-in
DecodingDXVA2 Native
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modefullscreen exclusive mode
GPU ManufacturerNVidia + Intel
GPU ModelQuadro K620M and Intel HD 5500
GPU Driver Version10.18.15.4279 and 354.13
Attached Fileszip file icon Primary_Display (External Monitor) - madVR - [^] (3,326,306 bytes) 2015-10-11 22:28
zip file icon Secondary_Display (Build-in) - madVR - [^] (5,565,227 bytes) 2015-10-11 22:29

- Relationships

-  Notes
madshi (administrator)
2015-10-11 21:11
edited on: 2015-10-11 21:11

Please enabled the debug OSD (Ctrl+J), then create a debug log for me, zip it and attach it to this bug report. It's important that the OSD is visible while you create the debug log.

StarkWiz (reporter)
2015-10-11 21:42

Can you please let me know how to create one ?
I know it should be similar to this [^]
But no idea how to get that, it seems it is generated after crash ?
madshi (administrator)
2015-10-11 22:06

No, that one is a crash report, no debug log.

In the madVR folder double click "activate debug mode.bat". After that simply play the movie, enter fullscreen mode, wait 5 seconds. Then close the media player. After that a debug log text file should be created on your desktop. Don't forget to double click "activate release mode.bat" when you're done.
StarkWiz (reporter)
2015-10-11 22:11

Oh I see that batch file is not included in the version that comes with MPC-BE64 by
I'll install it separately and let you know soon. Thanks :)
StarkWiz (reporter)
2015-10-11 22:30

I uninstalled MPCBE64 with madVR bundle completely to make sure that the new installation doesn't conflict with any previous madVR files.
The newly installed madVR version is 0.89.8
I noticed that any changes I had made previously were reset so it is using D3D9 by default.
And I preferred not making any changes at all.
I have attached 2 separate logs for when I ran potplayer on primary display and when I ran it on secondary display.
madshi (administrator)
2015-10-11 22:40

The debug log says:

CDirect3D::IsMediaPlayerFullscreen(self: 000000BFBF2B12F0, myRect: 0, 0, 1920, 1080; monitorRect: 0, 0, 1920, 1080) -> yes
D3D9 fullscreen windowed (new path)
covered by some windows
madVR window [madVR] {0,0,1920,1080}
covered by tpnumlkd.exe window [wndclass NumLock OSD] {842,925,1077,995}

Basically it confirms that your media player is in fullscreen. However, there's a window with the class name "NumLock OSD", owned by the process "tpnumlkd.exe", which is covering the madVR rendering window. And madVR cannot enter fullscreen exclusive mode if there are windows covering madVR's rendering window.
StarkWiz (reporter)
2015-10-11 22:50

wow thanks ending that process fixed the issue.
That process name is "NumLock on screen display for ThinkPad"
I've been going so crazy about not being able to enable exclusive fullscreen since I got this laptop. Thanks for the easy fix.

is it somehow possible to give more priority to madvr ?
So, when madvr tries to take control this specific process won't cause such problem.

Also there is one more thing I noticed that while using D3D11 screen goes blank for few seconds before switching to exclusive fullscreen mode.
This doesn't happen with default D3D9.
madshi (administrator)
2015-10-12 00:00

The logic of the "automatic fullscreen exclusive mode" is that it doesn't overwrite other windows. E.g. imagine you right click your media player. A menu pops up. Or you press some key shortcut to open a settings window of your media player. If madVR would simply overwrite those windows, that would be quite ugly.

So no, there's nothing I can do here. Which means, this is not a bug, and I'll close this bug report.

Don't know why the screen goes blank with D3D11, probably something specific to the GPU driver.

- Issue History
Date Modified Username Field Change
2015-10-11 16:47 StarkWiz New Issue
2015-10-11 21:11 madshi Note Added: 0001192
2015-10-11 21:11 madshi Note Edited: 0001192 View Revisions
2015-10-11 21:42 StarkWiz Note Added: 0001193
2015-10-11 22:06 madshi Note Added: 0001194
2015-10-11 22:11 StarkWiz Note Added: 0001195
2015-10-11 22:28 StarkWiz File Added: Primary_Display (External Monitor) - madVR -
2015-10-11 22:29 StarkWiz File Added: Secondary_Display (Build-in) - madVR -
2015-10-11 22:30 StarkWiz Note Added: 0001196
2015-10-11 22:40 madshi Note Added: 0001197
2015-10-11 22:50 StarkWiz Note Added: 0001198
2015-10-12 00:00 madshi Note Added: 0001199
2015-10-12 00:00 madshi Status new => closed
2015-10-12 00:00 madshi Assigned To => madshi
2015-10-12 00:00 madshi Resolution open => no change required

Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker