madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000356madVRbugpublic2015-10-26 12:362015-12-21 14:45
Reportermurmeltier 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionnot fixable 
Platform64-bitOSWindowsOS Version10
Summary0000356: Issue 0000325 still not solved
DescriptionIt looks like the first few frames get successfully decoded and displayed but after that the image "freezes" and the Media player stops to respond.

The audio playback is not affected. You can even hear it after the "crash".
Steps To Reproduce1. Open PotPlayer or MPC-HC
2. Choose NVIDIA CUVID as video decoder.
3. Open up madVR's settings editor, go to "scaling algorithms/chroma upscaling" and choose NNEDI3 under "processing done by custom pixel shader code" with 32 neurons.
4. Start the playback of any in h264 encoded video you like.
Additional InformationThere is no problem if you use DXVA2 Copy-back as video decoder.
TagsNo tags attached.
madVR Version0.89.12
Media Player (with version info)PotPlayer 1.6.56209 (32-Bit)
Splitter (with version info)Built-in MP4 Source/Splitter
Decoder (with version info)Build-in Nvidia CUDA Decoder
DecodingCUDA
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modefullscreen exclusive mode
GPU ManufacturerNVidia
GPU ModelGeForce GTX 750 Ti
GPU Driver Version358.50
Attached Files

- Relationships

-  Notes
(0001220)
huhn (reporter)
2015-10-27 00:49
edited on: 2015-10-27 00:49

this is a new bug in the nvidia driver.

CUVID doesn't decode any frames when a program uses openCL like madVR nnedi3 or even SVP openCL feature.

edit: a windows 10 driver problem

(0001222)
murmeltier (reporter)
2015-10-29 09:45

@huhn: Do you mean some kind of API inconsistency? In other words: Does madVR use some kind of openCL functionality that is simply not available anymore in the version of openCL that is distributed with Windows 10?

Would it be a lot of work to fix that?
(0001223)
madshi (administrator)
2015-10-29 09:50

No, it's a limitation of NVidia drivers in Windows 10. The same problem occurs even when not using madVR at all. E.g. if you use SVP (smooth video project) which also uses OpenCL, CUVID decoding also fails. So this problem is NVidia's fault, not madVR's.

- Issue History
Date Modified Username Field Change
2015-10-26 12:36 murmeltier New Issue
2015-10-27 00:49 huhn Note Added: 0001220
2015-10-27 00:49 huhn Note Edited: 0001220 View Revisions
2015-10-29 09:45 murmeltier Note Added: 0001222
2015-10-29 09:50 madshi Note Added: 0001223
2015-12-21 14:45 madshi Status new => closed
2015-12-21 14:45 madshi Assigned To => madshi
2015-12-21 14:45 madshi Resolution open => not fixable


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker