madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000398madVRbugpublic2016-05-04 14:022016-05-04 17:25
Reportersat4all 
Assigned To 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel Nuc D54250WYKHOSWindows 10 x64OS Version
Summary0000398: Color Accuracy
Descriptionhi madshi,
i"m having problem with madvr's colors accuracy.
first here is my settings:
madvr: 16-235, jinc ar for chroma and luma, trade quality for performance all unchecked and default values for other settings.
lav: dxva2-cb (i did try soft too), yuv -> rgb untouched
gpu: 1080p output, 0-255, all video processing off
tv: 16-235
test was done with the dark knight bluray remux.
school bus:
-madvr
[url=http://postimg.org/image/zcwe8yjvl/ [^]][img]http://s32.postimg.org/zcwe8yjvl/bus_madvr.jpg[/img][/url] [^]
-mpdn
[url=http://postimg.org/image/qgos93rc1/ [^]][img]http://s32.postimg.org/qgos93rc1/bus_mpdn.jpg[/img][/url] [^]
-kodi krypton
[url=http://postimg.org/image/nqkn7n2g1/ [^]][img]http://s32.postimg.org/nqkn7n2g1/bus_kodi.jpg[/img][/url] [^]

skin tone:
-madvr
[url=http://postimg.org/image/pv6xv90v5/ [^]][img]http://s32.postimg.org/pv6xv90v5/skin_tone_madvr.jpg[/img][/url] [^]
-mpdn
[url=http://postimg.org/image/vhxtzrsm9/ [^]][img]http://s32.postimg.org/vhxtzrsm9/skin_tone_mpdn.jpg[/img][/url] [^]
-kodi
[url=http://postimg.org/image/uebvibc81/ [^]][img]http://s32.postimg.org/uebvibc81/skin_tone_kodi.jpg[/img][/url] [^]

madvr seems pushing too much red.

kind regards
TagsNo tags attached.
madVR Version0.90.17
Media Player (with version info)MPC-HC.1.7.10.207.x64
Splitter (with version info)LAVFilters-0.68.0-28
Decoder (with version info)LAVFilters-0.68.0-28
DecodingDXVA2 Copyback
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop Composition<select>
Problem occurs with modeall modes
GPU ManufacturerIntel
GPU ModelHD 5000
GPU Driver Version15.40.13.4331
Attached Files

- Relationships

-  Notes
(0001322)
madshi (administrator)
2016-05-04 15:16
edited on: 2016-05-04 15:16

The 2nd screenshot definitely looks too red.

Try resetting MPC-HC settings to default. Maybe the saturation slider got set too a non-neutral value?

(0001323)
sat4all (reporter)
2016-05-04 15:30
edited on: 2016-05-04 15:30

I've tried to reset mpc-hc, unfortunately without change.
I forgot to mention that i have the same prob with mpc-be + madvr.

Thanks

(0001324)
madshi (administrator)
2016-05-04 15:58

Can you make a small sample which contains the 2nd screenshot (the one with the man lying on the floor)?
(0001325)
sat4all (reporter)
2016-05-04 16:00

Ok i will see what i can do with my upload speed.
(0001326)
madshi (administrator)
2016-05-04 16:48

The sample can be *really* small. Just needs to contain the 2nd screenshot, so we can compare result on your vs my PC.
(0001327)
sat4all (reporter)
2016-05-04 16:59

https://drive.google.com/open?id=0B1R8sNbhXOkEOWRaVkU1a3dRcDQ [^]
(0001328)
madshi (administrator)
2016-05-04 17:16

This looks like a bad user encode to me.

The h264 bitstream contains the field "colour_primaries = 8". Which according to the h264 spec means "Generic film (colour filters using Illuminant C)". And if you look into the madVR OSD (Ctrl+J), you'll see that madVR detects this properly and renders the video with the appropriate colors.

It's all the other video renderers which do it wrong, only madVR does it "correctly". madVR looks bad because the video bitstream probably contains wrong information.

Press Ctrl+Alt+Shift+P multiple times to switch to BT.709, that should work around the problem. Or add the text "primaries=bt.709" to the file name.
(0001329)
sat4all (reporter)
2016-05-04 17:23

thank you very much, i tought it's madvr fault bcs other renderers hide the problem.

thanks again for your precious time.
(0001330)
sat4all (reporter)
2016-05-04 17:25

bad encode.

- Issue History
Date Modified Username Field Change
2016-05-04 14:02 sat4all New Issue
2016-05-04 15:16 madshi Note Added: 0001322
2016-05-04 15:16 madshi Note Edited: 0001322 View Revisions
2016-05-04 15:30 sat4all Note Added: 0001323
2016-05-04 15:30 sat4all Note Edited: 0001323 View Revisions
2016-05-04 15:58 madshi Note Added: 0001324
2016-05-04 16:00 sat4all Note Added: 0001325
2016-05-04 16:48 madshi Note Added: 0001326
2016-05-04 16:59 sat4all Note Added: 0001327
2016-05-04 17:16 madshi Note Added: 0001328
2016-05-04 17:23 sat4all Note Added: 0001329
2016-05-04 17:25 sat4all Note Added: 0001330
2016-05-04 17:25 sat4all Status new => closed
2016-05-04 17:25 sat4all Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker