madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000443madVRbugpublic2016-11-05 23:482016-11-07 17:09
ReporterIshtarr 
Assigned ToIshtarr 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionno change required 
Platformx64OSWindowsOS Version8.1
Summary0000443: Present queue not filling in MPC-HC when in Fullscreen
DescriptionWhen I try to play any video in fullscreen mode, present queue will choke down to 0-8 (2-8 at best). It doesn't matter if I use 'fullscreen exclusive' option or not - present queue will not work in either of them. Windowed mode, on the other hand, works fine and without any drops.
Steps To ReproduceI'm afraid I can't tell how to reproduce my problem, since I still haven't found a solution to it.
Additional InformationI know that madvr worked fine 0000001:0000003 month or so ago. And since I know what settings my hardware can handle, I rarely change them. In that time, the only thing that changed was an upgrade to a new version of madvr and a new nvidia driver.

Now, what I already tried to fix present queue drops:
*. Set all settings in madvr to their lowest (disabled additional features, like 'reduce artifacts', 'image enhancement', 'smooth motion'; set dithering to none; set scaling algirithms to Mitchell-Netravaly).
*. Used 'restore default settings.bat' file.
*. Updated madvr from 0.90.23 to 0.90.24.
*. Downgraded madvr from 0.90.24 to 0.90.
*. Updated LAV Filters to 0.68.1.
*. Tried to use different decoding (DXVA2 Native, CUDA).
*. Uninstalled MPC-HC, installed K-Lite Mega Pack 12.5.0 and restored all settings to their default.
*. Updated Nvidia driver from 372.70 to 375.70.
*. Installed it again, this time using 'clean installation' option.

So far, no luck in finding a solution. I'm open to suggestions of where to look.
TagsNo tags attached.
madVR Version0.90.24
Media Player (with version info)MPC-HC 1.7.10.264 (903092e) x86
Splitter (with version info)LAV Splitter 0.68.1.33-git
Decoder (with version info)LAV Video 0.68.1.33-git
DecodingDXVA2 Copyback
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOff
Problem occurs with modefullscreen exclusive mode
GPU ManufacturerNVidia
GPU Model560Ti 1GB 256bit
GPU Driver Version375.70
Attached Filesjpg file icon fullscreen_mode.jpg [^] (61,506 bytes) 2016-11-05 23:48

- Relationships

-  Notes
(0001487)
madshi (administrator)
2016-11-06 09:24

Do you have f.lux or any other software running which also accesses the GPU?
(0001488)
Ishtarr (reporter)
2016-11-06 10:18

Holy Jesus, I spent all night trying to pinpoint my issue, testing everything from software to hardware, finally managed to make madvr work without any drops by disabling DX11 presentation and fullscreen exclusive mode... and it was a recent installation of f.lux that cased this problem D=
I feel so silly now.

Thank you for your prompt reply, madshi. I suppose, there's no way to make f.lux compatible with madvr, so I'll have to disable it every time I want to watch something in fullscreen?
(0001489)
madshi (administrator)
2016-11-06 10:58

You could try talking to f.lux about this. I don't think there's anything I can do. I believe it's f.lux's fault.
(0001490)
Ishtarr (reporter)
2016-11-06 11:05

Sure, will do.
(0001491)
Ishtarr (reporter)
2016-11-06 11:55

Basically, I need to enable 'Safe Mode' in f.lux if I want to watch a movie in fullscreen. This way, it won't interfere with madvr.
With this, my issue has been resolved. Thanks again for suggesting to check f.lux.

- Issue History
Date Modified Username Field Change
2016-11-05 23:48 Ishtarr New Issue
2016-11-05 23:48 Ishtarr File Added: fullscreen_mode.jpg
2016-11-06 09:24 madshi Note Added: 0001487
2016-11-06 10:18 Ishtarr Note Added: 0001488
2016-11-06 10:58 madshi Note Added: 0001489
2016-11-06 11:05 Ishtarr Note Added: 0001490
2016-11-06 11:55 Ishtarr Note Added: 0001491
2016-11-07 17:09 Ishtarr Status new => resolved
2016-11-07 17:09 Ishtarr Resolution open => no change required
2016-11-07 17:09 Ishtarr Assigned To => Ishtarr


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker