madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000478madVRbugpublic2017-04-24 02:322017-04-25 20:11
Reporterflokke 
Assigned Toflokke 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformPCOSWindows OS Version10 x64
Summary0000478: My control panel won't open no tray icon and when i click on the filter in my video and hit show icon/edit settings nothing
DescriptionThe MadVR Control Panel will not show up or even open. MadVR is being used in MPC-HC because the overlay that shows up is madvr's but when i try to open it manually via the filters list it opens up a second instance in my process list but nothing shows up. It does the same thing with the process list addition but nothing shows when i click the Show Tray Icon.
Steps To ReproduceOpen basically every video in my library.
Additional Informationi don't know if my processor matters but I am running a Ryzen 1800x again don't know if this matters since i've had this working before. I have already tried doing a windows refresh from scratch but it didn't help.
TagsNo tags attached.
madVR VersionTried 91.8, .7, .6 and .1
Media Player (with version info)MPC-HC 1.7.11 64-bit
Splitter (with version info)LavFilter .69
Decoder (with version info)LavFilter .69
DecodingDXVA2 Copyback
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOff
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGeforce GTX 1080
GPU Driver Version381.65
Attached Filesjpg file icon F8XFeoq.jpg [^] (681,865 bytes) 2017-04-24 02:32

- Relationships

-  Notes
(0001635)
madshi (administrator)
2017-04-24 09:35

Does "madHcCtrl.exe" exist in the madVR folder? Does it have the typical "MAD" icon assigned to it? Maybe the file is missing or corrupted. You can try redownloading madVR and overwriting the files, just to be safe.

If that's not it, it could be NTFS access rights stopping madHcCtrl.exe from running. Make sure your user has read/execute rights to run madHcCtrl.exe. Finally, it could be your security (anti-virus, anti-trojan) software blocking madHcCtrl.exe from running, for some weird reason.
(0001636)
flokke (reporter)
2017-04-24 16:32

So I did a little bit of playing around last night with this as I was getting really frustrated with it and decided to do a "Fresh" Boot as Microsoft calls it where the only thing that starts up on the computer is the microsoft services and for some odd reason the Control Panel started up just fine. When I turned everything back on and restarted the computer it starts up if I go and manually open it up without a video. If I close out of it and go to open a video it does the no control panel again. I think that something is conflicting with it when I have time later I will go through each process one by one and see which one it is.
(0001637)
madshi (administrator)
2017-04-24 16:47

Did you change the location of the files? madVR(64).ax tries to start madHcCtrl.exe, but they need to be in the same folder for that to work. Or maybe you have 2 folders where madVR is in? One the media players loads madVR(64).ax from, and a different one where madHcCtrl.exe is located?

As I said, it could still also be NTFS access rights or some anti-something software which might block madVR(64).ax from starting madHcCtrl.exe.
(0001638)
flokke (reporter)
2017-04-24 16:51

I run the uninstaller everytime i move the files but i did do a check just now of my system and it's only in my Documents folder there are no other instances of MadVR anywhere else. I'm running windows defender at the moment so I will check to see if that's it

On the other point I'm not sure how to chance the NTFS access rights as that's not something i've ever delved into myself but if you know what i need to do to check I will do that as well.
(0001639)
madshi (administrator)
2017-04-24 16:54

Which user account does the media player run under? If it's a different user (e.g. admin) then it might not have access to your Documents folder. However, if it doesn't, then not even loading madVR(64).ax should work, so I doubt that's the problem. As a test, you could try moving madVR to program files and installing it there, even if only to check if that changes anything...
(0001640)
flokke (reporter)
2017-04-24 17:04

Nope didn't change a thing. I think that once my pc starts up some service that I added has to be causing conflict with MadVR. And there is only one user on my pc which is me and I have full admin rights too it.
(0001641)
flokke (reporter)
2017-04-25 20:10

So I finally got around to 1 by 1 enabling services and start up programs and come to find out Nahimic's latest release is causing the bug. I've had Nahimic on my PC before with MadVR so something they changed must be causing conflict as this is a more important program to me I'll be doing without Nahimic.
(0001642)
flokke (reporter)
2017-04-25 20:11

Nahimic 2 Current release bugs out MadVR.

- Issue History
Date Modified Username Field Change
2017-04-24 02:32 flokke New Issue
2017-04-24 02:32 flokke File Added: F8XFeoq.jpg
2017-04-24 09:35 madshi Note Added: 0001635
2017-04-24 16:32 flokke Note Added: 0001636
2017-04-24 16:47 madshi Note Added: 0001637
2017-04-24 16:51 flokke Note Added: 0001638
2017-04-24 16:54 madshi Note Added: 0001639
2017-04-24 17:04 flokke Note Added: 0001640
2017-04-25 20:10 flokke Note Added: 0001641
2017-04-25 20:11 flokke Note Added: 0001642
2017-04-25 20:11 flokke Status new => resolved
2017-04-25 20:11 flokke Resolution open => fixed
2017-04-25 20:11 flokke Assigned To => flokke


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker