madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000480madVRbugpublic2017-06-03 14:342017-06-30 14:50
ReporterAxaion 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformPCOSWindowsOS Version10 Pro
Summary0000480: Enabling "Direct3D 11 for presentation" causes blocky video playback when not full-screened
DescriptionSo, i was actually in the MPC-HC channel a week or two back, and reported the same issue

What happens is if i enable the said setting, i get extreme blockiness on video playback untill i fullscreen the video (doesnt matter if automatic fullscreen exclusive mode is on or not)

Steps To ReproduceEnable "use Direct3D 11 for Presentation" in MadVR
Additional InformationThis is the only video playback bug i have, or graphic bug of any kind on my system
System is the following
CPU: 2500k @ 4.5Ghz
Mobo: Asrock z68 Extreme4
Ram: 16GB 1866Mhz DDR3 1.5
PSU: 650w Corsair AX 650

GPU: Nvidia GTX 970, Driver version: GeForce Game Ready Drivers ver. 382.33, I tried a few others too, same issue.
TagsNo tags attached.
madVR Version0.91.10, 0.91.09
Media Player (with version info)MPC-HC 1.7.11, - 1.7.10, - 1.7.9, - 1.7.8
Splitter (with version info)LAV 0.69.0.87, LAV internal 0.69.0 from MPC-HC 17.11, didnt check the others
Decoder (with version info)LAV Video Decoder 0.69.0.87, LAV Video Decoder 0.69.0 internal
DecodingDXVA2 Copyback
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modewindowed mode
GPU ManufacturerNVidia
GPU ModelGTX 970
GPU Driver Version382.33
Attached Filespng file icon ItsonAcid.png [^] (2,359,254 bytes) 2017-06-03 14:34

- Relationships

-  Notes
(0001647)
madshi (administrator)
2017-06-03 14:38

Are you using NNEDI3?
(0001648)
Axaion (reporter)
2017-06-03 14:43
edited on: 2017-06-03 14:44

Nope, my MadVR settings are these:
Processing: Automatically activate deinterlacing when needed -> If in doubt deactivate deinterlacing
Only look at pixels in the frame center

Zoom Control: Disable Scaling if image size changes by only: ... 2 lines or less
Move Subtitles: ... to bottom of the screen/window

Chroma Upscaling: NGU, Anti-Alias, Low Quality
Image Downscaling: SSIM: 1D -Strength 75%, Scale in Linear Light, Activate anti-ringing filter: Relaxed - Activate anti-bloating filter: Strength: 100%

Image Upscaling: NGU Anti-Alias
Algo Qual Luma doubling, Low (rest in that section untouched)

Only wrote the settings i have ticked on
I tried to set it to JINC too, didnt change a thing

(0001649)
madshi (administrator)
2017-06-03 15:50

No idea why that happens. No other madVR users has reported a similar issue. One thing you could try is to restore madVR to default settings and see if that makes a difference.

This is probably either a GPU driver problem, or a GPU hardware problem... :-(
(0001650)
Axaion (reporter)
2017-06-03 21:29

Yeah its odd as hell, i should add, this doesnt happen with the last version of KCP

I reinstalled windows before making this topic though, so its not KCP messing with settings

Also just tried to restore to defaults, of course its gone there, because by default that specific setting is not ticked, the moment i ticked it, and then closed and re-opened a new video it was there again

I'll try installing older versions of MadVR up till a few years back, maybe if im lucky ill find one where it works - and might give an idea on whats going on
(0001651)
Axaion (reporter)
2017-06-03 22:06

Right; I installed MadVR versions from the newest down till madVR 0.87.21
It still happens all the way down to that one, obviously not on 0.87.21, because the option wasent added back then

Another thing i just remembered, it only happens with x64 versions of MadVR, if i use x86, along with x86 MPC-HC, it doesnt happen

But x86 kinda negates any performance id gain from the setting
(0001652)
Axaion (reporter)
2017-06-03 22:17

Last notes; then i guess you can close it, since you cant reproduce it

It only happens with the LAV Video Decoder splitter set to "DXVA2(Native)" and "DXVA2 (copy/back)"

It does not happen when its set to "Nvidia CUVID" or "None"

However, when its set to Nvidia CUVID, it doesnt use the onboard PureVideo Chip, and loads my CPU and GPU more than with DXVA2 Settings, while the Video Engine Load (In GPU-Z) is at 0%, versus 5-15% with DXVA2

Im fairly certain thats all the info i got =\
(0001653)
madshi (administrator)
2017-06-06 14:03

This is such a weird situation, this only happening when you combine DXVA2 decoding and D3D11 presentation, that I don't really know what to say, especially because nobody else seems to have this specific problem. I don't even know what to suggest right now. The only things coming to my mind right now would would be to update the GPU BIOS, or to reinstall the OS. But I have doubts that either of this would help.

Can you live without the D3D11 presentation? You'll lose 10bit output capability, and HDR metadata support. But other than that, there should be no noticeable disadvantage.
(0001654)
Axaion (reporter)
2017-06-06 14:08

Oh, I thought i mentioned that, i have reinstalled since first encountering this error, like 5 times or something like that actually.

my GPU bios is fully updated, there has been no update to it since i updated it the first time, checked it like a week ago too

Yeah, im living without it right now - just annoys me that i lose performance, and thus being able to use some better shaders, but i doubt ill have the same hardware i have now, once i get a HDR Capable monitor, or even a 10-bit one.

Just thought id see if there was a fix, in case you were wondering its a MSi GTX 970 Gaming 4G (1st rev)

Or in case anyone else reads this with the same issue, hah.

I guess ill close the ticket then, not much you can do when my PC seems to be possesed
(0001655)
madshi (administrator)
2017-06-06 14:11

You don't happen to have an older/different NVidia GPU lying around for double checking?

Using D3D11 should not really improve performance at all. At least it usually doesn't. The key thing you lose should just be 10bit output and HDR metadata. If you found that D3D11 actually does improve performance for you, then maybe using the option "use a separate device for presentation" might achieve the same speedup?
(0001656)
Axaion (reporter)
2017-06-06 14:17

I probably do somewhere, ill have a look when i get the chance.

Well, from what i can tell with CTRL + J, my render times go down by 2ms~ (from 15.x to 13.x), Use seperate presentation did nothing

Guess its just nit picking for so little, lol - cause theres no way im getting HDR with this CPU and GPU anyway.
(0001657)
madshi (administrator)
2017-06-06 14:24

I wouldn't put too much weight on the 2ms render time difference. It could be as simple as the measurement being slightly off, due to different render paths being used, different flushes being made etc. If you can actually achieve better image quality settings without frame drops, *that* would be worth worrying about.
(0001658)
Axaion (reporter)
2017-06-06 14:25

Ah, no i dont have any framedrops
(0001699)
Axaion (reporter)
2017-06-30 14:49

Can close this now, newst driver update (that crashes watch dogs2, lol) seems to have fixed it!
(0001700)
Axaion (reporter)
2017-06-30 14:50

Video Driver update as of 30th~ June fixed this for me.

- Issue History
Date Modified Username Field Change
2017-06-03 14:34 Axaion New Issue
2017-06-03 14:34 Axaion File Added: ItsonAcid.png
2017-06-03 14:38 madshi Note Added: 0001647
2017-06-03 14:43 Axaion Note Added: 0001648
2017-06-03 14:44 Axaion Note Edited: 0001648 View Revisions
2017-06-03 15:50 madshi Note Added: 0001649
2017-06-03 21:29 Axaion Note Added: 0001650
2017-06-03 22:06 Axaion Note Added: 0001651
2017-06-03 22:17 Axaion Note Added: 0001652
2017-06-06 14:03 madshi Note Added: 0001653
2017-06-06 14:08 Axaion Note Added: 0001654
2017-06-06 14:11 madshi Note Added: 0001655
2017-06-06 14:17 Axaion Note Added: 0001656
2017-06-06 14:24 madshi Note Added: 0001657
2017-06-06 14:25 Axaion Note Added: 0001658
2017-06-30 14:49 Axaion Note Added: 0001699
2017-06-30 14:50 Axaion Note Added: 0001700
2017-06-30 14:50 Axaion Status new => closed
2017-06-30 14:50 Axaion Resolution open => no change required


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker