madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000492madVRbugpublic2017-07-27 17:302017-07-27 17:59
Reporterlostcup 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformPCOSWindowsOS Version10
Summary0000492: HDR color all wrong and go black in fullscreen mode
DescriptionI'm trying to playback HDR video on my PC with GTX1050 and Ryzen 1700X CPU. No matter how to change in madVR HDR settings. Fullscreen display are always wrong. Everything goes to black. Check the screenshot attached. Is this a bug or setting problem?
Steps To ReproduceOpen a HDR file
Go fullscreen
TagsNo tags attached.
madVR Versionv0.91.11
Media Player (with version info)MPC-HC 64bit 1.7.13.1
Splitter (with version info)LAV 0.70.2.4
Decoder (with version info)LAV 0.70.2.4
DecodingDXVA2 Native
Deinterlacingauto mode
DXVA2 Scaling Activeyes
Aero / Desktop CompositionOff
Problem occurs with modefullscreen exclusive mode
GPU ManufacturerNVidia
GPU ModelGTX1050
GPU Driver VersionForceware 384.76
Attached Filesjpg file icon snipaste_20170727.jpg [^] (163,592 bytes) 2017-07-27 17:30

- Relationships

-  Notes
(0001747)
madshi (administrator)
2017-07-27 17:59

I know this problem from AMD GPUs but not from Nvidia GPUs. Anyway, this probably has to do with DXVA color conversion. Try unchecking the two "trade quality" settings "use DXVA chroma upscaling when [...]". Furthermore, make sure you don't use DXVA luma up & down scaling.

If all else fails, using DXVA Copyback instead of Native might also do the trick.

- Issue History
Date Modified Username Field Change
2017-07-27 17:30 lostcup New Issue
2017-07-27 17:30 lostcup File Added: snipaste_20170727.jpg
2017-07-27 17:59 madshi Note Added: 0001747


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker