madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000504madVRbugpublic2017-09-17 15:342017-09-25 16:07
Reporterjonaszimm 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOSMicrosoft Windows 7 ProfessionalOS Version6.1.7601
Summary0000504: Subtitles are rendered to incorrect positions in screenshots with the option "encoded video size" enabled
DescriptionWhen enabling the option "encoded video size" to "create screenshots with a custom zoom factor" the subtitles are rendered to incorrect positions in the following screenshots.
Steps To Reproduce*Open any video file containing an ASS subtitle stream
*Enable the option "encoded video size" to "create screenshots with a custom zoom factor" in the subsection "screenshot" of the section "rendering" in the madVR control panel and apply the settings
*Proceed taking a screenshot in either windowed, full screen or exclusive full screen mode
*Notice the behaviour as described above
Additional InformationThis issue can be reproduced in either display mode (windowed, full screen or exclusive full screen). When taking a screenshot in windowed mode, the subtitles are rendered ABOVE the initial position, while being rendered BELOW when viewing the video in either full screen or exclusive full screen mode, as pictured on the attached file.

No other settings of madVR v0.92.3 – apart from the option "encoded video size" to "create screenshots with a custom zoom factor" – have been altered in the control panel and were left as is after the installation. Additionally, the execution of "restore default settings.bat" has been issued before installing the newest version of madVR.
TagsNo tags attached.
madVR Version0.92.3
Media Player (with version info)MPC-HC 1.7.3.112
Splitter (with version info)LAV Splitter 0.70.2.66-git
Decoder (with version info)LAV Video Decoder 0.70.2.66-git
Decoding<select>
Deinterlacing<select>
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU ModelAMD Radeon HD 7340
GPU Driver Version15.301.1901.0
Attached Filespng file icon [HorribleSubs] Katsugeki Touken Ranbu - 12 [720p].mkv_snapshot_00.02_[2017.09.17_15.23.05].png [^] (1,943,021 bytes) 2017-09-17 15:34
? file icon [HorribleSubs] Katsugeki Touken Ranbu - 12 [720p].mkv [^] (2,552,095 bytes) 2017-09-19 11:40

- Relationships

-  Notes
(0001806)
jonaszimm (reporter)
2017-09-18 11:11

I may add that the subtitles are being rendered by XySubFilter 3.1.0.746 BETA3 in its default configuration.
(0001807)
madshi (administrator)
2017-09-18 15:25

Does it work with 100% zoom setting instead of encoded video size?

A little sample would be great!
(0001809)
jonaszimm (reporter)
2017-09-19 11:41

The subtitles are not being rendered at their correct position with ANY custom zoom factor while using while using XySubFilter. Not even with every other option – apart from "create screenshots with a custom zoom factor" in "screenshots"– disabled. Additionally, I have come to the conclusion that this issue does not occur with the internal subtitle renderer of MPC-HC. I think it's save to say that this issue is most likely caused by XySubFilter itself.

I have now included a ten second long sample of the very same video viewed when issuing this report.
(0001810)
madshi (administrator)
2017-09-24 14:56

I've now tried to reproduce the problem - but I can't. It always works fine for me. This is with playback paused or running. I've even tried zooming playback to fill my 4K TV, but still the 100% screenshot comes out just fine.

Using MPC-HC 32bit.

Are you maybe using some special XySubFilter settings? Or maybe I am? I don't think so, but I'm not really such a big expert on XySubFilter settings...
(0001811)
jonaszimm (reporter)
2017-09-25 14:30

I reset the settings of XySubFilter to their default before uninstalling and installing XySubFilter anew but the issue remained. On a side note, I haven't been able to reproduce the issue with any other video file since issuing this report. Therefore I suspected the subtitle stream of the original video file itself to be the reason but I couldn't find any clues, as the position of the default style was correctly set to its default anchor at the lower end of the video.

As long as no other reports of this very issue are being filled out, I would like to consider it an isolated incident, as I could only reproduce the issue with the attached video file.
(0001812)
madshi (administrator)
2017-09-25 16:07

Interesting. I do wonder why this only occurs with 1 file. Anyway, I would still look into it, if I only could reproduce it here - but I can't. So because of these 2 combined factors: a) Only happens with one file and b) I can't reproduce it even with this one file, I'd say we should ignore this for now.

- Issue History
Date Modified Username Field Change
2017-09-17 15:34 jonaszimm New Issue
2017-09-17 15:34 jonaszimm File Added: [HorribleSubs] Katsugeki Touken Ranbu - 12 [720p].mkv_snapshot_00.02_[2017.09.17_15.23.05].png
2017-09-18 11:11 jonaszimm Note Added: 0001806
2017-09-18 15:25 madshi Note Added: 0001807
2017-09-19 11:40 jonaszimm File Added: [HorribleSubs] Katsugeki Touken Ranbu - 12 [720p].mkv
2017-09-19 11:41 jonaszimm Note Added: 0001809
2017-09-24 14:56 madshi Note Added: 0001810
2017-09-25 14:30 jonaszimm Note Added: 0001811
2017-09-25 16:07 madshi Note Added: 0001812
2017-09-25 16:07 madshi Assigned To => madshi
2017-09-25 16:07 madshi Status new => acknowledged


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker