madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000517madVRbugpublic2017-11-03 10:532017-11-11 13:49
Reportertomli747 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSWindows 10OS Version1709
Summary0000517: Automatically detect hard coded black bars causes upload queue drop
DescriptionWhen automatically detect hard coded black bars is selected, the upload queue, render queue and present queue drop after a few minutes. The video stutters when those queues drop to 0 and the dropped frames increases.
Steps To ReproducePlay a video and wait for 7-10 minutes, the upload queue starts to drop.
TagsNo tags attached.
madVR Version0.92.8
Media Player (with version info)MPC-HC 1.7.13
Splitter (with version info)internal LAV 0.70.2.1
Decoder (with version info)internal LAV 0.70.2.1
DecodingSoftware
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOff
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGTX 1050 laptop
GPU Driver Version388.00
Attached Files

- Relationships

-  Notes
(0001882)
madshi (administrator)
2017-11-03 10:59

The black bar detection currently runs on the CPU, which means that if your CPU can't keep up, it will cause all the queues to empty. Can you monitor your CPU usage? How is it when the queues empty?
(0001883)
tomli747 (reporter)
2017-11-03 11:35

The CPU usage is about 20%
(0001884)
madshi (administrator)
2017-11-03 11:40

That's weird. I'm wondering what's so special about 7-10 minutes. If it works well in the first 7-10 minutes, why does it suddenly stop working afterwards? One thing worth trying is to set your GPU to "Adaptive" power mode. Users have reported problems with other power modes.
(0001885)
tomli747 (reporter)
2017-11-03 11:56

The problem still occurs after setting GPU to "Adaptive" power mode. The same problem also occurs on my desktop(MPC-BE, 1600X, RX480)
(0001886)
madshi (administrator)
2017-11-03 12:09

Does it there also occur after 7-10 minutes and runs fine at first?

Strange enough, my HTPC has had this feature enabled for many months now, and I've never run into any trouble. I'm not running the latest madVR build on my HTPC atm, though (too lazy to update). Did this work well for you in the past, and only started to get buggy recently?
(0001887)
tomli747 (reporter)
2017-11-03 12:19

Yes

It works well before February. And started to get buggy after July. Not sure about the exact time because I had stopped watching videos for a few months.
(0001888)
madshi (administrator)
2017-11-03 12:30

Ok, could be a Windows update, or a GPU driver update or madVR update. It's impossible for me to guess. The easiest check would be to try an old madVR build, which you can download here:

https://www.videohelp.com/software/madVR/old-versions#download [^]
(0001889)
tomli747 (reporter)
2017-11-03 12:38
edited on: 2017-11-03 12:38

I tried 0.91.7 and same problem occurred.

(0001890)
madshi (administrator)
2017-11-03 12:42

Do you happen to know which madVR version you were using when the problem did not occur?

FWIW, many users reported problems with 387+388 drivers. You could try going back to 385 drivers.
(0001891)
tomli747 (reporter)
2017-11-03 12:45

No, sorry.

I tried Radeon Crimson 17.4.1 and it doesn't work.
(0001892)
madshi (administrator)
2017-11-03 13:04

Are you running any 3rd party software in addition to madVR? E.g. GpuZ, f.lux, or anything else?
(0001893)
tomli747 (reporter)
2017-11-03 13:10

MPC-BE, LAV filter and madVR only
(0001894)
madshi (administrator)
2017-11-03 13:16

Well, then the only remaining options are either a problem with the OS or madVR build 0.91.7 wasn't old enough.
(0001895)
tomli747 (reporter)
2017-11-03 13:21

Which version should I try?
(0001896)
madshi (administrator)
2017-11-03 13:23

I don't really know. v0.89.0 introduced the black bar detection stuff. So you could try v0.89.0 and maybe some other random builds between that and v0.92.8.
(0001897)
tomli747 (reporter)
2017-11-03 16:11

v0.90.0 no problem, but v0.91.0 has.
(0001906)
madshi (administrator)
2017-11-09 10:10

I've implemented some performance improvements in v0.90.22. But those should actually *improve* performance, and users did report it helped. v0.90.21 and older did the whole work in a single thread. v0.90.22 and newer is using multiple threads (and thus multiple CPU cores) to do the work. So can you please try v0.90.21 vs v0.92.22?
(0001912)
tomli747 (reporter)
2017-11-09 17:24

v0.90.21 is fine, but v0.90.22 isn't. It seems all version after v0.90.22 has that problem.
(0001914)
madshi (administrator)
2017-11-09 18:40

Ok, at least we know now which change in madVR caused the issue for you. Strange enough, nobody else has reported this specific problem yet. For many other users the change in v0.90.22 was positive, because it allowed them to use the black bar detection feature for 4Kp60 videos which wasn't possible before.

I wonder if this might be a specific problem with your mainboard/GPU? E.g. it's possible that your mainboard or your GPU doesn't like if multiple different threads try to "upload" pixels via PCIe to your GPU at the same time. You could try updating your mainboard and/or GPU BIOS. Maybe it could help, but I'm not sure.

In the long run I plan to move the black bar detection from CPU to GPU. That should definitely solve this issue, on the cost of higher GPU use. But it's probably not going to be soon.
(0001915)
tomli747 (reporter)
2017-11-10 01:33
edited on: 2017-11-10 01:33

But the strange thing is I can reproduce this on both computers, one is 7700HQ + GTX1050, another is 1600X + RX 480, so I don't think it's a hardware problem. And there are other people have the same problem https://forum.videohelp.com/threads/384346-Intermittent-low-upload-queue-in-MPC-BE-madVR [^] .

(0001916)
madshi (administrator)
2017-11-10 10:17

Well, I'd need to be able to reproduce the problem somehow, otherwise there's not so much I can do about it, unfortunately. Does this problem occur with all videos, regardless of resolution, framerate and interlaced vs progressive type?
(0001917)
tomli747 (reporter)
2017-11-11 13:49

Yes, all videos

- Issue History
Date Modified Username Field Change
2017-11-03 10:53 tomli747 New Issue
2017-11-03 10:59 madshi Note Added: 0001882
2017-11-03 11:35 tomli747 Note Added: 0001883
2017-11-03 11:40 madshi Note Added: 0001884
2017-11-03 11:56 tomli747 Note Added: 0001885
2017-11-03 12:09 madshi Note Added: 0001886
2017-11-03 12:19 tomli747 Note Added: 0001887
2017-11-03 12:30 madshi Note Added: 0001888
2017-11-03 12:38 tomli747 Note Added: 0001889
2017-11-03 12:38 tomli747 Note Edited: 0001889 View Revisions
2017-11-03 12:42 madshi Note Added: 0001890
2017-11-03 12:45 tomli747 Note Added: 0001891
2017-11-03 13:04 madshi Note Added: 0001892
2017-11-03 13:10 tomli747 Note Added: 0001893
2017-11-03 13:16 madshi Note Added: 0001894
2017-11-03 13:21 tomli747 Note Added: 0001895
2017-11-03 13:23 madshi Note Added: 0001896
2017-11-03 16:11 tomli747 Note Added: 0001897
2017-11-09 10:10 madshi Note Added: 0001906
2017-11-09 17:24 tomli747 Note Added: 0001912
2017-11-09 18:40 madshi Note Added: 0001914
2017-11-10 01:33 tomli747 Note Added: 0001915
2017-11-10 01:33 tomli747 Note Edited: 0001915 View Revisions
2017-11-10 10:17 madshi Note Added: 0001916
2017-11-11 13:49 tomli747 Note Added: 0001917


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker