madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000532madVRbugpublic2018-01-06 23:392018-01-14 19:22
Assigned Tomadshi 
StatusclosedResolutionunable to reproduce 
PlatformMPC-HCOSWindowsOS Version10 x64
Summary0000532: madVR messes up player user interface during playback in full screen mode
DescriptionWhen a video is played using madVR, the player's user interface containing playback controls, seek bar, etc. does not show up properly. For example, there is no seek bar, or there are no playback control buttons, or they appear and disappear intermittently, most often when the mouse cursor is hovered over them.

This happens only when the player is in full screen mode (non-exclusive). I have tried with both MPC-HC and MPC-BE (both on their default settings), and in both cases the issue appears under mentioned conditions. With other renderers (for instance EVR, both default and Custom Presenter), the issue does not appear.

Interestingly, everything looks fine on screenshots taken directly from the OS, so the pictures that I attached to this report were taken using a cellphone.
Steps To ReproducePlay a video. Enter full screen mode (non exclusive, with or without the "enable windowed overlay" option enabled), for instance by pressing Alt-Enter. Hover mouse over the player's user interface (control bar). Optionally move mouse across the interface.
TagsNo tags attached.
madVR Version0.92.10
Media Player (with version info)MPC-HC 1.7.13 (e37826845)
Splitter (with version info)LAV Splitter
Decoder (with version info)Lav Video Decoder
DecodingDXVA2 Native
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modewindowed mode
GPU ManufacturerNVidia + Intel
GPU ModelIntel HD Graphics 630
GPU Driver Version23.20.16.4901
Attached Fileszip file icon [^] (2,984,117 bytes) 2018-01-06 23:39

- Relationships

-  Notes
madshi (administrator)
2018-01-09 11:36

Doesn't seem to happen on my PC. Is this an Optimus laptop? These are notoriously buggy. Do you have "use D3D11 for presentation" and/or "use a separate device for presentation" activated in the madVR settings? If so, please try to uncheck both. Does that help?
marko7 (reporter)
2018-01-09 11:44

Yes, I believe this is an Optimus laptop, however, in the cases that I have tried so far, only the integrated Intel graphics was being used. I do not have the "use a separated device..." option checked. Regarding the "use D3D11...", I tried both with and without that option checked, and it made no difference.
madshi (administrator)
2018-01-09 11:46

Well, you could try using the Nvidia GPU, but I'm not sure if that makes a difference. In any case, I suspect that this is most probably an Intel GPU driver bug. Nobody else has reported a similar issue yet, though, so it may be specific to some driver versions, or even some MPC-HC versions. So you could try different GPU driver versions and different MPC-HC versions.

Without being able to reproduce the issue, I probably can't do much about it, unfortunately... :-(
marko7 (reporter)
2018-01-09 11:58

OK, thank you for looking at the issue. I would report the issue to Intel, however, since it doesn't appear with other video renderers, I'm not sure I have a case for it being a driver bug. I'm not even sure the problem is a specific MPC-HC version, since I also tried with MPC-BE. What player do you use? Maybe I can try with that.
madshi (administrator)
2018-01-09 12:00

I'm using MPC-HC. But the problem doesn't occur with my (old) HD4000.
madshi (administrator)
2018-01-14 11:33

Have you had a chance to test with Nvidia? Also, any change if you switch to software decoding?
marko7 (reporter)
2018-01-14 18:33

Ok, I just tried it. Same thing happens with both Nvidia and software-only decoding.
madshi (administrator)
2018-01-14 18:41

Only remaining thing coming to my mind: Have you tried different Intel GPU driver versions? If that doesn't help then I'm out of ideas. If I could reproduce the issue here, I might be able to do something, but everything works fine here.
marko7 (reporter)
2018-01-14 18:44
edited on: 2018-01-14 18:45

Yes, I did try that. Currently I am using the latest drivers directly from Intel and Nvidia, respectively, but I tried reverting to two older versions and the issue remains (and it started appearing before I first installed this latest version that I'm currently using).

madshi (administrator)
2018-01-14 18:51

Have you tried exclusive mode? In that mode the media player GUI should not be visible at all, so it can't be screwed up... ;)
marko7 (reporter)
2018-01-14 19:03

Yes, indeed in Exclusive mode the issue does not reproduce :)
madshi (administrator)
2018-01-14 19:04

So, is this an acceptable workaround for you?

I believe this is a GPU driver issue, so even if you don't like the workaround, there's probably not much I can do about it, anyway... :(
marko7 (reporter)
2018-01-14 19:13

Ok. I might settle with that workaround, yes. I might also try reverting to an even older version of the Intel driver, as well as an older version of madVR and see what happens then. Even though a big advantage to the latest Intel graphics drivers is HDR support.
madshi (administrator)
2018-01-14 19:22

Ok, I'll close this bug report for now, then.

- Issue History
Date Modified Username Field Change
2018-01-06 23:39 marko7 New Issue
2018-01-06 23:39 marko7 File Added:
2018-01-09 11:36 madshi Note Added: 0001981
2018-01-09 11:44 marko7 Note Added: 0001982
2018-01-09 11:46 madshi Note Added: 0001983
2018-01-09 11:58 marko7 Note Added: 0001984
2018-01-09 12:00 madshi Note Added: 0001985
2018-01-14 11:33 madshi Note Added: 0001996
2018-01-14 11:33 madshi Assigned To => madshi
2018-01-14 11:33 madshi Status new => feedback
2018-01-14 18:33 marko7 Note Added: 0002076
2018-01-14 18:33 marko7 Status feedback => assigned
2018-01-14 18:41 madshi Note Added: 0002077
2018-01-14 18:41 madshi Status assigned => feedback
2018-01-14 18:44 marko7 Note Added: 0002078
2018-01-14 18:44 marko7 Status feedback => assigned
2018-01-14 18:45 marko7 Note Edited: 0002078 View Revisions
2018-01-14 18:51 madshi Note Added: 0002079
2018-01-14 18:51 madshi Status assigned => feedback
2018-01-14 19:03 marko7 Note Added: 0002083
2018-01-14 19:03 marko7 Status feedback => assigned
2018-01-14 19:04 madshi Note Added: 0002085
2018-01-14 19:04 madshi Status assigned => feedback
2018-01-14 19:13 marko7 Note Added: 0002088
2018-01-14 19:13 marko7 Status feedback => assigned
2018-01-14 19:22 madshi Note Added: 0002090
2018-01-14 19:22 madshi Status assigned => closed
2018-01-14 19:22 madshi Resolution open => unable to reproduce

Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker