madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000535madVRbugpublic2018-01-16 19:472018-01-23 19:46
Reporterjmonier 
Assigned Tomadshi 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSWindowsOS Version8.1
Summary0000535: HDR is turned back on after playback file is closed
DescriptionWhen the playback file is closed after playback stops, HDR appears to be turned off, but after 1 sec or so it is turned back on. It then stays on until the player is closed, when it is turned off. This occurs with the Nvidia Win 7/8 driver versions starting with 385.69 up to the current driver (390.65). The problem does not occur with 385.41 and below. Note that if playback is stopped without closing the file, nothing happens, i.e. HDR remains on. This has been tested with Zoomplayer and MPC-HC.
Steps To ReproduceSee above
Additional InformationNote that the Win 7/8 driver is a different driver than the Win 10 driver and behaves somewhat differently, e.g. there is no problem turning on HDR for any recent version.

Just as an FYI, driver 390.65 resets "Output Dynamic Range" to "Limited" (from "Full") whenever the computer is rebooted. Earlier versions do not have this problem.
TagsNo tags attached.
madVR Version 0.92.11
Media Player (with version info)Zoomplayer 14.1 beta 2, MPC-HC 1.7.13
Splitter (with version info)LAV 0.72.2.82-git
Decoder (with version info)LAV 0.72.2.82-git (D3D11 decoding)
Decoding<select>
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOff
Problem occurs with modewindowed mode
GPU ManufacturerNVidia
GPU ModelGTX1070
GPU Driver Version385.69 up
Attached Fileszip file icon madVR - log.zip [^] (1,074,891 bytes) 2018-01-18 23:32

- Relationships

-  Notes
(0002143)
madshi (administrator)
2018-01-16 19:53

Can you please create a debug log (as short as possible) which shows the problem with closing the file, HDR -> off -> on? Please zip it before attaching it, thanks.
(0002207)
madshi (administrator)
2018-01-22 19:31

According to the log file it seems that madVR does everything correctly. I don't have a win7/win8 test PC, anymore, so I can't test it. On win10 I can't reproduce the problem.

I'll report the problem to my Nvidia contact.

I'll close this bug report, because there's simply nothing I can do (except reporting the issue to Nvidia).
(0002208)
madshi (administrator)
2018-01-22 19:41

Actually, after double and triple checking, I'm not sure, it could be my fault, after all.

Are you 100% sure that the issue does not occur with drivers 385.41 and below?
(0002209)
madshi (administrator)
2018-01-22 19:44

Here's a test build, does it change anything?

http://madshi.net/madVRHdrTest.zip [^]
(0002210)
jmonier (reporter)
2018-01-23 01:48

The test build does not change anything.

The problem is there for EVERY build 385.69 and above. It is definitely not there on 385.41 but I have not checked any below that.
(0002211)
jmonier (reporter)
2018-01-23 01:50

It's too bad that you don't have a win 8 machine any more since the Nvidia win8 driver is apparently significantly different from the win10 driver.
(0002212)
madshi (administrator)
2018-01-23 09:25

Ok, can you please do the following test for me:

While HDR playback is running, use the task manager to terminate all "madHcCtrl.exe" processes (there are probably at least 2, maybe more). Please use the "details" tab in the task manager, not the first tab.

How does that affect things when you close the file, and when you close the media player?
(0002213)
jmonier (reporter)
2018-01-23 17:29

After terminating all "madHcCtrl.exe" processes (there are 2) HDR simply stays on when the file is closed (it would go off and then on again otherwise).

When the player is closed HDR goes off (which is the same in either case).
(0002215)
madshi (administrator)
2018-01-23 17:39

Ok, next (and probably final) test:

After terminated all madHcCtrl.exe processes, please also violently terminate the media player, so neither the media player nor madVR have a chance to turn off HDR. Does HDR automatically turn off in that moment when you terminate the media player process?

It's very important that you terminate *all* madHcCtrl.exe processes first, before you terminate the media player, because otherwise the madHcCtrl.exe processes will turn HDR off. Basically I need to know if the Nvidia GPU driver itself turns HDR off when the media player process dies.
(0002218)
jmonier (reporter)
2018-01-23 18:52

Yes, HDR IS turned off, even when I used Task Manager to terminate the player process.
(0002219)
madshi (administrator)
2018-01-23 19:03

I suppose this build probably fixes the issue?

http://madshi.net/madVRhdrTest.rar [^]

FWIW, even if it does, I will probably not use this fix. It looks like a driver issue, and I'll probably rely on Nvidia fixing the issue instead. Of course I'll report it to the Nvidia dev.
(0002220)
jmonier (reporter)
2018-01-23 19:43

Yes, that fixes it. Since 385.41 seems to work just as well as more recent versions for me in all other respects, I'll probably go back to that one until Nvidia fixes the problem.

If it's no trouble, could you also report the problem with the 390.65 driver where the "Output Dynamic Range" gets set to "Limited" upon a reboot.
(0002221)
madshi (administrator)
2018-01-23 19:46

Ok, will report both issues, and now close this bug report, but it's really not a bug in madVR.

- Issue History
Date Modified Username Field Change
2018-01-16 19:47 jmonier New Issue
2018-01-16 19:53 madshi Note Added: 0002143
2018-01-16 19:53 madshi Assigned To => madshi
2018-01-16 19:53 madshi Status new => feedback
2018-01-18 23:32 jmonier File Added: madVR - log.zip
2018-01-21 21:30 madshi Status feedback => assigned
2018-01-22 19:31 madshi Note Added: 0002207
2018-01-22 19:31 madshi Status assigned => closed
2018-01-22 19:31 madshi Resolution open => not fixable
2018-01-22 19:40 madshi Assigned To madshi =>
2018-01-22 19:41 madshi Assigned To => madshi
2018-01-22 19:41 madshi Note Added: 0002208
2018-01-22 19:41 madshi Status closed => feedback
2018-01-22 19:41 madshi Resolution not fixable => reopened
2018-01-22 19:44 madshi Note Added: 0002209
2018-01-23 01:48 jmonier Note Added: 0002210
2018-01-23 01:48 jmonier Status feedback => assigned
2018-01-23 01:50 jmonier Note Added: 0002211
2018-01-23 09:25 madshi Note Added: 0002212
2018-01-23 09:25 madshi Status assigned => feedback
2018-01-23 17:29 jmonier Note Added: 0002213
2018-01-23 17:29 jmonier Status feedback => assigned
2018-01-23 17:39 madshi Note Added: 0002215
2018-01-23 17:39 madshi Status assigned => feedback
2018-01-23 18:52 jmonier Note Added: 0002218
2018-01-23 18:52 jmonier Status feedback => assigned
2018-01-23 19:03 madshi Note Added: 0002219
2018-01-23 19:03 madshi Status assigned => feedback
2018-01-23 19:43 jmonier Note Added: 0002220
2018-01-23 19:43 jmonier Status feedback => assigned
2018-01-23 19:46 madshi Note Added: 0002221
2018-01-23 19:46 madshi Status assigned => closed
2018-01-23 19:46 madshi Resolution reopened => no change required


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker