madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000541madVRbugpublic2018-02-25 04:102018-09-27 08:55
Reporterloco 
Assigned Tomadshi 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformWindowsOSWindows 10 Enterprise 2016 LTSBOS Version1607
Summary0000541: Fulscreen exclusive mode doesn't work
DescriptionHello!
"enable automatic fulscreen exclusive mode" checkbox doesn't do anything.
PotPlayer doesn't use FSE and when I press Ctrl+j can see the following info: "D3D11 fulscreen windowed (8 bit)".
Actually, I have 10-bit Sony KD-55XE9005 TV, but can't force madVR to output 10 bit.
Steps To Reproduce1) "enable automatic fulscreen exclusive mode" checkbox - ok
2) PotPlayer -> Settings -> Video -> Fulscreen exclusive mode -> Enable: Fastest
3) Start to playback videofile -> Enter to go Fulscreen -> Press Ctrl+j for info -> "D3D11 fulscreen windowed (8 bit)"
Additional InformationI updated to Windows 10 LTSB yesterday. Some time ago, I didn't have that problem on Windows 7 Pro.
Ctrl+j = D3D11 fulscreen exclusive (10 bit)

For now (with Windows 10 LTSB installed), I can't use madVR FSE not only with PotPlayer, I also tried to use it with MPC-HC with no luck. Other renderers, such as EVR Custom, or VMR9 in both players works flawlessly in exclusive fulscreen mode with no problems.
TagsNo tags attached.
madVR Version0.92.11
Media Player (with version info)PotPlayer 1.7.8557
Splitter (with version info)LAV Splitter 0.71.0.9-git
Decoder (with version info)LAV Video Decoder 0.71.0.9-git
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modefullscreen exclusive mode
GPU ManufacturerNVidia
GPU ModelGeForce GTX 1060 3 GB
GPU Driver Version390.77
Attached Filespng file icon ScreenShot01404.png [^] (26,046 bytes) 2018-02-25 04:10

- Relationships

-  Notes
(0002234)
loco (reporter)
2018-02-25 10:34

upd: I tried to install MS Windows 10 Corporate.
madVR Fulscreen exclusive mode don't work on fresh install Windows 10 Corporate too.
(0002363)
madshi (administrator)
2018-09-15 15:45

Sorry for the late reply.

Do you have a custom DPI setting (different to 100%), maybe? Does it still occur with the latest PotPlayer build? If so, can you please create a small debug log for me, with the OSD (Ctrl+J) enabled? The debug log should just contain PotPlayer starting a video, going fullscreen, and failing to enter FSE mode. After that happened, wait 5 seconds, then close PotPlayer, zip the debug log and attached the ZIP here. Thanks.
(0002391)
loco (reporter)
2018-09-22 10:56

Hello!
I don't have custom DPI settings on 1080p Panasonic display either on Sony 4k display. The settings are 100% DPI setting for both displays.
I attached log files from both displays.
https://drive.google.com/file/d/1Kk1jt63PEqAh_TppUeGiXuiWh0GqzuCh/view?usp=sharing [^]
I use the following connection scheme:
HDMI from GTX1060 -> ONKYO TX-NR676E Receiver -> Panasonic TX-L32U20 + Sony KD-55XE9005
(0002392)
madshi (administrator)
2018-09-22 11:02
edited on: 2018-09-22 11:02

The log says this:

00004593.459 Render D3D11 fullscreen windowed (8 bit)
00004593.460 Render covered by some windows
00004593.461 Render madVR window [madVR] {0,0,1920,1080}
00004596.505 Render covered by StrokesPlus.exe window [STROKESPLUS] {0,0,1920,1080}

Sony:

00008780.233 Render D3D11 fullscreen windowed (8 bit)
00008780.233 Render covered by some windows
00008780.235 Render madVR window [madVR] {0,0,3840,2160}
00008782.797 Render covered by StrokesPlus.exe window [STROKESPLUS] {0,0,3840,2160}

So it seems that there's a StrokesPlus.exe running which has a window which is somehow in front of the madVR rendering window. In this situation entering FSE mode is not possible because madVR must be the top level window in order to enter FSE mode properly.

(0002393)
loco (reporter)
2018-09-22 12:16

Yeeeah!
Finally true 10-bit hdr playback is on my new 4k tv! Thank you a lot!!!
Thank you for the best video renderer madVR, is there any way I can donate you? I really appreciate you hard work!!!
(0002394)
madshi (administrator)
2018-09-22 12:59

Glad to hear it works now!

At the moment I'm not taking donations just yet, but I will at some point in the future. Maybe you could reserve a couple of dollars for me for the future? :)
(0002405)
loco (reporter)
2018-09-27 00:35

Hello again!
Yes, of course! I use madVR for over 5... 7 years?... Actually, I don't remember, but I really think you are a real genius! Thank you million times!
We can close this ticket, I'm happy with greatest madVR :)

- Issue History
Date Modified Username Field Change
2018-02-25 04:10 loco New Issue
2018-02-25 04:10 loco File Added: ScreenShot01404.png
2018-02-25 10:34 loco Note Added: 0002234
2018-09-15 15:45 madshi Note Added: 0002363
2018-09-15 15:45 madshi Assigned To => madshi
2018-09-15 15:45 madshi Status new => feedback
2018-09-22 10:56 loco Note Added: 0002391
2018-09-22 10:56 loco Status feedback => assigned
2018-09-22 11:02 madshi Note Added: 0002392
2018-09-22 11:02 madshi Note Edited: 0002392 View Revisions
2018-09-22 11:03 madshi Status assigned => feedback
2018-09-22 12:16 loco Note Added: 0002393
2018-09-22 12:16 loco Status feedback => assigned
2018-09-22 12:59 madshi Note Added: 0002394
2018-09-27 00:35 loco Note Added: 0002405
2018-09-27 08:55 madshi Status assigned => closed
2018-09-27 08:55 madshi Resolution open => no change required


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker