madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000544madVRbugpublic2018-03-06 01:462018-03-09 12:42
Reportersukidayo 
Assigned Tomadshi 
PriorityhighSeveritymajorReproducibilityrandom
StatusfeedbackResolutionopen 
PlatformPCOSWindowsOS Version8.1
Summary0000544: Subtitles disappear on pause when using with PotPlayer
DescriptionI do not know if this is PotPlayer bug or MadVR but subtitles disappear in randomly in 30% of cases on pause.

The bug occurs with only MadVR render not other renders.
Steps To Reproduce1. Open any video with subtitles.
2. When you see some dialoge with subtitle pause the video.
3. Because the bug occurs randomly in 30% of cases you may need play and pause many times to reproduce. Try at least 10 times.
4. After disapearing when you play again subtitles come back. But I have stopped the video because wanted to read dialoge more thoroughly and if I play again then I have no time to read it. I jump to 5 seconds back and try play it again but when I pause the video it disapears again :( I need to pause and play many times to make it showing on pause.
Additional InformationThe bug is very old (more than 2 years).

PS. I do not know if "Desktop Composition" is enabled.
TagsNo tags attached.
madVR Version0.92.12
Media Player (with version info)PotPlayer 1.7.8557
Splitter (with version info)embedded mkv splitter
Decoder (with version info)embedded FFmpeg (h264, thread frame)
DecodingSoftware
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modewindowed mode
GPU ManufacturerNVidia + Intel
GPU ModelGTX 850M + HD 4600
GPU Driver Version385.28
Attached Files

- Relationships

-  Notes
(0002238)
madshi (administrator)
2018-03-06 09:05

Using which subtitle renderer? Have you tried XySubFilter?
(0002240)
sukidayo (reporter)
2018-03-09 10:22

I did not even know there is many subtitle renderers :) Where can I see it?

Also am I right that to change it I just need install new filter and add it in the PotPlayer settings?
(0002241)
madshi (administrator)
2018-03-09 12:42

I'm not a PotPlayer expert, unfortunately, so I'm not sure how to change the subtitle renderer in PotPlayer. Is there a PotPlayer support forum somewhere, where you could ask for help about this?

AFAIK, PotPlayer's internal subtitle renderer is based on MPC-HC's internal subtitle renderer. And the MPC-HC internal subtitle renderer used to have the same problem, but it was solved in a newer MPC-HC build, I think. So I'm pretty sure this is a problem with the internal PotPlayer subtitle renderer. So replacing it with a different one is likely to solve the problem.

Alternatively you could try to ask the PotPlayer dev to look into it. Maybe he can include some of the MPC-HC subtitle renderer improvements into PotPlayer?

- Issue History
Date Modified Username Field Change
2018-03-06 01:46 sukidayo New Issue
2018-03-06 09:05 madshi Note Added: 0002238
2018-03-06 09:05 madshi Assigned To => madshi
2018-03-06 09:05 madshi Status new => feedback
2018-03-09 10:22 sukidayo Note Added: 0002240
2018-03-09 10:22 sukidayo Status feedback => assigned
2018-03-09 12:42 madshi Note Added: 0002241
2018-03-09 12:42 madshi Status assigned => feedback


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker