View Issue Details

IDProjectCategoryView StatusLast Update
0000546madVRbugpublic2019-04-17 15:39
Reportermclingo Assigned Tomadshi  
Status assignedResolutionopen 
PlatformwindowsOSwindowsOS Versionwindows 10
Summary0000546: black screen, loss of HDMI or PC crash changing from 3D mode back to 4k desktop
DescriptionWhen playing a 3D MVC movie in any player, KODI DS, MPC-HC / MPC-BE for instance, it will play perfectly fine, smooth playback even when skipping with no frame drops or skips. However when you stop the movie and the MADVR has to switch back from 1080p MVC 3D MODE it fails, you either get a black screen or on some occasions it can totally freeze you PC.
Steps To ReproducePlay movie, stop movie
Additional InformationThere are two workarounds.

1. Put your desktop in 1080p mode first before starting the movie, this way when it comes out of 3D mode it doesnt have to change resolution, this is where MADVR is falling over.

2. Use you media player to refresh rate switch instead, this works very well in KODI DS and MPC versions, however this is no use for NVIDIA card users who need to be able to set custom CRU.
TagsNo tags attached.
madVR Versionall versions I have tested, at least the last 5
Media Player (with version info)MPC-BE/HC - KODO DS
Splitter (with version info)LAV - all versions
Decoder (with version info)LAV - al versions
DecodingDXVA2 Copyback
Deinterlacingnone (progressive)
DXVA2 Scaling Activeyes
Aero / Desktop CompositionOff
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU ModelAMD RX 550 and NVIDIA GTX 1050
GPU Driver Versionall recent versions



2018-09-17 23:43

administrator   ~0002378

It seems to work fine for me. Most other users don't seem to have this problem, either, I think? Have you tried different GPU driver versions?


2018-09-18 00:15

reporter   ~0002386

ive had this problem for as long as I can remember through many driver versions but also two completely fresh PC rebuilds - and 3 different AMD cards.

could it be something to do with the way i have MADVR setup, when I use KODI DS refresh rate switching I have no problems at all, this only happens when I deploy MADVR refresh rate switching.

I used to be able to DEVCON reset to get the screen back but no i have to reboot, thats the only thing thats changed with driver versions.

Pretty sure other people have this problem to with AMD cards, thing is, there arent that many people with 3D 4K TV's so i'm not surprised this doesnt come up often on the forum.


2019-04-17 15:39

reporter   ~0002517

Hi, i've been looking at this again, its actually got worse with the latest stable version, i've had to go back to v0.92.14.

3D movies open in a small square top right hand side of screen and not full screen, I also get HDMI loss when closing movie as usual.

If I untick FSE the movie opens and plays fine but I still get HDMI loss on stopping movie.

on V0.92.14 movie opens and plays fine and when I stop the movie it drops back to GUI fine (i'm using KODI DS)

Is there any difference with how MADVR is dealing with FSE between these versions maybe?

Issue History

Date Modified Username Field Change
2018-03-11 18:18 mclingo New Issue
2018-09-17 23:43 madshi Note Added: 0002378
2018-09-17 23:43 madshi Assigned To => madshi
2018-09-17 23:43 madshi Status new => feedback
2018-09-18 00:15 mclingo Note Added: 0002386
2018-09-18 00:15 mclingo Status feedback => assigned
2019-04-17 15:39 mclingo Note Added: 0002517