madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000573madVRbugpublic2018-09-01 19:272018-09-30 19:42
ReporterFortMax 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityalways
StatusfeedbackResolutionopen 
PlatformPCOSWindows 10OS Version1803
Summary0000573: screenshots of DVD menus fail (getDIB failed,hr=80004005)
DescriptionAny attempt to take a screenshot of a DVD menu fails.
MPC-HC will freeze, and after a while it will unfreeze and give the error "getDIB failed,hr=80004005"
Steps To ReproducePlay a regular old DVD
Get to the DVD's menu.
Try to take a screencap of the menu using MPC-HC's screencap function
Additional InformationWorks fine on Mad VR 0.92.2, still broken as of 0.92.14
TagsNo tags attached.
madVR Version0.92.3 through current
Media Player (with version info)MPC-HC CCCP build 1.7.8.162
Splitter (with version info)LAV Splitter 0.65.0.5 (not active for DVD video)
Decoder (with version info)LAV Video 0.65.0.5 (not active for DVD video)
DecodingSoftware
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modewindowed mode
GPU ManufacturerAMD
GPU ModelRadeon HD 6800 series
GPU Driver Version15.201.1151.1008
Attached Files

- Relationships

-  Notes
(0002346)
madshi (administrator)
2018-09-01 19:29

Ouch, this could be complicated. DVD menus are a very special case, very different to normal video. I'll have a look at this, but it might take a while until I get to that. For now you could simply use the PrintScreen (will not work in Fullscreen Exclusive Mode, though).
(0002347)
FortMax (reporter)
2018-09-01 19:53

My current workaround is going back to 0.92.2 where it works fine.
(0002348)
madshi (administrator)
2018-09-01 19:54

Makes sense. That's the last build before all the new screenshot related functionality.
(0002431)
madshi (administrator)
2018-09-30 19:42

I've tried with a DVD sample here, and it seems to work fine for me, using v0.92.17. Can you test if you still have this problem with v0.92.17? If so, can you maybe upload a small video/DVD sample, with which I/you can reproduce the problem?

- Issue History
Date Modified Username Field Change
2018-09-01 19:27 FortMax New Issue
2018-09-01 19:29 madshi Note Added: 0002346
2018-09-01 19:53 FortMax Note Added: 0002347
2018-09-01 19:54 madshi Note Added: 0002348
2018-09-18 00:02 madshi Assigned To => madshi
2018-09-18 00:02 madshi Status new => assigned
2018-09-30 19:42 madshi Note Added: 0002431
2018-09-30 19:42 madshi Status assigned => feedback


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker