madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000576madVRbugpublic2018-09-14 16:292018-09-18 00:03
Assigned Tomadshi 
PlatformOSwin10OS Version
Summary0000576: ASS subtitles disappearing
DescriptionSubtitles disappear to early if enable smooth motion option.
For example source have 29.97fps
If we enable smooth motion and set monitor to 59.94Hz refresh rate then subtitles disappear in half of time, like in 1.5s instead of 3s. Means there is no recount for subtitles after frame rate conversion and they shown at amount of time they should be at 29.97fps, but video goes as fast as 59.94fps etc
Sorry for my bad english
Steps To Reproduce1) Use madvr with pot player
2) Open video with ass subtitles, like
Evangelion 1.11_You_Are_(Not)_Alone_(2009)_[1080p,BluRay,x264,DTS-ES].mkv (UTW-THORA release) - Actually have this bug everywhere with ass subtitles
3) Make subtitles works properly with animations etc (pot/madvr settings)
4) Play video 5 min from end, where you can easily see how long subtitles should be shown (song/karaoke), and make sure that all works fine.
5) Enable smooth motion option and see how fast subtitles disappearing now
Additional InformationThis bug presence since the smooth option added, IIRC.
I tried different windows versions, different GPUs (from both AMD and Nvidia), different players.
Problem with madvr timecodes. Something like PTS should be recounted to match new frame rate.
TagsNo tags attached.
madVR Version0.92.14 (doesnt matter which one actually)
Media Player (with version info)PotPlayer 1.7.13963 (doesn't matter too)
Splitter (with version info)PotPlayer build-in or LAV (same as above doesn't matter)
Decoder (with version info)PotPlayer build-in or LAV (and this one doesn't matter)
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU Modelgtx780, gtx980, gtx1080, r9 290x, vega64...
GPU Driver Version398.82 atm (doesn't matter)
Attached Filespng file icon nvocl.png [^] (3,632 bytes) 2018-09-14 17:05

- Relationships

-  Notes
madshi (administrator)
2018-09-14 16:41

Which subtitle renderer are you using? Not sure which PotPlayer supports. There's at least xy-vsfilter and XySubFilter, probably also a PotPlayer internal one. Does the problem occur with all subtitle renderers or only with some or only with one?
newcomer (reporter)
2018-09-14 17:07

That was crazy fast answer for bugreport.
Actually i have no idea which one im using :) But im sure i used vsfilter some time ago and after just switched to build-in from pot player.
Just now installed latest MPC-HC, run same subtitles with madvr smooth motion on and dont see a problem. No idea which one subtitle renderer used also.
So related to subtitle renderer, hm.

Please look attached file also - this happens randomly when using madvr and playback crashing. Issue occurs only with nvidia gpu, so i think as usually problem in their horrible drivers.
madshi (administrator)
2018-09-14 17:39

Does this crash also happen with MPC-HC? I don't use OpenCL, anymore, so it's unlikely to madVR's fault. Maybe PotPlayer uses OpenCL?

I'd recommend that you switch to XySubFilter, if PotPlayer supports that. The subtitle issue is *probably* a problem with the PotPlayer internal subtitle renderer, but it's hard to be 100% sure.
newcomer (reporter)
2018-09-14 17:52

This crash happens only when enable additional filtering, like NGU + artifact removal filters in madvr while also using SVP instead of madvr smooth motion and only on nvidia gpus. Maybe crash caused by SVP, but only when madvr using GPU too... What are you using for computing at GPU?
About MPC-HC no idea, i just installed it few min ago.
Also how to use external subtitle renderer with potplayer? I used vsfilter with something else like lav decoders + splitter + ffdshow etc. Not even remember how its all worked, but i remember that after i switched to internal potplayer decoders and splitters (since they fixed them and boosted performance) i got internal subtitle renderer working on subs.
thx for your great work and fast answers
madshi (administrator)
2018-09-14 18:10

I'm using DirectCompute. I believe SVP uses OpenCL. The crash is in OpenCL. Maybe you're running out of GPU RAM? You could try lowering the size of the GPU queue in madVR. Not sure if that helps, though.

I'm not very familiar with PotPlayer, don't know how to use different subtitle renderers there. In MPC-HC there's a simple drop down box to choose which subtitle renderer you want to use.
newcomer (reporter)
2018-09-14 18:34

About VRAM - no, thats not problem here.
Can you check subtitle output with potplayer (dont forget to enable subtitle animation in subtitles settings) just to see issue yourself? Maybe you will tell easy way to fix it.
newcomer (reporter)
2018-09-14 19:04

Googled about xysubfilter with potplayer - it seems external subtitle renderer can be used only via external splitters and decoders as stated here [url][/url] [^]
So i did as said :( XySubFilter show me 1st subtitles with wrong language and i cant choose the one i need (in potplayer i can easy switch them).
UPD now can, but need to go to tray, find the xysubfilter icon, go to GUI settings (not just right click) then choose and apply. And if i pause play or something and start again - need to do all the way again :(
I use potplayer for how it is easy to use with as less clicks as possible and all the build-in abilities (even support avisynth). But this way with subs is crazy...
madshi (administrator)
2018-09-14 22:04

If the problem only occurs with PotPlayer, but not with MPC-HC, then it's very likely a PotPlayer specific bug, and there won't be any way for me to fix it. You'll have to talk to the PotPlayer dev about it.
madshi (administrator)
2018-09-18 00:03

I'm closing this because it seems to be a bug in either PotPlayer or SVP, but not in madVR.

- Issue History
Date Modified Username Field Change
2018-09-14 16:29 newcomer New Issue
2018-09-14 16:41 madshi Note Added: 0002353
2018-09-14 17:05 newcomer File Added: nvocl.png
2018-09-14 17:07 newcomer Note Added: 0002354
2018-09-14 17:39 madshi Note Added: 0002355
2018-09-14 17:52 newcomer Note Added: 0002356
2018-09-14 18:10 madshi Note Added: 0002357
2018-09-14 18:34 newcomer Note Added: 0002358
2018-09-14 19:04 newcomer Note Added: 0002359
2018-09-14 22:04 madshi Note Added: 0002360
2018-09-18 00:03 madshi Note Added: 0002385
2018-09-18 00:03 madshi Status new => closed
2018-09-18 00:03 madshi Assigned To => madshi
2018-09-18 00:03 madshi Resolution open => fixed

Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker