madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000597madVRbugpublic2019-02-07 17:482019-12-06 11:38
ReporterAshkaan 
Assigned To 
PrioritylowSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformWindowsOSWindows 10 ProOS Version10
Summary0000597: OSD in MPC disappears when using MadVR
DescriptionWhether in full screen or windowed, when MadVR is running, the OSD stops displaying.
Steps To ReproduceEnsure MadVR is preferred. Play anything.
TagsNo tags attached.
madVR Version0.92.17
Media Player (with version info)MPC-HC 1.7.13
Splitter (with version info)LAV 0.70.2.1
Decoder (with version info)LAV 0.70.2.1
DecodingDXVA2 Native
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGTX 1080 Ti
GPU Driver Version417.71
Attached Fileszip file icon madshi.zip [^] (35,454 bytes) 2019-02-07 19:35

- Relationships

-  Notes
(0002475)
madshi (administrator)
2019-02-07 18:30

Which OSD do you mean exactly?
(0002476)
Ashkaan (reporter)
2019-02-07 18:31

The MPC-HTC OSD. The one that tells you the time/time remaining and the filename when you first open a file.
(0002477)
madshi (administrator)
2019-02-07 18:32

It seems to work fine for me. Is this with MPC-HC default settings?
(0002478)
Ashkaan (reporter)
2019-02-07 18:38

Yes, totally default. Admittedly, I played with some of MadVRs settings to try to get this to work, so I don't remember what default was. Here are my settings:

Checked:
delay playback start until...
delay playback start after...
enable windowed overlay...
use a separate device for presentation...

Unchecked:
enable automatic fullscreen...
disable desktop composition...
use Direct3D...
use a separate device for DXVA...

Greyed:
only when media player...
present a frame...

CPU queue size: 16
GPU queue size: 8
(0002479)
madshi (administrator)
2019-02-07 18:41

Did it ever work?

FWIW, I don't remember anyone ever reporting this issue yet. So it must be really rare/weird.

You can reset madVR settings to default by double clicking "restore default settings.bat" in the madVR folder.
(0002480)
Ashkaan (reporter)
2019-02-07 18:55

I installed MadVR with Chocolatey and the .bat file isn't in the install location.
(0002481)
madshi (administrator)
2019-02-07 18:57

Don't really know what to say. It works here. If I can't reproduce the problem, it's hard for me to do anything about it.
(0002482)
Ashkaan (reporter)
2019-02-07 18:58

With those exact settings, it's working fine?
(0002483)
Ashkaan (reporter)
2019-02-07 19:05

I'm trying to upload my settings for testing, but it won't let me. What format can I upload?
(0002484)
madshi (administrator)
2019-02-07 19:15

Try zipped.
(0002485)
Ashkaan (reporter)
2019-02-07 19:36

Nice! Zip worked. 7z didn't.
(0002486)
madshi (administrator)
2019-02-07 20:33

I tried, activating each of your 3 monitors, and it always works fine for me with your settings.

Suggestions:

1) Try downloading MPC-BE, just as a test. Same problem there?
2) Try downloading madVR and install it in a separate folder, just as a test. Does it work then?
(0002487)
Ashkaan (reporter)
2019-02-07 22:06

1) I just downloaded a portable MPC-BE with default settings, I added MadVR as preferred under external filters, and same problem.

2) I downloaded madVR portable, ran the install script, totally default, same problem (in both HC and BE).
(0002488)
madshi (administrator)
2019-02-07 22:15

I've no explanation.

FWIW, when using madVR, the MPC-HC/BE OSD is no longer drawn by MPC, but by madVR instead. Which means that it looks different. But it should still appear. At least it does for me.

Maybe try a different GPU driver? But I really have no hope for that. Nobody else has ever reported this problem, so I've no idea what's going on.
(0002489)
Ashkaan (reporter)
2019-02-09 20:07

PS: This guy has the same issue:

https://www.reddit.com/r/software/comments/25std5/mpcbe_with_madvr_no_osd/ [^]

I bet a lot of people have it, but they just don't notice. Any other ideas or leads for me to try? How does it work? Does it rely on GPU in any way?
(0002491)
madshi (administrator)
2019-02-11 15:19

I'd say we should wait for the next official madVR build (I don't have an ETA for that yet). The next build will have some changes which could change the OSD behaviour. If the problem then still occurs, we'll have to do some debugging/digging. So I'll leave this bug report open until then.
(0002492)
Ashkaan (reporter)
2019-02-11 17:02

Thank you
(0002596)
niczoom (reporter)
2019-12-06 04:15

Ok, I had madvr setup under 'External Filters' and under 'Playback\Output' was EVR (custom pres.). This setup had no OSD showing. When I removed madvr from the 'External Filters' and set it under 'Playhback\Output' the OSD now works.
(0002597)
madshi (administrator)
2019-12-06 11:38

Yes, it's recommended to set madVR under "Output", because otherwise MPC will think it renders with EVR, and thus behave differently.

- Issue History
Date Modified Username Field Change
2019-02-07 17:48 Ashkaan New Issue
2019-02-07 18:30 madshi Note Added: 0002475
2019-02-07 18:31 Ashkaan Note Added: 0002476
2019-02-07 18:32 madshi Note Added: 0002477
2019-02-07 18:38 Ashkaan Note Added: 0002478
2019-02-07 18:41 madshi Note Added: 0002479
2019-02-07 18:55 Ashkaan Note Added: 0002480
2019-02-07 18:57 madshi Note Added: 0002481
2019-02-07 18:58 Ashkaan Note Added: 0002482
2019-02-07 19:05 Ashkaan Note Added: 0002483
2019-02-07 19:15 madshi Note Added: 0002484
2019-02-07 19:35 Ashkaan File Added: madshi.zip
2019-02-07 19:36 Ashkaan Note Added: 0002485
2019-02-07 20:33 madshi Note Added: 0002486
2019-02-07 22:06 Ashkaan Note Added: 0002487
2019-02-07 22:15 madshi Note Added: 0002488
2019-02-09 20:07 Ashkaan Note Added: 0002489
2019-02-11 15:19 madshi Note Added: 0002491
2019-02-11 17:02 Ashkaan Note Added: 0002492
2019-12-06 04:09 niczoom Note Added: 0002595
2019-12-06 04:15 niczoom Note Added: 0002596
2019-12-06 04:15 niczoom Note Deleted: 0002595
2019-12-06 11:38 madshi Note Added: 0002597


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker