madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000628madVRbugpublic2019-12-07 17:552020-01-14 11:02
Reporteronur 
Assigned Tomadshi 
PrioritynormalSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
Platform32/64OSWindows 10OS Version10
Summary0000628: MadVR and LAV possible Bug
DescriptionPlaying specific files from specific resume pos is not working (black screen).
(i think when pos is short bevor keyframe everything is ok).

LAV starting from 0.71.0 is not working.
newest mpc-hc has integrated LAV 0.70.2 which is working.
EVR Renderer is working with all versions of LAV.
Steps To Reproduce1.)
mpc-be player - with prefered external filter (LAV Splitter Source and LAV Video Decoder)
https://drive.google.com/file/d/12T5jjOuCUKzfylkc_wT86iWpHT637GRw/view [^]
or
https://drive.google.com/uc?export=download&id=1PFk0HyHuFZebrNTUbctI83souI_aGTEb [^]
(load file with resume pos 01:04)

now we have a black screen.


2.)
test with source code:
First we need a Stopped Graph, with the test file Samsung Wonderland Demo.ts
Filter Graph with LAV Source and LAV Decoder and MadVR Renderer.
when we start file playing with resume pos the screens is black.

not working:
REFERENCE_TIME rtResume=640000000;
pMSeek->SetPositions(&rtResume, AM_SEEKING_AbsolutePositioning, NULL, AM_SEEKING_NoPositioning);
pMC->Run();

not working:
REFERENCE_TIME rtResume=640000000;
pMSeek->SetPositions(&rtResume, AM_SEEKING_AbsolutePositioning, NULL, AM_SEEKING_NoPositioning);
pMC->Pause();
pMC->Run();

working:
REFERENCE_TIME rtResume=640000000;
//first seek to keyframe
hr = pMSeek->SetPositions(&rtResume, AM_SEEKING_SeekToKeyFrame, NULL, AM_SEEKING_NoPositioning);
pMC->Pause();
                
//wait until Ready
__int64 endclock = GetTickCount64() + 2000;
OAFilterState pfs;
while (pMC->GetState(10, &pfs) == VFW_S_STATE_INTERMEDIATE || pfs != State_Paused)
{
   Sleep(10);
   if (GetTickCount64() > endclock)
     break;
}

//now seek to Real Pos
hr = pMSeek->SetPositions(&rtResume, AM_SEEKING_AbsolutePositioning, NULL, AM_SEEKING_NoPositioning);
TagsNo tags attached.
madVR Versionv0.92.17
Media Player (with version info)MPC-BE.1.5.4.4850.x86
Splitter (with version info)LAV starting from 0.71.0
Decoder (with version info)LAV starting from 0.71.0
DecodingDXVA2 Native
Deinterlacingauto mode
DXVA2 Scaling Activeyes
Aero / Desktop CompositionOn
Problem occurs with modewindowed mode
GPU ManufacturerIntel
GPU ModelIntel UHD 620
GPU Driver Version26.20.100.7463
Attached Fileszip file icon mpc-hc.zip [^] (4,692 bytes) 2019-12-24 14:53

- Relationships

-  Notes
(0002599)
madshi (administrator)
2019-12-10 23:15

So latest LAV doesn't work, but older LAV builds work? I guess it's a 50/50 chance that it's a bug in madVR or in LAV. Have you tried asking nevcairiel about it? If it worked in older LAV builds but not in the latest, that would suggest that some change in LAV caused this issue. But it could of course still be madVR's fault (as well).
(0002603)
onur (reporter)
2019-12-20 16:07

answer of nevcairiel:
TS files are not always perfectly seekable, its just the nature of the format - its designed for broadcast and streaming. If you need flawless seeking, remux to MP4 or MKV.

my adoption:
newer LAV with EVR, EVR-CP is working without problems.
maybe LAV Source is reporting wrong size/format on start, then switch to right format, and madVR cannot handel dynamic changes on size/format?

but you are the developer, you can debug.
(0002605)
onur (reporter)
2019-12-24 14:58

to make testing easier,
i have uploaded mpc-hc.zip which has mpc-hc.ini for mpc-hc.
you must use new version of mpc-hc from here,
https://github.com/clsid2/mpc-hc/releases [^]
because new version uses new LAV.

and you must place "Samsung Wonderland Demo.ts" in mpc-hc folder, then you can start file from fav menu.
thanks, onur
(0002606)
madshi (administrator)
2019-12-25 15:25

Thanks. Are you clsid?

I'll look into this when I find some time, but atm I'm extremely busy working on the Envy, so it could take a while... ;-(
(0002613)
onur (reporter)
2020-01-14 00:56

?clsid dont know what you mean?
its ok, look at it, when you have time.

i have another question.
Is it possible that AMT/ATI Vega Graphics can output BT2020 (Windows 10).
My Display dont reports BT2020.
i have BT2020 only if i activate HDR in Windows Settings, but then its fake BT2020 (i think) (wrong nit and..).
thanks for your work, regards, onur
(0002614)
madshi (administrator)
2020-01-14 11:02

It's a bug in the AMD driver that it doesn't report BT.2020 to the display when madVR switches the AMD into HDR mode. You can ask AMD support to fix it.

- Issue History
Date Modified Username Field Change
2019-12-07 17:55 onur New Issue
2019-12-10 23:15 madshi Note Added: 0002599
2019-12-20 16:07 onur Note Added: 0002603
2019-12-24 14:53 onur File Added: mpc-hc.zip
2019-12-24 14:58 onur Note Added: 0002605
2019-12-25 15:25 madshi Note Added: 0002606
2019-12-25 15:25 madshi Assigned To => madshi
2019-12-25 15:25 madshi Status new => assigned
2020-01-14 00:56 onur Note Added: 0002613
2020-01-14 11:02 madshi Note Added: 0002614


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker