madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000087eac3tobugpublic2013-06-11 11:222015-11-03 10:05
Reporterr0lZ 
Assigned Tomadshi 
PriorityhighSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSOS Version
Summary0000087: Failure to demux subtitle tracks from SSIF or MPLS of a 3D-BD
DescriptionWhen there are subtitle tracks in the M2TS file corresponding to the dependent view of a 3D-BD, eac3to issues a lot of "The source file seems to be damaged (discontinuity)" error messages, then fails with "The SUP reader received unknown data. Aborted at file position #."

This is probably due to the presence of two times the SAME subtitle stream in the SSIF file: one time for the base view, and one time for the dependent view.

Many 3D-BDs have no subtitle in the M2TS file corresponding to the dependent view, and in that case, eac3to has no trouble demuxing them. But when there are subtitle streams in the dependent view M2TS, it fails always.

Note: Demuxing the same subtitle stream from the base or dependent M2TS file works perfectly. The problem occurs only and always when demuxing from the SSIF (combined) file, or from the MPLS.
Steps To ReproduceDemux any subtitle track from the SSIF or MPLS file of the movie of a 3D BD with subtitle streams associated to the dependent view.

Some examples of 3D-BDs that have subtitles in the dependent view:
Avatar
Chicken Little
Hugo Cabret
Las aventuras de Tadeo Jones
Step Up
Tangled (Disney)
Toy Story 2 (Disney/Pixar)
The Lion King (Disney)
Additional InformationMore info here:
http://forum.doom9.org/showthread.php?p=1632419#post1632419 [^]
TagsNo tags attached.
eac3to Version3.27 and 3.30
Attached Files

- Relationships

-  Notes
(0000184)
madshi (administrator)
2013-06-11 11:24

Ok, I have Tangled, will see if I can reproduce it, if I find some time (can take a while).
(0000270)
Shevek (reporter)
2013-07-04 03:37

This is also happening on Shark Night 3D
(0000717)
madshi (administrator)
2015-03-10 20:18

My Blu-Rays are currently out of reach, due to being boxed up during my recent move. Is there any way you can provide a small sample?
(0001224)
madshi (administrator)
2015-11-01 14:46

Closed due to lack of reply.
(0001230)
r0lZ (reporter)
2015-11-03 10:05

Sorry, I have not been notified of your comment asking for a sample.
But finally, here it is: http://download.videohelp.com/r0lZ/tmp/DTS_HD_MAsync_bug_sample.dts [^]

It's the beginning of the file, because if I cut later, eac3to doesn't recognise the format any more. As a consequence, demuxing the subtitles from the sample produces only some discontinuity warnings, and the subtitle can be demuxed. With the full original SSIF (20.4 GB), after a lot of discontinuity warning, the demux is aborted with this message:

[...]
s07 0:26:43 The source file seems to be damaged (discontinuity).
s07 0:26:46 The source file seems to be damaged (discontinuity).
process: 47%
s07 0:26:51 The source file seems to be damaged (discontinuity).
s07 0:26:51 The source file seems to be damaged (discontinuity).
s07 The SUP reader received unknown data.
s07 0:26:55 The source file seems to be damaged (discontinuity).
Aborted at file position 10261364736.

The same problem happens with all 3DBDs containing subtitles in the M2TS of the dependent view. It's not always the case and I don't understand why some BDs (notably the Disney and Pixar BDs) include the subtitles in the dep view. As far as I know, it's totally useless.

For your information, here is the analysis of the files of the Tangled movie by eac3to:

E:\>eac3to Z:\BDMV\PLAYLIST\00004.mpls 1)
M2TS, 2 video tracks, 4 audio tracks, 5 subtitle tracks, 1:40:16, 24p /1.001
1: Chapters, 17 chapters
2: h264/AVC (left eye), 1080p24 /1.001 (16:9)
3: h264/MVC (right eye), 1080p24 /1.001 (16:9)
4: DTS Master Audio, English, 7.1 channels, 24 bits, 48kHz
   (core: DTS, 5.1 channels, 1509kbps, 48kHz)
5: AC3 Surround, English, 2.0 channels, 320kbps, 48kHz
6: AC3, Russian, 5.1 channels, 640kbps, 48kHz, dialnorm: -27dB
7: AC3, Ukrainian, 5.1 channels, 640kbps, 48kHz, dialnorm: -27dB
8: Subtitle (PGS), English
9: Subtitle (PGS), Russian
10: Subtitle (PGS), Ukrainian
11: Subtitle (PGS), Russian
12: Subtitle (PGS), Ukrainian

E:\>eac3to Z:\BDMV\STREAM\SSIF\00000.ssif
M2TS, 2 video tracks, 4 audio tracks, 5 subtitle tracks, 0:59:21, 24p /1.001
1: h264/AVC (left eye), 1080p24 /1.001 (16:9)
2: h264/MVC (right eye), 1080p24 /1.001 (16:9)
3: DTS Master Audio, 7.1 channels, 24 bits, 48kHz
   (core: DTS, 5.1 channels, 1509kbps, 48kHz)
4: AC3 Surround, 2.0 channels, 320kbps, 48kHz
5: AC3, 5.1 channels, 640kbps, 48kHz, dialnorm: -27dB
6: AC3, 5.1 channels, 640kbps, 48kHz, dialnorm: -27dB
7: Subtitle (PGS)
8: Subtitle (PGS)
9: Subtitle (PGS)
10: Subtitle (PGS)
11: Subtitle (PGS)

E:\>eac3to Z:\BDMV\STREAM\00000.m2ts
M2TS, 1 video track, 4 audio tracks, 5 subtitle tracks, 0:59:21, 24p /1.001
1: h264/AVC, 1080p24 /1.001 (16:9)
2: DTS Master Audio, English, 7.1 channels, 24 bits, 48kHz
   (core: DTS, 5.1 channels, 1509kbps, 48kHz)
3: AC3 Surround, English, 2.0 channels, 320kbps, 48kHz
4: AC3, Russian, 5.1 channels, 640kbps, 48kHz, dialnorm: -27dB
5: AC3, Ukrainian, 5.1 channels, 640kbps, 48kHz, dialnorm: -27dB
6: Subtitle (PGS), English
7: Subtitle (PGS), Russian
8: Subtitle (PGS), Ukrainian
9: Subtitle (PGS), Russian
10: Subtitle (PGS), Ukrainian

E:\>eac3to Z:\BDMV\STREAM\00001.m2ts
M2TS, 1 video track, 5 subtitle tracks, 0:59:21, 24p /1.001
1: h264/MVC (right eye), 1080p24 /1.001 (16:9)
2: Subtitle (PGS), English
3: Subtitle (PGS), Russian
4: Subtitle (PGS), Ukrainian
5: Subtitle (PGS), Russian
6: Subtitle (PGS), Ukrainian

00001.m2ts is the M2TS of the dep view. As you can see, it contains also the same subtitle streams. The stream IDs are identical. Therefore, in the SSIF, the same streams with the same ID are included two times! It's probably the cause of the problem.

Demuxing the subtitles directly from one of the two M2TS work fine, without any warning. The bug occurs only when demuxing the MPLS or SSIF.

- Issue History
Date Modified Username Field Change
2013-06-11 11:22 r0lZ New Issue
2013-06-11 11:24 madshi Note Added: 0000184
2013-06-11 11:24 madshi Assigned To => madshi
2013-06-11 11:24 madshi Status new => assigned
2013-07-04 03:37 Shevek Note Added: 0000270
2015-03-10 20:18 madshi Note Added: 0000717
2015-03-10 20:19 madshi Status assigned => feedback
2015-11-01 14:46 madshi Note Added: 0001224
2015-11-01 14:46 madshi Status feedback => closed
2015-11-01 14:46 madshi Resolution open => unable to reproduce
2015-11-03 10:05 r0lZ eac3to Version 3.27 => 3.27 and 3.30
2015-11-03 10:05 r0lZ Note Added: 0001230
2015-11-03 10:05 r0lZ Status closed => feedback
2015-11-03 10:05 r0lZ Resolution unable to reproduce => reopened


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker