View Issue Details

IDProjectCategoryView StatusLast Update
0000662madVRbugpublic2024-02-02 09:59
Reportergoraelec Assigned To 
Status newResolutionopen 
Summary0000662: non-DXVA chroma upscaling produces severe banding
DescriptionI first noticed this while using the builds from . I started getting severe banding whenever I switched to one of those builds. I tried this again today with 123b and got the same banding. This is what I did to troubleshoot:
1. Called up debug menu with Ctrl+J on 123b and noted down what I saw there
2. Reverted to the latest stable build and did the same

The first difference I noticed was that the stable build showed `chroma > DXVA` while 123b showed `chroma > Jinc AR` which is what I actually set up in `chroma upscaling`. I reverted back to the latest stable build and unchecked `use DXVA for chroma upscaling...` in `trade quality for performance` options and reproduced the same banding I saw on 123b. So there are two issues here, I think:
1. non-DXVA chroma upscaling produces severe banding
2. builds 122-123b (these are the only ones I used) don't follow `use DXVA for chroma upscaling...` settings
TagsNo tags attached.
madVR Version0.92.17
Media Player (with version info)MPC-HC
Splitter (with version info)LAV
Decoder (with version info)LAV
DecodingDXVA2 Native
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop Composition<select>
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU ModelVega Frontier Edition
GPU Driver Version20.Q4



2021-02-05 01:12

reporter   ~0002785

To add, I tried all possible options besides Jinc AR and got the same banding on all of them


2021-02-08 18:57

administrator   ~0002786

It's probably DXVA Native decoding which causes this (?). Have you tried DXVA Copyback or Software decoding?


2021-02-15 09:35

reporter   ~0002790

I don't have any banding when DVXA is turned on, actually. Copyback doesn't make a difference


2021-02-15 11:21

administrator   ~0002791

Not sure what to say, nobody else has reported a similar issue. Maybe reverting to the madVR default settings helps, by double clicking the "restore default settings.bat" batch file?


2024-02-02 09:36

reporter   ~0003096

Thank you SO much for posting this. I have been struggling with this issue on and off for MONTHS and now I can finally reproduce the issue on my PC and work around it.


2024-02-02 09:59

administrator   ~0003097

How did you work around it? Would be great if you could describe it in detail, in case other users run into the same issue in the future.

Issue History

Date Modified Username Field Change
2021-02-05 01:11 goraelec New Issue
2021-02-05 01:12 goraelec Note Added: 0002785
2021-02-08 18:57 madshi Note Added: 0002786
2021-02-15 09:35 goraelec Note Added: 0002790
2021-02-15 11:21 madshi Note Added: 0002791
2024-02-02 09:36 th3w1zard1 Note Added: 0003096
2024-02-02 09:59 madshi Note Added: 0003097