madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000193madVRbugpublic2014-04-11 16:392015-03-22 14:59
Reporterhuhn 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
Platformx64OSwindows 7OS Version7200
Summary0000193: image corruption when up and downscale it needed at the same time
Descriptionwhen a pixel shader down scaler and bilinear up scaler is used with a 1440x1080 16/9 ar source and both is needed up and downscaling then the picture gets corrupted looks like nearest neighbor is used for upscale.
Steps To Reproduceset up scaling to bilinear and downscaling to a pixel shader scaler like spline 3
open a 1440x1080p 16/9 common TV steam
scale it to 1600x900 or some way a up and a down scaler is needed.
Additional Informationthis is just a reminder madshi you said to my you can reproduce this.
TagsNo tags attached.
madVR Version87.10
Media Player (with version info)mpc-be 13.1.1 4624
Splitter (with version info)lavfilter 61.1
Decoder (with version info)lavfilter 61.1
DecodingSoftware
Deinterlacingauto mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU Modelx9 270
GPU Driver Version14.3
Attached Files

- Relationships

-  Notes
(0000594)
madshi (administrator)
2014-04-11 16:49

> you said to my you can reproduce this

That was ages ago, wasn't it? I thought that was already fixed? Does this really still occur with 87.9?
(0000595)
huhn (reporter)
2014-04-11 16:56

one more bug in the same scenario

if bilinear is used for downscaling and nearest neighbor is used for upscaling bilinear is used for both. very unusual case... i have to say

there are more bug when a texture unit and a pixel shader scaler is used at the same time but they are to hard to describe for me. i think they all have the same source.
(0000596)
huhn (reporter)
2014-04-11 17:03

> That was ages ago, wasn't it? I thought that was already fixed? Does this really still occur with 87.9?

it is see here:
spline/spline http://abload.de/img/madvrscalenobugwesry.png [^]
bilinear/spline http://abload.de/img/madvrscalebug14sh6.png [^]

and that's why i remind you
(0000604)
madshi (administrator)
2014-04-18 19:21

Should be fixed in v0.87.10. Please double check when the new build is out. If you can still reproduce the bug, please reopen this bug entry.
(0000612)
huhn (reporter)
2014-04-23 16:42

there is still a problem with this resize case:
  up down
bilinear / nearest = both bilinear or at least nearest neighbor is not used
nearest / bilinear = both bilinear or at least nearest neighbor is not used

not that important if you ask me cause nearest neighbor is not a viable choice to me. but i think it's not wrong to inform you about this. and it looks like this was added by fixing this bug at least 50 % off this.

quote:
> if bilinear is used for downscaling and nearest neighbor is used for
> upscaling bilinear is used for both. very unusual case... i have to say


looks like the bilinear up and nearest down bug was added in this version and the nearest up and bilinear down was added when the first case of this error was fixed. looks like you fixed it "only" for 1 case not both back there. of cause i'm not sure about this.

just to make things more clear nearest neighbor is used in combination with all resizer except bilinear!
(0000613)
huhn (reporter)
2014-04-23 19:42

i double checked 87.9 this version has the same error as 87.10 for both cases so this is NOT introduced in 89.10.
(0000808)
madshi (administrator)
2015-03-22 14:59

Yes, you're right, the bilinear/nearest combination doesn't work correctly. But to be honest, fixing this would make things quite a bit more complicated in my code, and I don't think it's important to fix. So I think I'll keep things as they are now, and close this bug report.

- Issue History
Date Modified Username Field Change
2014-04-11 16:39 huhn New Issue
2014-04-11 16:49 madshi Note Added: 0000594
2014-04-11 16:49 madshi Assigned To => madshi
2014-04-11 16:49 madshi Status new => feedback
2014-04-11 16:56 huhn Note Added: 0000595
2014-04-11 16:56 huhn Status feedback => assigned
2014-04-11 17:03 huhn Note Added: 0000596
2014-04-18 19:21 madshi Note Added: 0000604
2014-04-18 19:21 madshi Status assigned => closed
2014-04-18 19:21 madshi Resolution open => fixed
2014-04-23 16:42 huhn madVR Version 87.9 => 87.10
2014-04-23 16:42 huhn Note Added: 0000612
2014-04-23 16:42 huhn Status closed => feedback
2014-04-23 16:42 huhn Resolution fixed => reopened
2014-04-23 19:42 huhn Note Added: 0000613
2014-04-23 19:42 huhn Status feedback => assigned
2015-03-22 14:59 madshi Note Added: 0000808
2015-03-22 14:59 madshi Status assigned => closed
2015-03-22 14:59 madshi Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker