madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000303madVRbugpublic2015-05-18 23:152015-06-08 11:30
Reporternevcairiel 
Assigned Tomadshi 
PriorityhighSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0000303: Crash on Stop or EOF in JRiver Media Center
DescriptionmadVR crashes on EOF or when hitting Stop, maybe 0000051:0000080% of the time.
Unfortunately, the problem does not reproduce on another system.

But I did manage to get a crash report out of madVR, by copy-pasting its crash dialog. The crash submission did not work, nor did it save a crash report file anywhere that I found..
TagsNo tags attached.
madVR Version0.88.8
Media Player (with version info)JRiver Media Center 20.0.109
Splitter (with version info)LAV Splitter 0.65
Decoder (with version info)LAV Video 0.65
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelNVIDIA GTX 660
GPU Driver Version352.86
Attached Fileszip file icon crash report.zip [^] (6,939 bytes) 2015-05-18 23:15
zip file icon crash.zip [^] (7,038 bytes) 2015-06-02 16:56

- Relationships

-  Notes
(0001045)
madshi (administrator)
2015-05-18 23:24

That's extremely confusing. According to the crash report the "main thread" is finalizing madVR, and has already reached a point where the "render thread" should be over and done with. But then the crash occurs in the very "render thread" which should not exist, anymore.

I can't seem to reproduce this problem here with MC19, will have to install MC20 and check again.

Just in case I might not be able to reproduce the issue: Could you try some older madVR versions to find out which exact version introduced the problem? That would be a great help!
(0001047)
nevcairiel (reporter)
2015-05-18 23:44

All 0.88.x versions seem affected. 0.87.21 didn't crash so far.

I'll try a complete settings reset and slowly going back to my regular settings, maybe something stands out.
(0001048)
nevcairiel (reporter)
2015-05-19 01:05

Disabling 10-bit seems to have stopped the crash for now. I'll leave it like this and see if its really gone, or just random.
(0001049)
madshi (administrator)
2015-05-19 07:39

Ok, thanks. So does playback need to stop in FSE mode for the crash to occur? Or is it enough to enter FSE mode at one point during playback? Or is not even that necessary (but in theory it should, otherwise the 10bit setting should have no effect)?
(0001050)
nevcairiel (reporter)
2015-05-19 13:28

So far it looks like it only crashes when I hit stop while being in FSE mode (ie. via remote control in this case).
Exiting FSE with the mouse first seems to stop it.
(0001062)
nevcairiel (reporter)
2015-05-22 11:10

Just wanted to report that running in 8-bit has been perfectly stable for the last couple days, so thats good!
(0001063)
madshi (administrator)
2015-05-22 11:18

Ok, good to know. Hope to have some time to analyze the 10bit problem during the weekend.
(0001064)
madshi (administrator)
2015-05-26 17:38

I was able to reproduce it with MC20 and I think I fixed it. So I'll close this bug report for now. If you still have the problem with v0.88.9 (whenever that may be released), please reopen this bug report.

Thanks!
(0001069)
nevcairiel (reporter)
2015-06-02 16:56
edited on: 2015-06-02 16:57

I finally got around to testing again, and unfortunately, the problem is still present in both 0.88.9 and 0.88.10

I have attached a new crash log from 0.88.10, just in case.

(0001070)
madshi (administrator)
2015-06-02 17:53

On a quick glance it looks like a different crash, but will have a closer look later...
(0001071)
madshi (administrator)
2015-06-05 18:08

I think this should be fixed in v0.88.11. Can you confirm?
(0001072)
nevcairiel (reporter)
2015-06-05 18:32

So far so good. Usually it crashed 80% of the time, now it didn't crash in a quick test a dozen times or so. I'll leave it at 10-bit and confirm over the weekend that its not coming back!

Thanks!
(0001073)
madshi (administrator)
2015-06-05 18:37

Sounds good so far!
(0001074)
nevcairiel (reporter)
2015-06-07 16:32

Still perfectly stable after a weekend of usage!
(0001075)
madshi (administrator)
2015-06-08 11:29

Good to hear - thanks!

- Issue History
Date Modified Username Field Change
2015-05-18 23:15 nevcairiel New Issue
2015-05-18 23:15 nevcairiel File Added: crash report.zip
2015-05-18 23:24 madshi Note Added: 0001045
2015-05-18 23:24 madshi Assigned To => madshi
2015-05-18 23:24 madshi Status new => feedback
2015-05-18 23:44 nevcairiel Note Added: 0001047
2015-05-18 23:44 nevcairiel Status feedback => assigned
2015-05-19 01:05 nevcairiel Note Added: 0001048
2015-05-19 07:39 madshi Note Added: 0001049
2015-05-19 13:28 nevcairiel Note Added: 0001050
2015-05-22 11:10 nevcairiel Note Added: 0001062
2015-05-22 11:18 madshi Note Added: 0001063
2015-05-26 17:38 madshi Note Added: 0001064
2015-05-26 17:38 madshi Status assigned => closed
2015-05-26 17:38 madshi Resolution open => fixed
2015-06-02 16:56 nevcairiel Note Added: 0001069
2015-06-02 16:56 nevcairiel Status closed => feedback
2015-06-02 16:56 nevcairiel Resolution fixed => reopened
2015-06-02 16:56 nevcairiel File Added: crash.zip
2015-06-02 16:57 nevcairiel Note Edited: 0001069 View Revisions
2015-06-02 17:53 madshi Note Added: 0001070
2015-06-02 17:53 madshi Status feedback => assigned
2015-06-05 18:08 madshi Note Added: 0001071
2015-06-05 18:08 madshi Status assigned => feedback
2015-06-05 18:32 nevcairiel Note Added: 0001072
2015-06-05 18:32 nevcairiel Status feedback => assigned
2015-06-05 18:37 madshi Note Added: 0001073
2015-06-05 18:37 madshi Status assigned => feedback
2015-06-07 16:32 nevcairiel Note Added: 0001074
2015-06-07 16:32 nevcairiel Status feedback => assigned
2015-06-07 16:32 nevcairiel Status assigned => resolved
2015-06-07 16:32 nevcairiel Resolution reopened => fixed
2015-06-08 11:29 madshi Note Added: 0001075
2015-06-08 11:30 madshi Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker