madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000033madVRbugpublic2013-03-15 21:192015-03-14 14:58
Reporterturbojet 
Assigned Tomadshi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0000033: display mode changer not switching to 75hz
DescriptionWith '1680x1050p60, 1680x1050p72, 1680x1050p75' the first 2 work corrctly with 30 and 24 fps sources. With 25 fps it switches to 60 hz even if monitor is at 75 hz (74.983) reported by madvr status. Expect it to switch to 75 hz where SmoothMotion25.ytp is smooth without smoothmotion.
TagsNo tags attached.
madVR Version87.10
Media Player (with version info)mpc-hc 1.7.6
Splitter (with version info)LAV Splitter 0.62.0.0
Decoder (with version info)LAV Video Decoder 0.62.0.0
DecodingCUDA
Deinterlacingforced film mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modefullscreen exclusive mode
GPU ManufacturerNVidia
GPU ModelGTX 760
GPU Driver Versionlatest whql
Attached Fileszip file icon madVR 60-75-60.zip [^] (538,101 bytes) 2013-06-03 22:53
? file icon 25.mkv [^] (1,742,002 bytes) 2013-06-04 22:54
png file icon 25osd.PNG [^] (245,705 bytes) 2013-06-04 23:31


zip file icon madVR - log - 59.94 instead of 75.zip [^] (1,507,144 bytes) 2014-08-07 21:40

- Relationships

-  Notes
(0000048)
madshi (administrator)
2013-03-16 11:13

Please upload a short log file. Thanks.
(0000135)
turbojet (reporter)
2013-06-03 22:55

Attached a log, it includes attempting to go from 60 to 75 in the first instance. In the second display is at 75 and madvr switches to 60. 50hz works fine so I'm not really missing switching to 75.
(0000137)
madshi (administrator)
2013-06-04 09:00

According to the log, the decoder seems to claim that the source file is 50p. That's the key problem. If it were 25p or 50i, madVR should switch to 75Hz.
(0000149)
turbojet (reporter)
2013-06-04 22:59

Makes sense but why is madvr detecting it as 50p? Attached a snippet of the video that was used in the log. It happens with all 25p videos I've tried.

Also thanks for fixing the other issues I had in the latest build. On the issue about dropping frames when switching displays of different refresh rates, it no longer drops which is good but madvr osd reports composition of the first display. Should it be reporting the current displays composition rate like it does with display rate?
(0000150)
madshi (administrator)
2013-06-04 23:07

> Makes sense but why is madvr detecting it as 50p?

That's not what happens. madVR does not "detect" anything. It's the upstream DirectShow filters which report 50p to madVR.

What does the madVR OSD (Ctrl+J) report for you when playing that 25.mkv? It says "movie 25.000 fps (says source filter)" on my PC. There must be something specific to your DirectShow filter chain which results in 50.000 fps being reported to madVR. Maybe your splitter or decoder is responsible for the error. Or maybe you've LAV Video Decoder configured to deinterlace internally? If so, the output will be 50fps and that would be your fault then... ;-)

> Should it be reporting the current displays
> composition rate [...]?

It does! The problem is that the OS is using a composition rate which doesn't match the refresh rate. That's a problem with the OS, not with madVR.
(0000152)
turbojet (reporter)
2013-06-04 23:38
edited on: 2013-06-04 23:54

1. It says 25 fps, uploaded image of the OSD, maybe there's something else there. Nevermind the dropped frames or 50hz display.

2. But in the situation of switching single displays the composition rate does change while madvr osd doesn't in the current instance. Opening another instance of madvr reports it, it's just a very minor cosmetic issue. Not sure if I reported it here or not but is there a way to get multiple displays of different refresh rates to not drop frames in window mode on non-primary/extended display where the composition really is different from display? EVR doesn't handle this correctly either but overlay mixer and madvr's overlay and FSE do.

(0000154)
madshi (administrator)
2013-06-05 07:54

And in that situation where the ODS reports 25fps, madVR still doesn't switch to 75Hz? Are you sure that this is the very same thing as your log file recorded? Because (unless I've made a mistake when interpreting it) your log file seems to indicate that the OSD should have reported 50fps.

About the composition rate: That doesn't belong into this bug entry. Please reopen the other bug entry and let's continue that discussion there.
(0000161)
turbojet (reporter)
2013-06-05 22:11
edited on: 2013-06-05 22:12

It's the full video of what 25.mkv attached is from log and osd are from the full video which switches to 60 instead of 75hz.

How do I reopen a bug entry? Only seeing 13 issues, all either assigned or feedback. None of the resolved/closed issues show.

(0000164)
madshi (administrator)
2013-06-06 10:12

Ok, the situation is quite complicated but I think I figured it out now. There are 2 basic problems:

(1) It seems that your filter chain tells madVR that the source is 50p. However, madVR has a built in logic which can detect such incorrect information and auto-corrects it. This feature seems to have done its job because according to the log, madVR does handle the source as being 25p or 50i.

(2) I think you have deinterlacing set to "automatically activate when needed" and you have *not* forced film mode. Correct? With this deinterlacing setting madVR cannot be sure whether your video file might not need deinterlacing sooner or later. As a result madVR looks for a multiply of 50Hz, just to be safe. In my case madVR looks for a multiply of 25Hz because I have forced film mode.

I don't think this is a bug in madVR. If I looked for a 25Hz multiply with your settings, madVR would actually switch to a e.g. 1080p25 instead of 1080p50 for some all users with similar settings, even for content which actually needs deinterlacing. So I cannot really change this. It would break things for other users. You can solve the problem by forcing madVR into film mode. Or by adding a 1080p50 mode to the list of supported refresh rates.

You can view closed issues by clicking on "View Issues". Then modify the "Hide Status" and finally click on "Apply Filter".
(0000656)
ergoen (reporter)
2014-08-07 21:37

I am encountering the exact same issue as the original poster, 23.97, 24fps and 30 fps material plays well, but 25 fps becomes 59.94 (the lowest frame rate mode available). I have tried enabling and disabling deinterlacing.

(I will attach a log where I am deinterlacing in the decoder to film mode 25fps and forcing film mode in madvr)
(0000735)
madshi (administrator)
2015-03-14 14:58

Should be fixed in v0.87.15.

- Issue History
Date Modified Username Field Change
2013-03-15 21:19 turbojet New Issue
2013-03-16 11:13 madshi Note Added: 0000048
2013-03-16 11:13 madshi Assigned To => madshi
2013-03-16 11:13 madshi Status new => feedback
2013-06-03 22:53 turbojet File Added: madVR 60-75-60.zip
2013-06-03 22:55 turbojet Note Added: 0000135
2013-06-03 22:55 turbojet Status feedback => assigned
2013-06-04 09:00 madshi Note Added: 0000137
2013-06-04 09:00 madshi Status assigned => feedback
2013-06-04 22:54 turbojet File Added: 25.mkv
2013-06-04 22:59 turbojet Note Added: 0000149
2013-06-04 22:59 turbojet Status feedback => assigned
2013-06-04 23:07 madshi Note Added: 0000150
2013-06-04 23:07 madshi Status assigned => feedback
2013-06-04 23:31 turbojet File Added: 25osd.PNG
2013-06-04 23:38 turbojet Note Added: 0000152
2013-06-04 23:38 turbojet Status feedback => assigned
2013-06-04 23:40 turbojet Note Edited: 0000152 View Revisions
2013-06-04 23:41 turbojet Note Edited: 0000152 View Revisions
2013-06-04 23:54 turbojet Note Edited: 0000152 View Revisions
2013-06-04 23:54 turbojet Note Edited: 0000152 View Revisions
2013-06-05 07:54 madshi Note Added: 0000154
2013-06-05 07:55 madshi Status assigned => feedback
2013-06-05 22:11 turbojet Note Added: 0000161
2013-06-05 22:11 turbojet Status feedback => assigned
2013-06-05 22:12 turbojet Note Edited: 0000161 View Revisions
2013-06-06 10:12 madshi Note Added: 0000164
2013-06-06 10:12 madshi Status assigned => closed
2013-06-06 10:12 madshi Resolution open => no change required
2014-08-07 21:37 ergoen madVR Version 85.1 => 87.10
2014-08-07 21:37 ergoen Media Player (with version info) mpc-be 2259 => mpc-hc 1.7.6
2014-08-07 21:37 ergoen Splitter (with version info) mpc => LAV Splitter 0.62.0.0
2014-08-07 21:37 ergoen Decoder (with version info) ffdshow 4499 => LAV Video Decoder 0.62.0.0
2014-08-07 21:37 ergoen Decoding Software => CUDA
2014-08-07 21:37 ergoen Deinterlacing none (progressive) => forced film mode
2014-08-07 21:37 ergoen Problem occurs with mode all modes => fullscreen exclusive mode
2014-08-07 21:37 ergoen GPU Model gts250 => GTX 760
2014-08-07 21:37 ergoen Note Added: 0000656
2014-08-07 21:37 ergoen Status closed => feedback
2014-08-07 21:37 ergoen Resolution no change required => reopened
2014-08-07 21:40 ergoen File Added: madVR - log - 59.94 instead of 75.zip
2015-03-14 14:58 madshi Note Added: 0000735
2015-03-14 14:58 madshi Status feedback => closed
2015-03-14 14:58 madshi Resolution reopened => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker