madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000267madVRbugpublic2015-03-27 07:102015-03-31 20:32
ReporterArmxnian 
Assigned Tomadshi 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSWin 8.1 pro x64OS Version
Summary0000267: madvr crash
DescriptionSeeking in the video crashes madvr. Audio keeps going but picture freezes.
Steps To ReproduceSeek in the video. Seek once or multiple times. Happens sometimes and happens randomly.
TagsNo tags attached.
madVR Versionv0.87.13
Media Player (with version info)MPC-BE
Splitter (with version info)unknown
Decoder (with version info)unknown
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU Modelunknown
GPU Driver Versionunknown
Attached Fileszip file icon crash.zip [^] (3,992 bytes) 2015-03-27 07:20
? file icon crash1.mkv [^] (6,200,017 bytes) 2015-03-28 23:12
? file icon crash2.mkv [^] (8,197,587 bytes) 2015-03-28 23:16
? file icon crash3.mkv [^] (6,229,654 bytes) 2015-03-28 23:40
zip file icon report and log.zip [^] (463,327 bytes) 2015-03-31 01:43

- Relationships

-  Notes
(0000875)
madshi (administrator)
2015-03-28 22:06

I've tried about 50 times seeking, but no crash here. Any more/better tips how to reproduce it? If I can't reproduce it, it will be hard to fix.
(0000877)
Armxnian (reporter)
2015-03-28 23:27

I've uploaded 2 videos showing what happens. It's quite hard to reproduce when I'm trying but as you can see I did get it to happen. It always crashes when I actually want to use the seek, which is really annoying. So I guess you can say it happens more often when I've been watching the video for a while. The only things I use are xysubfilter, lav (cuda decoder), madvr, and the mpcbe audio renderer, so nothing fancy. I'm using artifact removal, nnedi3 32 neurons for chroma, smooth motion, error diffusion, and everything unchecked in trade quality for performance. CPU queue and GPU queue are set to 128 and 24. It's been happening for a while now.
(0000878)
Armxnian (reporter)
2015-03-28 23:37

And I uploaded the same capture just different encodes... fail. I'll upload the second example named crash3.
(0000880)
madshi (administrator)
2015-03-29 11:12

Could you please add the missing information? E.g. which GPU you're using, software/hardware decoding etc?

Have you enabled the "use alternative interop hack" in the image doubling section? If so, try disabling that. Does that make a difference?
(0000881)
Armxnian (reporter)
2015-03-29 23:35

This post did have all that information, seems like it got removed when you deleted the 3 other duplicate threads.

Currently I'm using the latest version of everything, including madvr (.13), nightly lavs, latest mpcbe build, and latest nvidia drivers. My GPU is a 750ti. The crash happens with all different versions of the software since I first started using them, so builds from as long as a year ago. Currently I'm using cuda in lav to decode, but I just tried no gpu acceleration and got it to crash on my first try. Interop hack is unchecked.
(0000882)
madshi (administrator)
2015-03-30 08:51

Weird, deleting the other duplicated should have had no effect on this one. Anyway, the bug tracker doesn't allow me to assign this bug report as long as the information isn't there. I'd have to fill in dummy information myself to be able to assign it.
(0000883)
Armxnian (reporter)
2015-03-30 09:05

Yeah I don't know what happened to the info, I'm sure it was there, because IIRC it doesn't allow you to create a thread with missing info. Can you edit fields or should I make a new thread?

I tried dxva2 copy back decoding for a movie today, seeked a couple times with no problem, but I paused and moved one frame ahead using ctrl and the right arrow and it crashed. So it has nothing to do with the decoder because it crashes with just CPU, dxva2 and cuda. Does the bug report tell you anything? I can get a new one if it might help.

I'm beginning to think it has something to do with mpcbe. I'll try mpchc tomorrow (pacific time). Only reason I switched to mpcbe was because wasapi in the mpchc audio renderer was broken and reclock for some reason now gives me static noise, but they said they are making a new renderer for mpchc.
(0000884)
madshi (administrator)
2015-03-30 09:10
edited on: 2015-03-30 09:10

I think you should be able to edit the fields? Or does it not work?

The bug report does tell me "something", I can see why it crashes, but I don't understand how madVR got into that state. I don't think it's the media player's fault. One thing that might help is if you could upload another crash report, together with a matching debug log (please zip them together, the bug tracker only accepts zip uploads). Maybe I can see what's going on then.

(0000900)
Armxnian (reporter)
2015-03-31 01:45

There are no text fields or an edit button for the initial info from what I can tell.

I uploaded the crash report and debug log. I used the video of the crash I uploaded earlier as a test. I seeked around a few times and got it to crash on my first attempt.
(0000901)
Armxnian (reporter)
2015-03-31 07:41

Tried with mpchc and still got the crash. Turned off xysubfilter and again crashed. So not the media player or any filters from what I can tell. I didn't have to try very hard on these tests, got them to crash on my first attempt to seek in the video. Hopefully you can find something as I am out of things to test.
(0000908)
madshi (administrator)
2015-03-31 20:32

I think this should be fixed in the next build. If not, please reopen this bug.

- Issue History
Date Modified Username Field Change
2015-03-27 07:10 Armxnian New Issue
2015-03-27 07:20 Armxnian File Added: crash.zip
2015-03-28 22:06 madshi Note Added: 0000875
2015-03-28 23:12 Armxnian File Added: crash1.mkv
2015-03-28 23:16 Armxnian File Added: crash2.mkv
2015-03-28 23:27 Armxnian Note Added: 0000877
2015-03-28 23:37 Armxnian Note Added: 0000878
2015-03-28 23:40 Armxnian File Added: crash3.mkv
2015-03-29 11:12 madshi Note Added: 0000880
2015-03-29 23:35 Armxnian Note Added: 0000881
2015-03-30 08:51 madshi Note Added: 0000882
2015-03-30 09:05 Armxnian Note Added: 0000883
2015-03-30 09:10 madshi Note Added: 0000884
2015-03-30 09:10 madshi Note Edited: 0000884 View Revisions
2015-03-30 09:10 madshi Note Edited: 0000884 View Revisions
2015-03-31 01:43 Armxnian File Added: report and log.zip
2015-03-31 01:45 Armxnian Note Added: 0000900
2015-03-31 07:41 Armxnian Note Added: 0000901
2015-03-31 20:32 madshi madVR Version => v0.87.13
2015-03-31 20:32 madshi Media Player (with version info) => MPC-BE
2015-03-31 20:32 madshi Splitter (with version info) => unknown
2015-03-31 20:32 madshi Decoder (with version info) => unknown
2015-03-31 20:32 madshi Decoding => Software
2015-03-31 20:32 madshi Deinterlacing => none (progressive)
2015-03-31 20:32 madshi DXVA2 Scaling Active => no
2015-03-31 20:32 madshi Aero / Desktop Composition => On
2015-03-31 20:32 madshi Problem occurs with mode => all modes
2015-03-31 20:32 madshi GPU Manufacturer => AMD
2015-03-31 20:32 madshi GPU Model => unknown
2015-03-31 20:32 madshi GPU Driver Version => unknown
2015-03-31 20:32 madshi Note Added: 0000908
2015-03-31 20:32 madshi Status new => closed
2015-03-31 20:32 madshi Assigned To => madshi
2015-03-31 20:32 madshi Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker