madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000308madVRbugpublic2015-06-09 00:412015-09-23 17:14
ReporterMS-DOS 
Assigned Tomadshi 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWin7 x64OS Version
Summary0000308: NNEDI3 bad performance without the interop hack
DescriptionNNEDI3 was working poorly without the interop hack since the release of two interop builds: https://www.doom9.org/showthread.php?p=1677698#post1677698 [^] with any possible combinations of MadVR, player and decoder settings and any videos after GPU load reaches a certain amount (around 70%).

Behavior: Various amounts of presentation glitches\dropped frames (and stuttering) depending on the video source\settings.

I've emailed you two debug logs of playing a 960x540 video, one in FSE and another one in FSW mode.
TagsNo tags attached.
madVR Version0.88.11
Media Player (with version info)MPC-HC x64 1.7.9.6
Splitter (with version info)LAV 0.65.0.16
Decoder (with version info)LAV 0.65.0.16
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerAMD
GPU Model5870
GPU Driver Version13.12, 15.5 Beta
Attached Files

- Relationships

-  Notes
(0001076)
madshi (administrator)
2015-06-09 09:10

I'm slightly confused. Why do you consider this a bug? It sure is a bug, but the bug is in the AMD drivers. Or why do you think this is a bug in madVR?
(0001077)
MS-DOS (reporter)
2015-06-09 14:41

I know there is a D3D9 <-> OpenCL interop bug on AMD. However, it's not about that bug in general, but rather about the workarounds you made for it. To be more specific, back when you removed the hack option from 0.87.15, I was the *only* person who voiced against it...
https://www.doom9.org/showthread.php?p=1715454#post1715454 [^]
...which now made me think that there was something with your first (non-hack) method which caused this particular issue on my system. I was hoping the debug logs would shed some light on it.
(0001078)
madshi (administrator)
2015-06-09 15:28

I don't know if it's specific to your PC. When I introduced the interop hack, there were some users for whom the interop hack worked well, and others for whom it didn't. I don't think there's much I can do here.
(0001170)
MS-DOS (reporter)
2015-09-23 17:09

Much or not, there apparently *was* something you could do, and you did it.
Just tested 0.89.3 and I no longer have this issue. Overall, NNEDI3 now works much faster than it did before with the interop hack.

Thank you for your work :)
(0001171)
madshi (administrator)
2015-09-23 17:12

Well, the change I did was made necessary because NVidia dropped DX9 OpenCL interop. So I had to change to DX11 OpenCL interop. That this also improved the AMD situation was just a lucky coincidence. I didn't know that doing so would improve (or solve) the interop problem. If I had known that I would done the change sooner. AMD itself has never responded to any of that. They could just have told me that the problem is limited to DX9 and to use DX11 instead, but they didn't.

Anyway, problem (seemingly) solved, thanks for letting me know, so I'll close the bug report now.

- Issue History
Date Modified Username Field Change
2015-06-09 00:41 MS-DOS New Issue
2015-06-09 09:10 madshi Note Added: 0001076
2015-06-09 09:10 madshi Assigned To => madshi
2015-06-09 09:10 madshi Status new => feedback
2015-06-09 14:41 MS-DOS Note Added: 0001077
2015-06-09 14:41 MS-DOS Status feedback => assigned
2015-06-09 15:28 madshi Note Added: 0001078
2015-06-09 15:28 madshi Status assigned => feedback
2015-09-23 17:09 MS-DOS Note Added: 0001170
2015-09-23 17:09 MS-DOS Status feedback => assigned
2015-09-23 17:12 madshi Note Added: 0001171
2015-09-23 17:14 madshi Status assigned => closed
2015-09-23 17:14 madshi Resolution open => fixed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker