madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000464madVRbugpublic2017-01-12 13:062017-01-30 11:06
Reporterkgp700 
Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformIntelOSWindowsOS Version10
Summary0000464: Deinterlace not working on Potplayer with madvr v0.90 or higher versions
DescriptionWhen playing HDTV(BDA Device), Deinterlace doesn't working

(Working fine on madvr v0.89.19)
(I tested 10 versions graphic card drivers, 10 versions potplayer versions)
Steps To ReproducePrecondition:
Installed Potplayer any version

Installed Madshi video renderer v0.90 or higer version (include newest(0.91.5) ver)

HDTV(BDA) Tunner card on the computer
(My HDTV Tunner name is SKYTV HD6 Express)

Madshi video renderer Settings:
Madshi video renderer internal deinterlace enabled

Potplayer Settings
Video Renderer : Madshi Video Render
Deinterlace : Use Hardware Deinterlacing
Hardware Deinterlacing : Auto or Force Bob

Steps :

1. Open PotPlayer
2. Right mouse button click on player
3. Open > Open Digital TV (BDA device)
TagsNo tags attached.
madVR Version0.91.5
Media Player (with version info)PotPlayer
Splitter (with version info)Potplayer internal
Decoder (with version info)Potplayer internal
DecodingSoftware
Deinterlacingforced video mode
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGTX660
GPU Driver Version376.33
Attached Filespng file icon deint.png [^] (2,749,562 bytes) 2017-01-12 14:57

- Relationships

-  Notes
(0001565)
kgp700 (reporter)
2017-01-12 13:14
edited on: 2017-01-12 13:15

H264 Codec HDTV channels fine, problem on MPEG2 HDTV Channels

(0001566)
madshi (administrator)
2017-01-12 13:49

Can you make a screenshot of the OSD (Ctrl+J), please, in the situation where deinterlacing should be active but isn't?
(0001567)
kgp700 (reporter)
2017-01-12 15:08
edited on: 2017-01-12 15:16

I attached OSD screenshot.

OSD on madvr 0.88.21
movie 29.970fps (says source filter)
deinterlacing on (says upstream)

OSD on madvr 0.91.5
movie 59.940fps (says source filter)
deinterlacing off (framerate)

When I enable automatically active deinterlacing when needed and
if in doubt, active deinterlacing, it also not working

When I playing mpeg2 ts file, working deinterlace but not on mpeg2 hdtv

(0001568)
madshi (administrator)
2017-01-12 16:25

This problem is caused by the wrong frame rate. If it really were 59.940fps *and* interlaced then after deinterlacing it would become 120fps, which makes no sense.

I'm not sure if this is a bug in madVR, it could be. It could also be a bug in the source filter which may be caused by some other different behaviour of madVR.

Unfortunately I don't have a way to reproduce this issue. But I hope if you provide the following 2 information, I might be able to tell if it's my fault or the source filter's, and then we can go from there:

1) Can you please try to find out which *exact* madVR build introduced the problem? There are many builds in between 0.88.21 and 0.91.5. I need to know which exact build broke deinterlacing, because if I know that I can compare the source code changes and maybe have an idea which change could have caused the problem.

2) Can you please zip and upload a debug log of both a working and non-working madVR build, so I can compare them?
(0001569)
kgp700 (reporter)
2017-01-12 17:23
edited on: 2017-01-12 17:50

I remember madvr v0.90 is first version of deinterlace issue version but when I try today, only appeared black screen...

so, I tested v0.90.1, 0.90.2, 0.91.5
test result was interesting.

0.90.1
29.970fps (say source filter)
deinterlacing on (says upstream)

0.90.2
59.940fps (say source filter)
deinterlacing off (framerate)

0.90.3
59.940fps (say source filter)
deinterlacing off (framerate)

0.91.5
59.940fps (say source filter)
deinterlacing off (framerate)

deinterlace worked on v0.90.1, not worked on another versions.
I attached v0.90.1, 0.90.2, 0.91.5 log files

Log files too much big, uploaded to external site mega.nz
https://mega.nz/#!1gNS2TgR!KKkN-Z9kL4fPrKmwl41EVp5RVpSeFmLlNVn65mghecg [^]

and.. I can't understand why do not working H/W Deinterlace when H/W Deinterlace(potplayer setting)+ disabled "automatically active deinterlacing when needed" on madvr setting

(If enabled "automatically active deinterlacing when needed" on madvr setting, H/W Deinterlace working correctly)

Why required madvr internal deinterlacing for active H/W Deinterlace?
This situation occurred on all of madvr versions

(0001584)
madshi (administrator)
2017-01-30 11:06

Ok, 0.90.1 and older versions detected if the decoder reported a framerate which was too high by a factor of 2 and then fixed that. That's why it worked with 0.90.1.

However, I had to remove this workaround in 0.90.2 (and newer) because LAV Video Decoder has a built in deinterlacer, so LAV reports 29.970fps in case it doesn't deinterlace and it reports 59.940fps in case it does deinterlace.

So the real problem is with your decoder. It reports an incorrect frame rate. Try using LAV Video Decoder instead, it will probably fix the issue.

- Issue History
Date Modified Username Field Change
2017-01-12 13:06 kgp700 New Issue
2017-01-12 13:14 kgp700 Note Added: 0001565
2017-01-12 13:15 kgp700 Note Edited: 0001565 View Revisions
2017-01-12 13:49 madshi Note Added: 0001566
2017-01-12 14:57 kgp700 File Added: deint.png
2017-01-12 15:08 kgp700 Note Added: 0001567
2017-01-12 15:10 kgp700 Note Edited: 0001567 View Revisions
2017-01-12 15:16 kgp700 Note Edited: 0001567 View Revisions
2017-01-12 16:25 madshi Note Added: 0001568
2017-01-12 17:23 kgp700 Note Added: 0001569
2017-01-12 17:47 kgp700 Note Edited: 0001569 View Revisions
2017-01-12 17:50 kgp700 Note Edited: 0001569 View Revisions
2017-01-30 11:06 madshi Note Added: 0001584


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker