madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000479madVRbugpublic2017-05-14 21:472018-01-21 05:44
Assigned Tomadshi 
Platformx86_64OSWindowsOS Version8.1
Summary0000479: Delay before playback starts
DescriptionSince version 0.91.0 I have a noticeable delay (more than 10 seconds) before playback starts.
With the more recent versions the audio starts with a delay of about 5 seconds, but the video still waits about 10 seconds.
Version 0.90.24, and the previous ones, don't have this issue.

This also happens after resetting madVR settings.

Some details on my configuration (apart from the OS everything else is 32-bit):

Nvidia GTX 680 with drivers 382.05

Windows 8.1 x64

MPC-HC 1.7.11
LAV Filters 0.69.0
madVR 0.91.8

This also happens with DVB Viewer Pro instead of MPC-HC.

I checked the changelog for 0.91.0 but I can't see anything that might cause this.
TagsNo tags attached.
madVR Version0.91.8 (32-bit)
Media Player (with version info)MPC-HC 1.7.11 (32-bit)
Splitter (with version info)LAV Filters 0.69.0 (32-bit)
Decoder (with version info)LAV Filters 0.69.0 (32-bit)
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOff
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGTX 680
GPU Driver Version382.05
Attached Fileszip file icon madVR - [^] (1,460,468 bytes) 2017-05-17 18:20

- Relationships

-  Notes
madshi (administrator)
2017-05-15 17:48

Can you create a debug log, zip it and attached it here?
mcn2 (reporter)
2017-05-17 18:20

Here's the log.
I closed MPC-HC when the image appeared, approximately 8 seconds in.
madshi (administrator)
2017-05-17 22:43

Hmmmm... The rendering thread seems to be stuck, but in my source code I can't find anything that would explain that. Are you 100% sure that this was introduced in v0.91.0? If you downgrade to v0.90.24 now, the problem really goes away?

Nobody else has reported a problem like this, so I wonder if it's maybe something specific to your PC. But I've no clue what it could be right now.
mcn2 (reporter)
2017-05-18 13:45

Yes, I made various tests and this problem only appears with v0.91.0 and later.

To add even more confusion I noticed that starting the Diablo III launcher fixes the problem, at least for some hours. Then it starts again.
This might happen with other applications too, I suppose.

However, as you say, I'm afraid it might very well be an issue with my PC.
After all, I'm still affected by this: [^]

Thanks for your time.
madshi (administrator)
2018-01-14 12:32

Sorry for the very late reply. Does this problem still occur with the latest builds? If so, I suppose I could make a few test builds to find out which exact change between v0.90.24 and v0.91.0 introduced the issue, if you still need this to be looked at?
mcn2 (reporter)
2018-01-16 03:45

At the moment I'm on 0.89.16, since newer versions used to often give me high CPU usage when a video gets paused (but only after some time that it has been paused).

During the week-end I'll check out the latest version and let you know.

By the way do you think that this issue: [^]
could be caused by VRAM exhaustion on the GPU?
madshi (administrator)
2018-01-16 10:24

I've no idea what causes that issue. Nobody else has ever reported a similar issue to me yet.
mcn2 (reporter)
2018-01-21 05:44

I'm still affected by this issue with 0.92.11.

When opening a file MPC-HC status bar shows 'Opening...' for about 4 seconds, then the audio starts and after approx. 8 seconds the video starts too.

Also, if I drag and drop a file on an instance of MPC-HC that already is showing a file the playback starts immediately as expected.

- Issue History
Date Modified Username Field Change
2017-05-14 21:47 mcn2 New Issue
2017-05-15 17:48 madshi Note Added: 0001643
2017-05-17 18:20 mcn2 File Added: madVR -
2017-05-17 18:20 mcn2 Note Added: 0001644
2017-05-17 22:43 madshi Note Added: 0001645
2017-05-18 13:45 mcn2 Note Added: 0001646
2018-01-14 12:32 madshi Note Added: 0002019
2018-01-14 12:32 madshi Assigned To => madshi
2018-01-14 12:32 madshi Status new => feedback
2018-01-16 03:45 mcn2 Note Added: 0002135
2018-01-16 03:45 mcn2 Status feedback => assigned
2018-01-16 10:24 madshi Note Added: 0002138
2018-01-16 10:24 madshi Status assigned => feedback
2018-01-21 05:44 mcn2 Note Added: 0002159
2018-01-21 05:44 mcn2 Status feedback => assigned

Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker