madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000523madVRbugpublic2017-11-09 09:532017-11-09 11:17
ReporterOronDF343 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSWindows 7 ProOS Version
Summary0000523: Black screen with D3D11 on dedicated GPU of switchable graphics laptop
DescriptionWhen MPC-HC is running on the dedicated GPU, if D3D11 is enabled in the madVR settings all I get is a black screen (even the OSD doesn't show up). Only by disabling D3D11 I can get the video to display.

Another setting that can cause this issue is the "use a separate device for presentation" setting. This must be disabled for there to be video, regardless of D3D11 setting.

D3D11 works when running on the integrated GPU, but performance is abysmal. Running on the dedicated GPU even without D3D11 is better, but MUCH older versions of madVR which didn't have this problem actually had better performance due to D3D11 working.
Additional InformationThe software and driver versions noted are for reference only. This issue has happened on older versions of all the mentioned since over a year ago!
TagsNo tags attached.
madVR Version0.92.8
Media Player (with version info)MPC-HC 1.7.13.112
Splitter (with version info)LAV 0.70.2.80-git
Decoder (with version info)LAV 0.70.2.80-git
DecodingSoftware
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOn
Problem occurs with modeall modes
GPU ManufacturerAMD + Intel
GPU ModelRadeon HD 8570M + HD Graphics 4400
GPU Driver Version17.30.1081-170901a-317687E-CrimsonReLive + 10.18.14.4578
Attached Files

- Relationships

-  Notes
(0001905)
madshi (administrator)
2017-11-09 09:59

> MUCH older versions of madVR which didn't have this problem

It would be very helpful to know which exact madVR build introduced the problem. Can you try to find out?
(0001908)
OronDF343 (reporter)
2017-11-09 10:42

Unfortunately, I just tried some things and I am unable to reproduce a case where D3D11 works (using v0.89.17 which I expected would work but it didn't). Maybe I am remembering wrong and I never actually had it working... Otherwise, it was an old version of LAV Filters Megamix from first half of 2016 that had worked.

Probably not a driver thing since it doesn't work with the old 16.2.1 drivers from leshcatlabs either. This issue persisted across official driver updates since then.
(0001909)
madshi (administrator)
2017-11-09 11:11

Switchable GPUs have always been highly unstable/unreliable. It could be either of the GPU drivers (AMD or Intel). Unfortunately I don't really have any idea what I could do about it.

If you activate "use a separate device for presentation", madVR uses 2 different devices and shares some resources (textures) between them. This sharing functionality isn't used by many games, which means it's a feature that some drivers have problems with. It seems to be especially problematic when using switchable GPUs.

D3D11 presentation internally also requires "use a separate device for presentation", so it has the same problems.

It's unlikely to be a madVR bug. For now there's probably nothing I can do. You could try different AMD + Intel GPU driver versions. With a bit of luck you might be able to make it work. If not, losing D3D11 support isn't *that* big of a deal. D3D9 should work just fine.

In a future version I might totally switch to D3D11 inside of madVR. If I do that, I won't require "use a separate device for presentation" for D3D11 to work, anymore. I think that will probably make madVR's D3D11 less problematic for switchable GPUs. But it might take several months until I get there. Maybe even years, I don't know...
(0001910)
OronDF343 (reporter)
2017-11-09 11:17

I see, thanks for the explanation

- Issue History
Date Modified Username Field Change
2017-11-09 09:53 OronDF343 New Issue
2017-11-09 09:59 madshi Note Added: 0001905
2017-11-09 10:42 OronDF343 Note Added: 0001908
2017-11-09 11:11 madshi Note Added: 0001909
2017-11-09 11:17 OronDF343 Note Added: 0001910


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker