madshi bug tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000083madVRbugpublic2013-06-08 16:402014-03-04 16:18
Assigned Tomadshi 
PlatformOSOS Version
Summary0000083: Could not open madVR config panel from MPC-HC
DescriptionWhen madVR is not loaded or fails to load (for example when there is no decoder available for the renderer) user cannot configure madVR settings via MPC-HC interface. The initial config panel does appear, but pressing "Edit Settings" button results in "madVR instance not found. Please make sure that your firewall doesn't block madVR" message.
Steps To Reproduce1. Make sure madVR is not loaded for current video.
2. MPC-HC -> View -> Options... -> External Filters -> Add Filter... -> select madVR from the list.
3. Double click on just added "madVR" entry. A madVR config panel should appear.
4. Click "Edit Settings" button. Message box saying "madVR instance not found" should appear.
Additional InformationI was trying out madVR's internal libav decoder and blocked LAV decoder so it won't interfere. The video loaded okay, then I tried "Intel software decoder" option -> no video, just audio. I tried to change the settings back but there is no madVR filter loaded for the video, so I went to External Filters and tried to configure it from there and got this error.
LAV, ffdshow and other codecs allow changing their settings from External Filters dialog, so I assume this is a bug.
TagsNo tags attached.
madVR Version0.86.3
Media Player (with version info)MPC-HC (a42fccd) (blitzkrieg) (master@7082)
Splitter (with version info)LAV Splitter 0.57.0
Decoder (with version info)madVR internal decoder
Deinterlacingnone (progressive)
DXVA2 Scaling Activeno
Aero / Desktop CompositionOff
Problem occurs with modeall modes
GPU ManufacturerNVidia
GPU ModelGeForce 8800 GTS (320 MB)
GPU Driver Version6.14.0013.2018
Attached Files

- Relationships

-  Notes
madshi (administrator)
2013-06-11 10:01

Well, yes, I guess you could consider this a bug. Normally, this madVR property dialog is only shown when a video is playing. And in that situation the problem does not occur. MPC-HC showing the madVR property without a video playing isn't really something I expected.

I'll fix this sooner or later, but it might take a while because I don't consider it very important, and a fix isn't that trivial.

The Intel software decoder only works if you manually download the Intel decoder dll. See first post of the madVR doom9 forum thread for a download link.
Danat (reporter)
2013-06-11 13:14

Yeah thats a minor issue. Just would be nice to have it resolved one day ;).

"See first post of the madVR doom9 forum thread for a download link."
omg I didn't see it all this time and even after you said it's there I've hardly noticed it ;). Thanks. I guess the "SDK Software" part confused me since I dont need that.
madshi (administrator)
2014-03-04 16:18

This should be "fixed" as of v0.87.4 and newer.

- Issue History
Date Modified Username Field Change
2013-06-08 16:40 Danat New Issue
2013-06-11 10:01 madshi Note Added: 0000180
2013-06-11 10:01 madshi Assigned To => madshi
2013-06-11 10:01 madshi Status new => acknowledged
2013-06-11 13:14 Danat Note Added: 0000191
2014-03-04 16:18 madshi Note Added: 0000440
2014-03-04 16:18 madshi Status acknowledged => closed
2014-03-04 16:18 madshi Resolution open => fixed

Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker